Problems with playing Quicktime movies

Hi all.

I tried to play Quicktime movie trailers on the site Apple - Movie Trailers, first using VLC, then using MPlayer and last Kaffeine (all Firefox plugins that is). They all failed. Then I installed Totem and it worked like a charm. Why?

First, this is what I use; openSUSE 11.1, KDE 4.2, Firefox 3.5.

Maybe I should begin with saying that I have followed the “ten steps guide” to verify all my video packages. I know I shouldn’t just say that without posting the result here to prove it but I have a feeling I won’t have to when I have explained my problems. I’ll just say that all relevant packages comes from Packman. And I have libquicktime0 installed (also from Packman).

As I said, I started going through VLC, MPlayer and Kaffeine (their Firefox plugins that is). Kaffeine didn’t even register a mime type for Quicktime in Firefox so when clicking a Quicktime movie link I just got a message from the site to install Quicktime.

Using VLC (from Packman, and removing Kaffeine) resulted in the same message on the site to install a Quicktime player. VLC did have a plugin registered in Firefox for Quicktime but this did not help.

Removing VLC and installing MPlayer got me a bit further, now a popup window opens in the browser that says “waiting for video” or something like that. But nothing more happens.

I tried VLC and MPlayer using the MediaPlayerConnectivity plugin in Firefox. Then I could get both players to start; VLC with very poor sound (intermediate gaps) and MPlayer with an error message “Couldn’t resolve name for AF_INET6:”.

I then remembered a friend using Ubuntu who didn’t have any problems what so ever watching Quicktime movies on Apple - Movie Trailers. So I installed the latest Ubuntu into a VirtualBox machine, fired up Firefox (3.0) and went to Apple - Movie Trailers. Clicking a Quicktime movie link resulted in a dialog offering me to install codecs, when this was done I could play Quicktime movies without any errors and with excellent quality.

So it got me thinking. Ubuntu and gnome uses Totem. I removed all of my players and installed Totem, went to Apple - Movie Trailers, clicked a Quicktime movie link and suddenly i can play Quicktime movies without any problems what so ever.

This really annoys me. Totem is a gnome media player. I don’t want to use it. But now I have to since none of my “ordinary” (KDE) players can handle Quicktime on the web. Does anybody know how to fix this? What does Totem do differently from Kaffeine, VLC or MPlayer?

I installed all quicktime files. No result. Since Apple - Movie Trailers works on my main machine and it didn’t on my laptop, I looked for differences and found that mplayerplug-in was not installed on the laptop. Installed it and now Apple - Movie Trailers works flawlessly.

Hope this helps you out.

Congratulations on sorting this, and glad to read it works for you. I’ve been a user of mplayerplug-in for most of the time that I have been a SuSE/openSUSE user.

Thanks for sharing your solution.

Knurpht, are your systems 32 or 64 bit? Mine are 32 bit. I’m pretty shure that when a tried this with MPlayer I had the plugin installed and it didn’t work. I will verify this on my laptop as soon as I can. Thanks for the input.

It didn`t worked for me, when I try to play a quicktime movie in the apple web site in firefox it crash and close, no matter what plugings are installed, in konkeror too, so what I do is download the video with wget and play it locally, not the solution but at least is a way to see the trailers.

I have tried the mplayer plugin on my laptop now. I had no other video players installed but MPlayer when I did this. Clicking a Quicktime movie link results in Firefox crashing. I then removed all MPlayer stuff including the plugin, and installed Totem and its plugin instead. Now I have no problem waching Quicktime movies on the net, no errors and good quality audio.

libquicktime is present in to versions; one libquicktime from openSUSE repos and one libquicktime0 from Pacman. They both provide so which one should I use? I noticed that on my laptop I had libquicktime from openSUSE and on my stationary machine I had libquicktime0 from Pacman. On my laptop Firefox crached, it might be related to libquicktime from openSUSE.

I’ve seen a number of different scenarios when trying to play Quicktime movies. The only working one is using Totem (which I do not want to do since I’m using KDE42). All others (Kaffeine, VLC and MPlayer) either do not work at all or work poorly or simply craches.