Problems with OpenSUSE and FCoE

I’ve been trying to get ECoE going on OpenSuse 11.2 with Kernel

I’ve gotten the open-fcoe on the 1-click from the OpenSUSE site. It installs but doesn’t run.

I’ve also tried the builds through the and built them on my system. They also don’t work for me.

I have the libhbalinux and hbaapi_build.

I’m trying to setup and run ECoE on standard ethernet NICs, which I believe can be done and I’ve tried following the QUICKSTART guided to build and setup initiator and target, but things don’t seem to be working; the fcoemod tells me that the fcoe driver may not be loaded, but it appears to be. I’ve tried rmmod fceo and then a new insmod fcoe, but still get the same result.

Here are the driver I have loaded and the problems I’m running into:

/etc/fcoe # lsmod
Module Size Used by
nls_iso8859_1 5960 0
nls_cp437 7656 0
vfat 15240 0
fat 67992 1 vfat
fcoe 27968 0
openfctgt 163460 1 fcoe
8021q 32448 0
garp 11592 1 8021q
stp 3628 1 garp
llc 9040 2 garp,stp
scst 423680 1 openfctgt
edd 12848 0
af_packet 27816 4
fuse 84336 3
loop 21716 0
dm_mod 98088 0
iTCO_wdt 14896 0
iTCO_vendor_support 5228 1 iTCO_wdt
sr_mod 20804 0
celerity8fc 435900 0
cdrom 44808 1 sr_mod
pcspkr 4008 0
sg 39648 0
e1000 146412 0
scsi_transport_fc 64300 1 celerity8fc
e1000e 162616 0
i2c_i801 13960 0
button 8520 0

~/trunk/fc # cd /etc/fcoe/

/etc/fcoe # cp cfg-ethx cfg-eth7

/etc/fcoe # service lldpad start
Starting lldpad: done

/etc/fcoe # dcbtool -v
dcbtool v0.9.32

/etc/fcoe # dcbtool sc eth7 dcb on
Version: 2
Command: Set Config
Feature: DCB State
Port: eth7
Status: Failed

/etc/fcoe # dcbtool sc eth7 pfc e:1
Version: 2
Command: Set Config
Feature: Priority Flow Control
Port: eth7
Status: Device not found, link down or DCB not enabled

/etc/fcoe # dcbtool sc eth7 app:fcoe e:1
Version: 2
Command: Set Config
Feature: Application FCoE
Port: eth7
Status: Device not found, link down or DCB not enabled
5dev:/etc/fcoe # service fcoe start
Starting FCoE initiator service: failed

/etc/fcoe # fcoemon -f
fcoemon: fcoemon: error 2 (null)
fcoemon: make sure FCoE driver module is loaded!

Can anyone tell me what I’m doing wrong or point me to some documentation that will tell me how to establish an FCoE connection for a point to point?

Did you ever solved this issue??? I have exactly the same problem on a RH system and not even RH support can help me…


On 08/03/2012 07:26 AM, cbulleri wrote:
> Did you ever solved this issue???

his question is a couple of years old and over 500 times it was
viewed…with no one helping…

so, i’d guess s/he does not come everyday to see if there is an answer

my point: s/he may never see your question here, so i’d recommend you
try to contact through a Private Message…maybe the account is set
up to forward PMs to an email address…

good luck…