Problems with OpenSuse 11.4 boot


First of all thanks for all the work that you all do helping us in this kind of situations.

Well, my problem is that i just install opensuse in a HP Pavilion DV7-4285DX, until that everything was ok, but after the reboot, i choose opensuse (i have windows 7 also), and it’s begins to load with the logo and loading bar, and after two or three seconds of loading, the loading bar crashes and the screen goes black, and stays like that.
I’m guessing that it could be a problem with the video graphics ATI Mobility Radeon HD 6370 s, but before i install OpenSuse, i had Fedora installed in that partition, so i’m kind of lost.
Another interesting thing it’s that if i choose failsafe mode, it works, but the resolution it’s 640x480…

So if you could help me in any way to solve this, or if you need more information about the problem, i’ll be waiting

How did Fedora work with graphics?

I do not know your knowledge level for openSUSE graphics. So first some basics. The graphics drivers that may work on Radeon HD driver, from the most primitive to the highest performance tend to be :

  • fbdev
  • open source. poorest performance, and highest compatibility - likely the driver which was used during the openSUSE install - vesa
  • open source. better performance and reasonable compatibility - radeonhd
  • open source. support is being stopped but still works with older AMD graphics cards. Better performance than fbdev or vesa. - radeon
  • open source. active support. better performance than fbdev, vesa or radeonhd. Should work in most AMD hardware (except very latest). Typically the driver that is loaded upon 1st reboot after an openSUSE install when AMD graphic hardware is on the PC - fglrx
  • proprietary AMD Catalyst graphic driver. highest performance. sensitive to (can be broken by) kernel updates. Best chance for functionality with newest AMD hardware. Can be a bit more tricky to install for new users

When I type “man radeonhd” and “man radeon” on my openSUSE, I obtain lists as to what hardware the radeonhd and radeon drivers work with. There is no mention of the HD 6370 in either the ‘radeonhd’ nor the ‘radeon’ man pages. The ‘radeon’ does mention

PALM Radeon HD 6310/6250

but that is not your hardware.

Probably you need the latest 11.8 Catalyst driver (just released today) : ATI Catalyst™ Proprietary Display Driver

I recommend you initially boot to using the basic ‘fbdev’ graphic driver until you can advance to a more capable graphic driver.

Thats not surprising. It means the ‘fbdev’ driver works. Booting with ‘failsafe’ boots with the fbdev graphic driver.

Boot your PC, and in the very first boot selection menu, start typing ‘x11failsafe’ (that is X eleven failsafe - one word) such that ‘x11failsafe’ appears in the options line (no quotes) of the menu, and then see if you can boot to X window. That will not be as restrictive as ‘FailSafe’. If that fails, try again the ‘FailSafe’ Settings.

Once you are in X you can try to switch to using the Vesa driver by editing the /etc/X11/xorg.conf.d/50-device.conf file by changing it with root permissions to :

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "vesa"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


and reboot and test. See if that works. If not, simply boot again with the fbdev graphic driver (fail x11failsafe or FailSafe). You could also try ‘radeon’ instead of ‘vesa’ but IMHO ‘radeon’ does not yet provide support for your hardware.

Ultimately, you probably need to try the proprietary AMD Catalyst driver: ATI Catalyst™ Proprietary Display Driver

There is guidance here (NOTE - I use a different method myself, but its a bear to type out and explain how I do this) : SDB:ATI drivers - openSUSE

BUT I know with older versions of the AMD Catalyst drivers, a user had problem with a 6730M : Radeon HD 6xxxxM driver problems… … that was 6 weeks ago, so maybe things are better now.

thanks, this information has been really helpful, i tried x11failsafe and i could enter, i change to vesa driver, but it didn’t work, then i try with ATI Catalyst, but that didn’t work.
I think that my problem is more complicated than what i think it is, because i have dual video card, an integrated intel , and the other card that i’ve already mention.
well, as i already said, i really appreciate your effort, so thanks for all, i’m going to keep trying if a found a way to fix it, i’ll tell you :wink:

Indeed it is EXTREMELY important to know that your PC has hybrid graphics. A lot of what I spent the time typing is not relevant and in future I recommend when looking for graphic support with this hardware I recommend you mention that your PC has hybrid graphics in your first post, so as to avoid users wasting their time in typing non-relevant information.

We really need someone in openSUSE who has mastered the hybrid graphics issue to write a good guide, but thus far we have not had this happen.

Some speculation:


I have read you may be able to disable the radeon graphics (but keep the intel functional) by using the boot code:


and then maybe in the /etc/X11/xorg.conf.d/50-device.conf file also specify ‘intel’ when booting with that boot code. ie

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "intel"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"



You may also find it necessary to disable either graphic device in BIOS. I’ve read in some BIOS/chipsets, for dual intel/amd hardware:
[li]For intel, set graphics controller to “Switchable” in BIOS[/li][li]For ATI, set graphics controller to “Discrete” in BIOS[/li][/ul]

There is also an application known as 'vgaswitcheroo (nvidia/intel hybyid users need to try bumblee) and that is being developed to try and help in this case of hybrid graphics.

I have read for ATI/intel hybrid:
[li]The PowerXpress pre-4.0 models have a mux solution to switch between discrete and integrated card.[/li][li]For most ATI/Intel hybrid configurations:[/li]a) try the latest closed-source Catalyst Driver for login/logout card switching, or
b) try vga_switcheroo and open-source graphics drivers (kernel 2.6.35 or newer).
[li]The PowerXpress 4.0+ models have a muxless solution to use both cards and switch on/off the discrete card.[/li][li]For Muxless PowerXpress 4.0+ models, please submit your DSDT tables information as described here: Linux Hybrid Graphics[/li][/ul]
but I do not know what applies to you there. Definitely try:
[li]a) try the latest closed-source Catalyst Driver for login/logout card switching, or[/li][li]b) try vga_switcheroo and open-source graphics drivers (kernel 2.6.35 or newer).[/li][/ul]

Some links (but you likely will be able to find some newer ones) :
[li]Switchable graphics - how do I disable one of the video drivers?[/li][li]I have a problem with switchable graphics laptop[/li][li]Linux Hybrid Graphics[/li][li]Linux Hybrid Graphics: More Bumblebee updates – automatic switching with acpi_call[/li][li]Vga switcheroo - Gentoo Linux Wiki[/li][li]airlied: hybrid graphics on Linux[/li][li][/li][li][Phoronix] A Day Later, Hybrid Graphics On Linux Does More[/li][li][Phoronix] First Came VGA Switcheroo, Now Comes ASUS Switcheroo[/li][/ul]

… and there are likely many newer threads. I stopped collecting links as I don’t have this hardware, and I decided it was inefficient time wise for me to do so. Someone who ACTUALLY has the hardware needs to sort this and create a guide. Not someone who does not have the hardware.

I am going to move back to ‘lurk only status’ and I will not likely respond to any more posts on this thread, because technically I do not know anything about hybrid graphics, having no experience.

Good luck in your efforts.