Problems with OpenGL and ATI Mobility HD 3430

I am new to linux and I just installed Opensuse 11.2 for the first time the other day. When I tried to change the screensaver to an OpenGL screen saver it would freeze. So I downloaded the latest driver from ATI and installed it. Then my mouse cursor disappeared, but I was able to fix that by adding Option “SWcursor” to xorg.conf file. However OpenGL still does not work. When I run glxgears i get the following.

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 15
Current serial number in output stream: 15

My /var/log/Xorg.0.log file has this line in it.

(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.

When I run # ** **it says that Package kernel-source needs to be installed, but when I do sudo zypper in kernel-source it says it is already installed.

I have tried uninstalling and reinstalling the driver using every different method I could find on the forums but no joy.

Can anybody help me? I am starting think about going back to Windows.

You have to get the version right. What is the output of :

rpm -qa '*kernel*'

Most of my friends, who are smart people, use Windows. If you prefer Windows, then use it. Your frustration is understandable, but IMHO best to keep those views to yourself as it will not make 1 bit difference in the support provided. … I won’t discourage anyone from returning to an operating system used by a significant majority of the people in the world. Like I said, most of my friends use MS-Windows (or MacIntosh) and they are smart people.


Thanks for the help.

You have 2 kernels. kernel-desktop and kernel-xen. IMHO that is causing you problems. I believe one can only build the driver against one kernel at a time. Plus the kernel-desktop version is “out of whack” with the rest (different version)

ok so I did sudo zypper in kernel-desktop and updated the kernel-desktop then I was able to do then ran aticonfig --initial rebooted and now it works. Thank you so much for your help.

Congratulations. Glad to read you had success. Well done in your determination to solve this.