Problems with Nvidia drivers in OpensSUSE 11.1

Hello

I have installed OpenSUSE 11.1 (32bit) in my computer and I’m suffering some graphics corruption and even hang ups within KDE 4 after installing the Nvidia drivers in X.

I did the installation from Yast connecting to http://download.nvidia.com/opensuse/11.1 (URL that I guessed from the Nvidia drivers documentation here: Nvidia Installer HOWTO for SUSE LINUX users) and it automatically selected the G02 (for 6xxx series and up) & pam versions of the 177.82 drivers for my GeForce 7600GS. Then executed “sax2 -r”

I noted three different versions of these drivers: pam, standard and trace. Could it be the problem? What is the difference between them? How can I check with one is the right one for my kernel?

I have found here the list of drivers:
ftp://download.nvidia.com/opensuse/11.1/i586/

My computer is:
Asus P4P800-SE (Intel 865PE/ICH5R)
Pentium4 3.0/400 Presscott HT
2Gb DDR400 in dual channel
Club3D Nvidia GeForce 7600GS 256Mb GDDR2

Thank you, very much for your help
Óscar

Well, I have tried this:

  • 177.82 and the new 180.22 drivers from Yast.
  • Legacy drivers from Yast but they won’t support my 7600GS.
  • Most drivers from Nvidia site, but only the last 180.22 will compile correctly.
  • Deactivate AGP in Xorg.conf
  • Many Nvidia options in Xorg.conf that I have read in this forum
  • Two kernels: pae & standard
  • KDE with and w/o desktop effects
  • Gnome desktop

Nothing solved my problems: some graphical corruption (seen in KDE), text consoles going blank (Alt-F1 to Alt-F6) and hang ups.

I am out of ideas…