Problems with New AMD RX 460 Gpu on Leap 42.2

This system is upgraded from 42.1 where fglrx was being used - to Leap 42.2. The old graphics card has recently been replaced with the RX460, a budget AMD gpu. The fglrx driver has been removed - as far as I know. However I am forced back to Vesa at the moment. I tried and tried to get ampgpu going but it kept complaining of no devices available. Also tried creating xorg.conf without success.

Kernel is 4.4.36-5-default now as I have been upgrading along he way.

Not sure where to go with this one. I see the pro driver is coming available. Does this require a special kernel? or could I install with this one?

/sbin/lspci -nnk | grep -A3 VGA
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:67ef] (rev cf)
Subsystem: ASUSTeK Computer Inc. Device [1043:04b4]
02:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:aae0]
Subsystem: ASUSTeK Computer Inc. Device [1043:aae0]

Hi
Too new for the 4.4 kernel…

You could try the driver from here;
http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx

You need dkms driver installed (have it built here for the moment);
http://download.opensuse.org/repositories/home:/malcolmlewis:/AMDgpu/openSUSE_Leap_42.2_Update/noarch/

Then just extract the downloaded AMDgpu-pro tarball and run the installer as root user from a terminal;


./amdgpu-pro-install

Thanks - using this guide I have amdgpu up and running. It did not happen automatically in my case. I had to edit 50-device.conf and insert amdgpu as the driver.
Currently experiencing frequent “tearing” across the screen - still working on a resolution to this.

On Wed 14 Dec 2016 07:56:01 PM CST, cabernet wrote:

Thanks - using this guide I have amdgpu up and running. It did not
happen automatically in my case. I had to edit 50-device.conf and insert
amdgpu as the driver.
Currently experiencing frequent “tearing” across the screen - still
working on a resolution to this.

Hi
If you remove your edit and the add a 20-amdgpu.conf file containing;


Section "Device"
Identifier "AMD Graphics Core Next GPU"
Driver "amdgpu"
Option "DRI" "3"
Option "TearFree" "true"
EndSection

See how that goes (it’s what I use for my R5 card).


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hmmm - not working here. Still going on this one. The desktop is functional as it is but compromised by frequent lines across the screen.

Hi
You might need to start looking at what other options can be used in the 20-amdgpu.conf file, then if you check the kernel module parameters you may need to look at creating a /etc/modprobe.d/50-amdgpu.conf and add those options there;

The following will show what are available and the second command as to what they are set too;


/sbin/modinfo amdgpu | grep parm

/usr/bin/systool -vm amdgpu

Success ! Yay - don’t ask me to explain the details, but tearing has now stopped. It may have come about after the most recent packagekitd updates (151216). After rebooting, tearing was absent.

Many thanks for help in resolving this.

Hi
Maybe the latest kernel update? Good to know it’s all working now :slight_smile: