Problems with native Steam

I have openSUSE 13.1 upgraded from 12.3 with Gnome-Shell 3.10 and kernel-desktop 3.12.2 from Kernel:Stable repo.
My PC specs is: Intel Core i5-3570k, Geforce GTX 660 and 8GB of RAM.

After upgrading i started to have weird problems with native Steam.
Some games (Metro: Last Light, Worms Reloaded, Natural Selection 2) crashes when i’m launching them from Steam client (by pressing Play button).
But this games working fine when i’m shutting down Steam and launching game from desktop launcher, after that Steam starts and this games can be launched from client directly.
Also, if i launching Steam client from sh file (~/.local/share/Steam/steam.sh) this games works normally, but if client started on boot or from terminal, everything is broken again.
I created bug report in Steam Github repo and devs said that something is interfering with signals from steam and i need to try and find out what that is.

Any help much appreciated.

Have been having a similar problem with Natural Selection 2. I will hit play and it will just freeze on the initial loading screen.

Start steam from the command line by typing steam in a console.

If you start steam from the command line, you can after steam has started, just start the game by clicking on the play button, but don’t close the console.

Look for errors and post the output here.

On 12/11/2013 08:36 AM, Gps2010 wrote:
>
> Start steam from the command line by typing steam in a console.
>
>
> If you start steam from the command line, you can after steam has
> started, just start the game by clicking on the play button, but don’t
> close the console.
>
> Look for errors and post the output here.

Do it something like this so that steam will run as a background process
and log all the information it spews out into a file.


steam &> steam-log &

Then just copy paste the file to http://paste.opensuse.org/
Refer to this if you dont know about I/O redirection: http://www.tldp.org/LDP/intro-linux/html/sect_05_01.html


Was I helpful? Click that little star so that I can brag about it to my
invisible friends >:)
Bring the Penguins Back! https://features.opensuse.org/316767

Are you using the Nvidia 331.20 driver? There is a definite problem with signals in that version; see here(and the links therein). Nvidia has acknowledged there is a problem, and hopefully will provide a new driver.

$ killall pulse-audio

restart game,
profit

I upgraded kernel to 3.13 and nvidia driver to 334.16 and problem still exist. I also tried to install older drivers but Xorg crashes after that.

Older drivers might not work with Kernel 3.13 or the Xorg included in openSUSE (depending on which version exactly you tried to install).
But why 334.16? That’s a beta version. The latest stable version is 331.49.
And the signal problem should already be fixed in that version.

And is there any specific reason for using kernel 3.12/3.13?
If you downgrade to the included 3.11.10 version, you could even use the nvidia driver from the official repo, which should rule out quite a few possible causes for problems (like forgetting to reinstall the driver after a kernel/Xorg/Mesa update :wink: ).

I tried 331.49, Xorg cannot start with it. Also i used previous versions of drivers before and that bug still presents.
I found reports that this bug appears after upgrading openSUSE from 12.3 to 13.1 and the fix is OS reinstall. I do not want to do it.

Latest kernels are better because they have many stability fixes and improvements.
I prefer to use latest versions of software. Also, i’m using dkms for additional kernel modules so no need to reinstall driver and other stuff.

Well, I haven’t tried 331.49 in particular, but I would find that strange.
Have you maybe updated Xorg to the latest version as well?

I found reports that this bug appears after upgrading openSUSE from 12.3 to 13.1 and the fix is OS reinstall. I do not want to do it.

Which bug? The steam problem?
I don’t see how an OS reinstall would help here.

If it really would, there must be a different way to fix this as well. Like installing/uninstalling some particular packages, changing some configuration, enabling/disabling certain system services.

Latest kernels are better because they have many stability fixes and improvements.

Well, yes, but they might break stuff like the nvidia driver.

I prefer to use latest versions of software. Also, i’m using dkms for additional kernel modules so no need to reinstall driver and other stuff.

Ok, just be aware of the fact that updates to xorg-x11-server and Mesa-libGL1 will break your nvidia driver installation despite of dkms.

I have no idea about your actual steam problem though, sorry.
As I said, that nvidia driver signal problem that Gps2010 referred to has been fixed in version 331.38 already.

I also found reports that this problem may be related to glibc. openSUSE 12.3 has 2.17 and 13.1 has 2.18.

I use 13.1 and have absolutely no problems with Steam. Just remember to edit /usr/bin/steam and set the default audio to alsa, so that you have audio working on all games.

On /usr/bin/steam, edit it and paste the following, right on the first free space:

export SDL_AUDIODRIVER=alsa

Regarding other problems, start steam from a terminal and past the contents here and on the Steam for Linux forums: http://steamcommunity.com/app/221410/discussions/

Same issue here with radeon opensource drivers, but amarildojr’s code fixed the issue!
Thanks.

Glad I helped! lol!

I filed a request to update Mesa 3D driver from 9.2 to 10.x in Tumbleweed here:

https://features.opensuse.org/317173
**
please vote up to make it happen!**

It could reduce all kind of desktop-effect and gaming issues.

My understanding is that tumbleweed follows the factory development path so until Mesa is upgraded there I’d say there is little hope for tumbleweed.

Did a recent update upgrade libgnutls.so.26 to 28?

Steam installed week or two ago and ran fine. Today I get:

Running Steam on opensuse 13.1 64-bit
STEAM_RUNTIME is enabled automatically
Error: You are missing the following 32-bit libraries, and Steam may not run:
libgnutls.so.26

I can’t find that version anywhere anymore?

Any ideas how I can get steam to work again?

Thanks!

No, that would be against openSUSE’s update policy.
And also every other package that depends on libgnutls would have had to be rebuilt and released as update as well.

In fact, openSUSE 13.1 already shipped with libgnutls28 when it was released.

I can’t find that version anywhere anymore?

It’s not available anywhere.
You definitely didn’t have this installed as an openSUSE package.

If you had it, it must have been included in steam, I’d say.

Any ideas how I can get steam to work again?

Hm. Maybe try to run it like this?

STEAM_RUNTIME=1 steam

Thx. That fixed Metro LL no sound issue. rotfl!

Late reply, apologies. The laptop is not my main pc and I sort of forgot this wasn’t working until my son pointed it out again :P.

Anyway. I’m still having this. I removed Steam (zypper rm steam) and installed it again but it didn’t change anything. I also removed the .steam folder and files from the profile, doesn’t help either.

Any other ideas anyone?

Thanks!