problems with my webcam

i have an inbuilt webcam on my laptop but problem is am not sure its drivers are installed coz it even listed among my hardware when i use yast2 to look it up!!when i run the /sbin/lspci command,a list of hardware is given but am not sure whether my webcam is what is reffered to as “intergrated graphics controller” on 00:02.1!!when i run /sbin/lspci -n,i get 00:02.1 0380: 8086:2a03 (rev 0c)!!what do i do to get my webcam working!!thanx

The device you are seeing is not your webcam, that’s your integrated graphics (an intel chip).

First, please tell us the model number and brand of your computer, and before anything else, check to see if the webcam actually works.

in X, type Alt+F2, and in the window that pops up, type “cheese”
This is a webcam app. if after about 5-10 seconds your webcam shows up, congrats! You don’t need our help.
Otherwise, post the info requested and wait for another response.

Its more common to have a usb webcam than a PCI based web cam. Ensure you have usbutils installed, and then try lsusb

If you did wish to look at a list of your PCI devices, a better summary command is: lspci -nn