Problems with mic on Intel 82801l

Problems with mic on Intel 82801l, notebook Lenovo G550. Very poor quality, too much noise. Tried change levels, with less sound noise remains the same.
driver ALSA 1.023. All packages installed. Sound works perfect.
The card isn’t listed at ALSA Supported page.
What to do?

I have the same intel onboard audio device in a Lenovo SL510, and there seems to be an issue with the built-in Mike on openSUSE 11.3. See this thread here, started by another user with a newer SL510 but I was also involved there. I solved it by upgrading to a newer kernel, but 11.4 is not that long to wait (RC1 is about to be announced in next few days). Anyway, do read that thread for a workaround, if it’s the same problem.

If not the same problem, then read this sticky from the Multimedia forum where that other thread resides, and carefully follow all the instructions for running alsa-info script. Post back here with the requested results.

Can you provide the output URL from running the diagnostic script:

/usr/sbin/alsa-info.sh

there is guidance here how to do that: Multimedia stickie

consused, the update to 11.4 will Definitely solve the problem?
How can I check this in advance? Testing KOTD?

oldcpu, the output is

http://www.alsa-project.org/db/?f=6ee267439bab1afeaa1e5a1a8dff64e33b7a4c6e

Reference the hardware, from the script I note a Conexant CX20561 (Hermosa) and that definitely IS supported by alsa.

From here I note these mixer settings:


!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Intel]

Card hw:0 'Intel'/'HDA Intel at 0xf4800000 irq 32'
  Mixer name	: 'Conexant CX20561 (Hermosa)'
**Simple mixer control 'IEC958',0**
  Mono: Playback **[off]**
**Simple mixer control 'IEC958 Default PCM',0**
  Mono: Playback [on]
**Simple mixer control 'Digital',0**
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]
**Simple mixer control 'Docking Mic',0**
  Front Left: 0 [0%] -74.00dB] Playback **[off]**
  Front Right: 0 [0%] -74.00dB] Playback **[off]**
**Simple mixer control 'External Mic',0**
  Front Left: 0 [0%] -74.00dB] Playback **[off]**
  Front Right: 0 [0%] -74.00dB] Playback **[off]**
**Simple mixer control 'Internal Mic',0**
  Front Left: 80 [100%] [6.00dB] Playback [on]
  Front Right: 80 [100%] [6.00dB] Playback [on]

The docking mic is clearly OFF. I assume you are not trying to use that.

The external mic is clearly OFF. Are you trying to use an external mic ?

The internal mic may be a digital mic, in which case it is possibly OFF as the digital mixer controlled by IEC958 is OFF. Is this an internal mic ?

Also, internal mics sometimes are electrically associated with an integrated USB webcam and then only work if the webcam has proper drivers setup and configured. Does this Leonovo have an internal webcam ? If so, what can you tell us about this webcam?

Now there are custom settings one can force as a model option for a Conexant CX20561 (Hermosa). My guess is that the Conexant 20561 (Hermosa) is the same as the Conexant 5051. If one looks inside the alsa documentation in the HD-Audio-Models.txt file, one will see these model options for a Conexant 5051 in version 1.0.23 of alsa:


Conexant 5051
=============
  laptop	Basic Laptop config (default)
  hp		HP Spartan laptop
  hp-dv6736	HP dv6736
  hp-f700	HP Compaq Presario F700
  lenovo-x200	Lenovo X200 laptop
  toshiba	Toshiba Satellite M300

Hence if the view is that alsa is misconfigured, one could force a model option at boot. In order to provide advice on the syntax/file needed to be changed to do that, I would need to see the output of:

 cat /etc/modprobe.d/50-sound.conf 

… and its possible a newer version of alsa would fix this (as alsa is now at version-1.0.24). I have an outdated guide to updating alsa here that I need to update: SDB:Alsa-update - openSUSE

but before providing advice there I would need to see the output of:


rpm -qa '*alsa*'
rpm -qa '*pulse*'
rpm -q libasound2
uname -a

cat /etc/modprobe.d/50-sound.conf

is

options snd slots=snd-hda-intel

u1Nb.JhlWIrGTU2C:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

The docking mic is clearly OFF. I assume you are not trying to use that.

The external mic is clearly OFF. Are you trying to use an external mic ?

The internal mic may be a digital mic, in which case it is possibly OFF as the digital mixer controlled by IEC958 is OFF. Is this an internal mic ?

docking not working, external also not, checked. Internal works badly with very much noise. Tried all mics.

lev@linux-8fbm:~> rpm -qa ‘alsa
alsa-utils-1.0.23-1.8.i586
alsa-oss-1.0.17-29.2.i586
alsa-1.0.23-2.12.i586
lev@linux-8fbm:~> rpm -qa ‘pulse
libpulse-mainloop-glib0-0.9.21-10.1.1.i586
libxine1-pulse-1.1.19-2.pm.48.15.i586
libpulse0-0.9.21-10.1.1.i586
lev@linux-8fbm:~> rpm -q libasound2
libasound2-1.0.23-2.12.i586
lev@linux-8fbm:~> uname -a
Linux linux-8fbm 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 i686 i686 i386 GNU/Linux
lev@linux-8fbm:~>

Reference the noise from the internal mic. Did you try moving DOWN the capture levels to 50% or lower to see if that cleans up the noise to an understandable voice ?

Try installing ‘alsa-firmware’ , and reboot and test. Do you get the same problem ?

If you recall I noted these model options:


Conexant 5051
=============
  laptop	Basic Laptop config (default)
  hp		HP Spartan laptop
  hp-dv6736	HP dv6736
  hp-f700	HP Compaq Presario F700
  lenovo-x200	Lenovo X200 laptop
  toshiba	Toshiba Satellite M300

Try each of the model options noted above, one at a time, to see if using any of them restore your mic to better functionality. Note that any one of those will break your sound. So you simply remove that option and try the next, which may or may not restore sound/mic functionality. If nothing works, remove the edit.

For example, to try lenovo-x200, add an additional line to the start of the 50-sound.conf file, so to change the /etc/modprobe.d/50-sound.conf file to:


options snd-hda-intel model=lenovo-x200
options snd slots=snd-hda-intel
# u1Nb.JhlWIrGTU2C:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

you need to use root permissions to edit that (ie “kdesu kwrite /etc/modprobe.d/50-sound.conf” , or “gnomesu gedit /etc/modprobe.d/50-sound.conf” ) and after editing save the change, and restart your sound with "su -c ‘rcalsasound restart’ " and then restart your mixer as a regular user and then test your mic, paying close attention to the mixer.

If " lenovo-x200" does not work, then replace it in the /etc/modprobe.d/50-sound.conf file with “toshiba” and try again. Try each of the model options until either one works, or none work. If none work, advise, and then we will look at updating alsa per the guidance here SDB:Alsa-update - openSUSE which means alsa-utils,
alsa-oss, alsa, and libasound2 will need to be updated. And alsa-driver-kmp-desktop will likely also need to be installed. But lets not do that yet. Instead, try the model options.

I missed what you had to say about a webcam.

Also, did you fix the mixer settings that I pointed out were possibly wrong ?

We don’t know that. Your problem may/not be similar to that in the thread I gave you (there you saw it depends on what happens with mike switching and recording tests at each stage).

In any case, although same sound chip/card, the alsa-info report shows a different Codec, and we had 64bit 11.3.

How can I check this in advance? Testing KOTD?

NO don’t do that now. It may be too risky and complicate the fault-finding process.

Recommend you follow through with oldcpu’s tests to a conclusion, and provide clear feedback to the questions. Any impatience won’t help, as mike problems can be tricky. :slight_smile: