Problems with LSI Megaraid right after install of OpenSuse 12.2


I have a Cisco UCS C22 M3 Rack server with build in LSI Megaraid controller (software raid controller or maybe what people call a fake/bios raid).

The installation process is going as expected and regardles of there is a build raid(1) or the disks are just configured as single seperate disks, the installation fails after the first reboot.
I have 2 SSD’s that I would like to have as a raid 1, but I don’t care if I have to use a software raid or fake raid.

Anyway the result is the same. After the first reboot after the installation, the server responds with:

i8042: No controller found
doing fast boot
Creating device nodes with udev
Welcome to emergency mode. Use “systemctl default” or ^D to enter…
Give root password for login

There is a guide from Cisco and LSI on how to add drivers when installing Red Hat and Suse Enterprice. The guides says to write “Brokenmodules=ahci, isci” and add a driver (using F6) in the first screen of the installation process. I have tried to follow the guide and not - and I have tried to add the LSI Megaraid driver from a USB-pen and also to go in Expert mode and add the driver from the “Load IDE/RAID/SCSI module” menu.

None of these attemps seems to work for me - I always end up with a nice installation menu and process without errors, only untill the first reboot.

Could someone maybe help me or give me a hint on what to try next in order to move on and get a succesfull installation?

Thanks in advance.


You’re talking about OpenSuse 12.3 …

  1. It’s openSUSE
  2. There is no 12.3 yet, just the first release candidate.
    If this is not for testing the distro purposes, but to get a stable system, install 12.2 or wait for the official release of 12.3.

Sorry - my mistake. It is 12.2 that I am using!

Changed the title to 12.2. Else everybody will either skip it or post that it should be moved to Pre-Release/Beta.

Thank you!

Found a solution. Suse or the driver did not like a seperate home partition like the defaults is set up to. The solution was to only make one partition besides the swap and also add both MBR and / in the bootloader.

Thanks for all the constructive feedback.


Hi claus232. Would you be so kind to give some detailed info on what you did? I have a rack server which has an LVM and is giving me the same problem. It might be that your solution would apply to my server also and I would like to try it. Thank you.

Well - it’s quite simple.

During the installation, when you get to the screen that shows how the harddrive will be partitioned, you uncheck the box that says “propose a seperate home partition”

  • and in the last installation screen, which shows a summary of the selected setup (where you typically select more software than the defaults" you click on the bootloader link, and then you get to a screen where you can select both the MBR and / as bootoptions (don’t really know if it makes a difference, but it worked).

Hope this helps.