Problems with Linksys WUSB600N (rt2870)

Hi all,

I’m new to openSUSE and as a matter of fact, to linux too. I’ve got a Linksys WUSB600N wireless adapter which used to work fine with some live versions of linux that I was testing out before moving onto suse… Each time, upon booting using live CDs, I used to copy the driver I had downloaded from:

SpeedShare - Download rt2870-kernel-2.6.24-nemesis.tar.bz2

Then ‘make’ and get into the driver’s os/linux directory to load the driver using ‘insmod rt2870sta.ko’

Now, upon doing a ‘make’ and ‘make install’, followed by the ‘insmod rt2870sta.ko’, I get the error saying:

insmod: error inserting ‘rt2870sta.ko’: -1 Invalid module format

I tried doing ‘modprobe -rv rt2870sta’ and didn’t get any error messages. But while doing ‘modprobe -v’, this error shows up:

insmod /lib/modules/
FATAL: Error inserting rt2870sta (/lib/modules/ Invalid module format

Seems to be quite a pain not being able to get around anywhere after struggling whole day looking through forums if anyone has had a similar issue. Any help would be much appreciated.



First of all, you don’t need to download that driver because it is already in openSUSE. Since you have installed it (that may be an older/incompatible version), you have to restore the latest version.

I’ve tried several installs of opensuse. Tried connecting the WUSB600N (rt2870 chipset) adapter without installing the drivers and with them. I found an two rpms while browsing around:

  1. rt2870sta-kmp-default- (dont remember the source from where I downloaded but this one worked for a while until I ended up doing an update and it started causing problems)

  2. rt2870sta-kmp-default- (this one I got from: RepoView: Akoellh’s Home Project (openSUSE_11.1_Update) it detects the wlan usb adapter, which shows up in KNetworkManager, but unable to connect)

I tried doing “iwlist scan” with the second rpm installed, but no scan results.

Any suggestions where I can find more rpms to try out?

That driver is distributed with kernel itself and you don’t need to install it from the RPM.
However, since Akoellh compiled and posted at his repository, he must have fixed some problems. He is one of the forum members. So, he will be the best person to answer your queries.
See if he responds to this post or you may post a private message to him.

hi zee

did u find a solution - if so please poste it

thx kay

maybe i have a similar problem - lookup my thread:
RT2870 configuration problem - help needed - openSUSE Forums

Could someone please upload the driver again? I need it desperately.

All the links I find on Google are dead, just like the Speedshare link.

Thanks in advance

This is what I did and its working perfectly:

Go to the network settings and temporarily change the settings to ifup. select the wusn600n card, click edit, go to hardware, and make sure that on the module name, rt2870sta is selected. for some reason it comes with rt2800 as default, and it does not work. go to general and make sure that the card is loaded at boot time. save and close network settings. open network settings again and change the method to network manager. save, exit and reboot.

That worked for me. you don’t need any special RPMs or anything like that. If you try this make sure you erase those RPMs, because they might create a conflict.

I hope this works!:sarcastic:

that worked perfectly. I was getting pissed off because for the last 2 days i have been trying to connect to my network, and it shows up, but when i try to connect, the authentication fails, but that simple trick did it :smiley: