Problems with latex on opensuse 12.3

I did update to opensuse 12.3 on my computer.

Now, when I start latex with the following command:

pdflatex mydoc1.tex

I get this output:

This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/TeX Live for opensuse.org)
restricted \write18 enabled.

kpathsea: Running mktexfmt pdflatex.fmt
fmtutil: format directory /var/lib/texmf/web2c' is not writable. I can't find the format file pdflatex.fmt’!

The problem seems to be to enter “extended mode”.

However, on another computer (which I also updated to opensue 12.3) latex
seems to function OK. There I get the message “entering extended mode”
and the document is processed like normal.

Is it something I should install at the first computer?

-r

“latex” seems to be working for me. I just tested “pdflatex” and that works.

I did not update to 12.3. Rather, I did a clean install of 12.3, but kept my “/home” file system (did not reformat that). I usually prefer that to an update.

The way that tex/latex is packaged has been greatly changed for 12.3. Maybe, because of that, the updating process doesn’t work properly. You might have some missing packages. I suggest going to Yast software manager, and searching for “latex” and “texlive”. Then install whatever seems important. The dependency checks should then bring in what else is needed.

On 2013-03-29, nennes <nennes@no-mx.forums.opensuse.org> wrote:
> I did update to opensuse 12.3 on my computer.
<SNIP>
> The problem seems to be to enter “extended mode”.

I too noticed that the standard TeX install on openSUSE 12.3 is different. I (having KDE and a large hard drive
generally pull in all the correct dependencies using:


sudo zypper in kile

… although I don’t actually use kile. This time, specifically on openSUSE 12.3, noticed some missing packages (siunitx
and units) but the rest seemed to work.

Am 29.03.2013 06:56, schrieb nennes:
> fmtutil: format directory `/var/lib/texmf/web2c’ is not writable.

Is the package texlive-filesystem installed?


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.0 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

This thread https://forums.opensuse.org/english/get-technical-help-here/applications/484928-kile-lyx-texlive.html may answer your query. Basically the way TeXLive is packaged has changed and you may have to download additional package groups to get the same packages as you got in previous releases.