Problems with Lamp server

Hi! Im using LAMP server on my Opensuse 11.1, have installed a forum and
it works fine if i connect it on localhost. But i cant connect it from
my IP on internet. Is it any config i have to do to make it work on
internet?

I used this guide to set it up!
‘Linux Apache MySQL PHP Server (lamp - openSUSE’
(http://en.opensuse.org/Linux_Apache_MySQL_PHP_Server_(lamp))

Sorry for my english:)


correadde

correadde’s Profile: http://forums.opensuse.org/member.php?userid=22008
View this thread: http://forums.opensuse.org/showthread.php?t=407273

Hi correadde, welcome to the forums. I think you linked in the wrong
guide. I get an empty page when I link to it.

To get to your IP from the internet you must open the firewalls to
allow external access:
If you have a router protecting your Lan from the internet: Open port
forwarding and forward port 80 to the internal IP address of your web
server. If you have an additional (personal) SuSEfirewall2 on your web
server, in Yast firewall settings enable http as an allowed service for
the external zone. At that point you can address your web server by the
external IP address of your broadband connection. If you want to connect
by domain name, goto a provider like dyndns: ‘DynDNS.com - Services –
Free Dynamic DNS (DDNS) Service’
(http://www.dyndns.com/services/dns/dyndns/)
and get a name like yourname.dyndns.org and link it to your IP address
from there.


‘Drop in and visit some time’
(http://www.swerdna.net.au/linux.html).

swerdna’s Profile: http://forums.opensuse.org/member.php?userid=84
View this thread: http://forums.opensuse.org/showthread.php?t=407273