Problems with kde 4.6.1 on new 11.4 install

I today upgraded to 11.4 using a downloaded DVD.

I was at 11.3/kde4.6.1.
I did a clean install of 11.4, reusing my /home partition from 11.3.
This is a desktop, legacy ATI (uses RADEON driver)

After the install process, I ran YAST-Software Management to grab recent updates.
Rebooted system, all seemed OK.

I then added the KDE46/11.4 repo, ran YAST and performed a “Switch to files in this repo” to move to 4.6.1.

I logged out, but cannot log back in, I simply return to the Greeter GUI after a brief blip.

Logging in to console, I don’t see anything definitive in /var/log/* as to what the problem might be.

Has anyone had similar issues, or success, with 4.6.1?


And if in terminal you erase/rename your ./kde4 folder to get to default settings, are you able to log in gui ?

I renamed .kde4

From console(as root), init 5 brings up a Greeter GUI, but same result.
Going back to console, no new .kde4 created.

If, from console, I

init 3

I see in the console error messages from (I think) X.Org X Server 1.9.3 that say
first… failure to load fglrx (as I would expect, it is not loaded)
then Fatal RadeoHD …“presently does not work with KMS”

With 4.6.0, it appeared that Xorg was trying fglrx first, then RadeonHD, then ended up using Radeon.

What is the best way to back out the KE46/11.4 repo (go back to 4.6.0) ?


Did you type nomodeset at the boot?

I did try booting with nomodeset, the system would boot to level 5 but Greeter screen never comes up, goes directly to console.

From reading your previous posts, it doesn’t look like your problem is with KDE. If some of the updates you ran included xorg-server or the kernel, you will need to reinstall the fglrx module. Although I’m not sure why the radeon driver isn’t working for you.

Thanks, this is integrated mobo ATI Graphics: ATI RS690 [Radeon X1200 Series]
This is considered “legacy”, there is no fglrx for this device (that is current).

I believe that the clean install was running radeon driver.
For some reason, after loading the KDE46 repo, it seems stuck wanting the radeonHD.

OK, I have recovered to the KDE 4.6.0 by

  1. Removing the KDE46/11.4 repo from my list.
  2. zypper dup

After reboot, GUI Greeter gets me back to the kde4.6.0 desktop.

I looking at /var/log/Xorg.0.log,
I see it try fglrx(not installed, so it fails), then RadeonHD (fails because KMS is enabled) then ends up running radeon driver.

My integrated RS690 (X1200) graphics device is listed by RadeonHD as supported, but I have never (11.2, 11.3) been able to make it work. Perhaps it is due to bios setting for shared framebuffer memory, I have tried some of the options but none work.

It is not obvious why files in the kde46/11.4 repo cause Xorg to not try radeon after radeonHD fails.

For now, am in business with kde 4.6.0.

Thanks for the suggestions

In the same timeframe today another thread appeared
[SOLVED] Cannot login after update to Kde 4.6.1 on openSuSE 11.4](

I re-enabled the kde46/11.4 repo, made a “switch system files”, logged out, logged back in selecting KDE Plasma Workspace from the Session Type Menu on the Greeter (login) screen and all is well.

I have never (in the past) payed much attention to Session Type.
Perhaps this is something new for 11.4?

Apparently there is a problem logging into KDE 4.6.1 after an upgrade. What you have to do is choose the session type at the bottom to KDE and log in. Sometimes you will have to choose KDE failsafe, login, then logout, and login again to the “regular” KDE.

After that the problem is fixed.