Problems with installing Nvidia driver

the easy way simply does not work. I’ve added the repo with :

zypper addrepo --refresh http://http.download.nvidia.com/opensuse/42.3 NVIDIA

but then the:
zypper install-new-recommends

does absolutely nothing.

I’ve uninstalled drm-kmp-default prior to install as in the article https://en.opensuse.org/SDB:NVIDIA_drivers .

Installing the drivers from the package downloaded from Nvidia site only “kinda” worked. I had to launch the installer with --no-drm option - otherwise it failed. So it is only partially successful. But at least I’m able to get into my Gnome install with res higher than 640x480 .
I’m installing driver for GTX1050Ti.

Any ideas howto do it correctly and get full driver functionality?

What did you expect? This command installs packages that are recommended by other packages. As nVidia normally are not recommended by any package that is part of openSUSE itself, nothing happened. Adding repository does not magically make packages inside this repository “recommended”.

well , I expect the guide from the official wiki to work. If the guide says that adding the repo and then running zypper install-new-recommends should get you up and running I expect it does. Pretty simple…
If it does not the guide on the wiki page should be fixed.
Anyways for the time being I got the driver running - after installing using nvidia installer (.sh) with no-drm option I added pacman repo. After update some weird thing happened (saved output if anyones interested) - which borked the driver. So I did NVIDIA-XXXX --uninstall , then installed it again and this time it worked (“no-drm” option was not needed) and it seems all is running fine.
Fingers crossed it stays this way - but so far graphics on OpenSUSE has been far from smooth experience.

Oh, I see. Sorry. Hmm … I wonder if openSUSE zypper can also match and recommend by PCI IDs. I do not remember ever seen it (or seen someone mentioning it).

Did you by any chance enable “no recommends” default (solver.onlyRequires=true in /etc/zypp/zypp.conf)?

If you don’t have anything worthwhile to add can you plz move to different thread (… yeah, and I know - I’m feeding the troll)?
Consider this very simple thing - how can a user new to OpenSUSE get up to speed if official docs give faulty instructions (if they are - you claim they are, while I simply don’t know)? RTFM argument gets flawed at this very point :wink: .

First> The command that you gave is missing one / at the bottom of the Repository, if you click it, you can not navigate.

http://http.download.nvidia.com/opensuse/leap/42.3/

The URL is invalid as was already pointed out. The addrepo indeed succeeds, but subsequent install-new-recommends spews out errors. Did you see any error in your case?

My bad. The command name is misleading in that it also follows Supplements tags in new packages. In defense, it is extremely hard to find any usable information about this, and even less - about actual content of Supplements. This tag is interpreted not by RPM itself but by libsolv and there is zero documentation. But as far as I can see, it actually supports matching by PCI IDs (i.e. nvidia kernel package has a bunch of module aliases that should cause it to be installed when matching cards are present).

Well, apparently it does work usually. It could be more clear, what release means indeed.

Hi there,

The driver RPMs hosted in this location are entirely built, maintained and supported by Novell/SUSE. NVIDIA hosts them as a courtesy to Novell, however all problems and support requests related to these RPMs should be reported to Novell via their bug tracking system: http://bugzilla.novell.com

If the issue can be reproduced using the official NVIDIA driver package from this location: Unix Drivers | NVIDIA

please send email to linux-bugs@nvidia.com. When emailing linux-bugs@nvidia.com, please attach an nvidia-bug-report.log, which is generated by running “nvidia-bug-report.sh” as the root user.

Thank you.