Problems with installing Godot 4.0

I want to install Godot 4
when installing Godot from the system application or from the installer downloaded from the website. godot is launched “normally” BUT the first sign is that it is launched instead of in the middle of the screen, it is launched between screens and it seems to be nothing because it can be moved, but when I right-click on something, the list of options does not appear and if I click several times, it will appear but in the middle screen, and sometimes not at all (maybe it appears in a place not covered by the screen because I have screens with different resolutions)
I used Steam which I installed on Lutris and installed Godot there (I also installed it on “normal” Steam but I don’t remember what exactly didn’t work) and everything seems to work there, everything is centered in Godot 4.0 BUT all the images in the mini file browser have a thumbnail of X and when I want them somehow use it, nothing happens :<<
I tried to install Godot directly from Lutris and everything seemed to be fine, but while watching the guides I realized that I didn’t have a large number of functions and others were hidden because I can only install versions 3.4 on Lutris :<
any ideas what should I do?
(when I have godot and it is not centered, I probably also had these X’s next to the png)

anyone have any idea?
I downloaded Godot version 3.0 with Zypper and everything works
Is there any way to run Godot 4.0 without errors on this system?

@kak Perhaps you can tell the Forum users what openSUSE release your running rather than the other tag.

maybe in diffrent way
I installed Steam on Lutris and installed Godot on Steam
then it is godot 4
and I guess the only problem is that png doesn’t work

detects all files but when I select png to do something with it (use it as a map) I get an error “Invalid texture selected.”
image
image
image

:frowning:

I’m guessing that you need to give Godot read permissions BUT HOW, this Godot “works” because it is installed in Steam installed in Lutris D:

@kak what version of openSUSE are you running?

I hope this is enough
and I have openuse in the kde version
image

Several points and questions:

  • you are using an outdated Tumbleweed snapshot. Upgrade your complete system via zypper dup
  • why do you install Steam via Lutris? Steam is a standalone application which works better without Lutris. Simply install Steam from the official openSUSE repos when you want to use it.
  • Why do you install Godot in Steam or Lutris? Godot is available as standalone application in the official openSUSE OSS repo.

You are using an absolutely complicated way:
Lutris->Steam->Godot

The Godot version in the openSUSE OSS repo is even newest available version 4.2.2 and doesn’t need Steam or Lutris.

first of all, I will update the system as you say
secondly, I have Steam installed normally, but the one running in Lutris allows me to run some Windows games that do not run on “normal” Steam
I installed Godot using the system, using “normal” Steam, using Lutris and each time there was a problem with its operation
I had 3 variants of errors
either the application was somehow not centered (I described it at length in my first “post?”) or Godot was in version 3, not 4, and when I install via Lutris Steam, only png files do not work

read what’s in the first “post?” I wrote it because I wrote a lot about it

The first post is unstructured. So the error when you install Godot 4.2.2 from the official openSUSE OSS repo is that it is centered between screens? Did you test with a fresh user profile?

On an up to date Tumbleweed snapshot, Godot 4.2.2 from the official openSUSE OSS repo opens on the main screen of a multimonitor setup. Also rightclick and everything works here.

So eiter test with a fresh user or remove oll the setting files from Godot and start fresh.

ich@laptopneu:~> LANG=C zypper se -si godot
Loading repository data...
Reading installed packages...

S  | Name  | Type    | Version   | Arch   | Repository
---+-------+---------+-----------+--------+-----------
i+ | godot | package | 4.2.2-1.1 | x86_64 | OSS
ich@laptopneu:~> 

children for this purpose suggest to create another account and in godot it normally works better than ever to get started
remove all the folders that contain “godot” but after 20/30 installations I’m a bit bored

explain that I can install different programs so I can’t get rid of godot :smiley:

Until now there are not much informations where helpers could work with. No exact version numbers. No structured steps to reproduce the issue. Avoiding answering questions. And much more…

As already explained, godot-4.2.2-1.1 works fine when installed from the official openSUSE repo.

I’m sorry for the small amount of information, I don’t really know what to send and how :<

but I managed to discover what was spoiling my godota
for some reason when i have the godot toolbar on screen 2 it can’t handle it
I created a new user on my system, when I launched Godot installed with the system application, everything worked, but when I added the toolbar to the bottom of the screen at the top, Godot started to go crazy and appear between screens and did not allow me to use the right mouse button

and I’ll ask right away if you can recommend any other programs that add a toolbar? (I heard that there are others and this would allow me to still have the toolbar)