Problems with installing 12.2 (mkinitrd) using grub2 on a EFI system with two discs

Hello,

I had some problems with openSuse12.2 installation. I “tricked” around the most ugly one, but still I want the complete thing fixed if possible.
Here are the details of the system:
HW:

  • Intel 64 bit (quad core) processor
  • 8 GByte RAM
  • EFI BIOS
  • Two SATA discs installed

SW:

  • Had before installed openSuse 11.4 and 12.1. (each one on its “own” disc)
  • Both had separated partitions for root (/) and home (/home); both were bootable using grub.
  • When I do an “upgrade” I reuse the oldest /root and /home partitions to do a fresh install (formatting the partitions). Then I copy over what I need from the old /home.
  • 11.4 was installed on ‘sda’, according to the partition scheme visible during install. I instructed yast2 to install 12.2 there (/root on sda5 (first extended partition) /home on sda6, instead of 11.4.
  • 12.1 is (still) installed on sdb1 (/root) and sdb2 (/home)
    So probably also the 12.1 grub was installed on sdb

Install process:
I installed 12.2 on /root and /home, used before for 11.4. I asked the install to format the partitions.
When it came to installing grub2, it ended with:
[partly translated from German]


Error during installation of initrd
Kernel image: /boot/...
Initrd image: /boot/...
KMS driver: i915
Root device: /dev/disk/by-id/...
WARNING: no dependencies for kernel module 'hid-generic' found
Kernel modules: ...
Features: ...
Perl Bootloader: 2012-09-14 22:42 ERROR: Command '/usr/sbin/grub2-install --force -skip-fs-probe /dev/sdb > /var/log/...
'/usr/sbin/grub2-bios-setup: Error: Embedding not possible, but needed for install on several drives.

I tried twice and both times failed in this way.
Then I disconnected the second disc (carrying 12.1). This time the install succeeded. I reconnected the drive afterwards and was able to mount the old partitions.

What I still don’t like at the situation are three points:
1 A newbie would most probably failed on installing 12.2 altogether.
2 I had no problem with 12.1 and 11.4 before
3 I still would like to being able to boot 12.1 as sort of backup system.

Any hints for me on the last point ?
Any plans to have this fixed completely ?

[As mentioned I can live with the current situation, but would be happy with solutions to this]

TIA and regards

Martin*

You are running in Legacy boot mode, so your problem has nothing to do with UEFI. Your title is misleading. Actually, with UEFI you would not have any problem at all.

'/usr/sbin/grub2-install --force -skip-fs-probe /dev/sdb

What is BIOS disk boot order? You say you have the current version 12.1 on sdb; is it set as boot disk in BIOS?

You are running in Legacy boot mode, so your problem has nothing to do with UEFI. Your title is misleading. Actually, with UEFI you would not have any problem at all.

Need to check. (But it will take some time, until I get to this system)
Would be funny - but at the same time it might be: I remember problems with booting on this system (When installing 11.4 or 12. Maybe I dropped back and then forgot to change it back.
Any chance to change this now ? (Without loosing the ability to boot 12.2) ?

What is BIOS disk boot order? You say you have the current version 12.1 on sdb; is it set as boot disk in BIOS?

Also need to check. Due to the fact, that during the (successful) install I only had the disc carrying 12.2 connected, I would assume this one as the first one in BIOS. But I’m not sure. [My description was with both discs installed]

Thanks for looking into this !

Martin

Hello,

answer to the first question: (UEFI mode in BIOS):
I don’t see an option to switch UEFI off in the BIOS.
BUT… do I need to start with a blank harddisc or at least to recreate the partition, intended to carry the boot/root ?] partition ?
When I installed 12.2 I only reformatted the already created partitions on the disc.

Regards

Martin

I’ll try to remember to look for the boot order in BIOS on next boot.

[QUOTE=mjost;2500548]answer to the first question: (UEFI mode in BIOS):
I don’t see an option to switch UEFI off in the BIOS./QUOTE]

Then something is wrong. grub2-bios-setup is used only on legacy BIOS systems.