problems with Ifup

Hi all,

I used to use SUSE all the time after I first put it in once I got my internet and graphics etc working, and found it perfect, however I can no longer access the internet.

Originally I used Network manager which could never get an IP address and connect properly. Eventually I read that It was buggy and I needed to use the traditional Ifup method. I tried this and it worked perfectly. very happy.

Then I went to uni and took my notebook, I connected it to the uni internet and it worked perfectly, then brought it home again, now I have deleted out my internet connection and tried putting it back in, tried network manager, doing the same setup with Ifup doesn’t seem to be working, intenret is fine, but linux doesn’t seem to be connecting at all. I’ve torn my hair out over this as have put in same details, tried making new user accounts etc, nothing seems to work, It seems a shame to give up on SUSE, but I have been going back to windows for a few months now, although suse seems wasted, anyone have any ideas? It just doesn’t seem to bother connecting. There is no suse firewall on that I can tell cause i disabled the default one, and also even wired connection doesn’t seem to be working in suse at the moment.

Please help,

Yours confused.


Your question is very confusing. It’s hard to figure out what is the question. So as far as I can guess you are trying to connect to internet without success. Not sure what version of Suse you are using. In a terminal console if you run the command ifconfig what do you get? please post it and we’ll go from there.

The home connection to the Internet might not supply/route the web addresses as well as the public connections. Try adding the IP address of your gateway/router into the configuration and also the IP addresses of the name servers provided by your ISP (or if you don’t know the IPs of the name servers, use Google’s free offering ans

Might help

ok, thanks will try and post reponce,

thanks guys for help.

ok, to also clarify the problem a little better than I originally wrote. I have connected to the Internet before using SUSE, however when I connected to a public network using Ifup, I have since been unable to connect to the internet using either network manager or Ifup. my card is installed and working correctly, I can see the local networks using wireless, although cannot seem to register with my network. I can ping the router but cannot ping google. The results of Ifconfig are shown below, I am using an intel wifi link 5100 AGN, and understand that many users have had problems with this card, but that the upgrade to SUSE 11.3 has fixed many of the problems, I have still not been able to do this. I am also not 100% how to route the internet connection via my router IP like many people have suggested on other threads, I have put the router and gateway ip address in a few places on the ifup configuration, however the wireless wep key etc are correct - so this has been doing my nut for months now, and everything I read I seem to have tried at some point. any help would be greatly appreciated.

lynandal@linux-3ia7:~> ifconfig
Absolute path to ‘ifconfig’ is ‘/sbin/ifconfig’, so running it may require superuser privileges (eg. root).
lynandal@linux-3ia7:~> su
linux-3ia7:/home/lynandal # ifconfig
eth0 Link encap:Ethernet HWaddr 00:1D:72:EC:FD:36
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:1192 errors:0 dropped:0 overruns:0 frame:0
TX packets:1192 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:93152 (90.9 Kb) TX bytes:93152 (90.9 Kb)

wlan0 Link encap:Ethernet HWaddr 00:21:6B:03:A5:36
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0:hom Link encap:Ethernet HWaddr 00:21:6B:03:A5:36
inet addr: Bcast: Mask:

linux-3ia7:/home/lynandal #

any suggestions anyone? thanks.

Can you describe where and how you configured things initially?

Looks to me like your wifi modem is supplying an IP address
The problem might then be that you need to add in the IP addressees of the Name Servers and the Gateway in the config of your wireless interface card.

Describe the pathway for Internet signals to come from the Internet to your computer through your modem hardware and any routers etc. In other words: what’s your setup for the internet.

ok, sorry guys, need to bear with me a bit as haven’t used linux since the Internet gave up. originally, I had struggled to set it up using my network card and the network manager to my netgear router, then was told there was a bug using the key manager utility that stores the passwords. I then switched and connected in the first instance to network using Ifup which worked perfectly. I was chuffed to bits and pretty much gave up on windows. I then took my notebook to uni and disconnected from my home wireless to connect to the uni one, however Linux couldn’t connect. I then tried at home using Ifup, and it can discover the networks around. What it doesn’t seem to do is fully register with an IP address - so the post above confused me. I don’t think the LAN cable plugged in makes a difference, - Firefox shows me nothing, so unsure on that? there are no firewalls and I still have done the same steps I did before.

My typical setup is a Wireless Netgear router > signal is picked up by IFup > cannot register an IP correctly and connect. I’m a little unsure where I find the name servers and Gateway to add to the config of Ifup.
Does this answer the questions above? or can you let me know what you need next,

thanks. Windows is working correctly online if that helps?

There’s a pictorial guide is for a router such as you describe. For a wifi situation and assigning the IP address by DHCP, you would follow screenshots numbered 0 through 6, except leaving out #5. You can use the IP addresses assigned by your Internet Service Provider for the Name Servers or use public/free Name Servers e.g. and are good ones.

Your wireless card’s return looks wrong, looks like the card isn’t getting an IP address, or a dodgy one, maybe, anyway try following the guide.

If there’s a problem then afterwards post back here the make and model of the wireless interface and also the return you get from these commands (after first entering su to get rootly powers):

lspci -nn | egrep "etwork|thernet|theros"

You may be suffering from what I observed all the time when transporting OpenSuSE virtual machines between networks which would be not much different than your physically moving your machine between networks.

At least through OpenSuSE 11.1, every time the NetworkID changed (moving from one network to another), YAST would create a new network interface, incrementing the enumeration by one.

So, the result for instance would be if you moved your machine between home and university once a day, by the end of the week you could have as many as 10 eth0, eth1, eth2, eth3, etc.

You can verify this by inspecting available network interfaces in YAST.

If you suffer from this problem, it would mean that since IFUP requires specifying a network interface you would have to know exactly which one of the eth interfaces was active and the last time you invoked IFUP probably won’t work again.

The workaround is to use

/etc/init.d/network restart

which instead of ifdown/ifup a single interface does that to all interfaces.

Note that at some time you may want to do some housecleaning and manually remove the extra network interfaces.


Yep, this is one thing I find totaly absurd under Linux (Unix doesn’t do that kind of nonsense). Fortunately you can change the numbers in /etc/udev/rules.d/70-persistent-net.rules and renaming the ifcfg-ethX files in /etc/sysconfig/network … otherwise you’ll end up sooner or later with device eth666 ! >:)

This is not specific to openSUSE 11.1 and not specific to openSUSE. All Linux do that. The nics are numbered in the order the modules are loaded - which can vary from start to start. That’s why the udev rule get written at the time of installation. Some distros don’t even create one …so if you have more than one nic, the interface names may change (unless you create /etc/udev/rules.d/70-persistent-net.rules yourself).

wow guys, thanks for all the detailed help. I’ll post back here as soon as I get another chance to try the above, the pictorial guide is brill thank you so much, and the incrementing nic refs is interesting - wierd, will have a proper read ad try, cheers, al

gutted, Swerna’s link to the pictorial guide is gone, is it possible to please re-up, I have tried some of the things on this thread, and still having no joy getting any of it working, its really winding me up how it works, and then stops working.

in fact, without sounding ignorant of the above comment that Linux makes lots of new network interfaces, in which instance I am presumably on my second or third one? Is it possible if I make a new account and delete my existing one, then I can just follow some simple instructions on a website somewhere which will help me set up my internet? not using the Network Manager because that won’t work, but using Ifup. I have tried several of the above, but I am at the point where I don’t really understand what I have tried or what to do next? and would like to restart. Will deleting my account allow me to do this from scratch, and is there a tutorial page somewhere?

Just checked – 12 ppl on the site right now. Maybe link is wrong, here it is again: Configure a network card in Suse/openSUSE 11.x for Internet Access & wifi.

Deleting or making new accounts will bring nothing. You can easily switch the method in YaST - network settings:
-> Global options
( ) User Controlled with NetworkManager
(*) Traditional Method with ifup.

However while set up properly both methods work as expected. (Network manager used to suck in the past but is ok now - I still haven’t used it under openSUSE though).

Yep I use knetworkmanager all the time and it works great for me.

ok, thank you - will follow the tutorial above and post back, cheers.