Problems with home server

So i started my home server, installed apache2, mysql, php, and I can run php scripts by doing:

<?php echo ‘test’; ?>

but whenever I try to make it give an error by doing

I tried to put my cms inside the htdocs folder, without the scripts configuration, so I would get an error, and it just shows a white page.

Did I do something wrong installing all this?
What could be making it so my errors don’t show up?

Also, I’m not sure if this was the correct forum to post this in, but I couldn’t find anywhere else to put it.

Also, I tried running “mysql” in the terminal, and I get this message:

matthew@linux-laf9:~> mysql start
ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2)

Edit: I fixed this problem by enabling mysql through system services.

Thanks in advance.

I was just about to say that you have to start the mysql service :wink:
First time i got in contact with mysql i got the same error and
did the same thing wrong lol!

check your php.ini file. I vaguely remember when i installed php from yast, error reporting was disabled by default