Problems with Grub and accessing drive

I recently installed OpenSUSE 11.1 from a Live CD to a separate hard drive. My main system is on a second drive running Windows XP. The Linux drive was split into a small SWAP partition and a EXT3 partition.

When I select OpenSUSE from Grub at boot up, I get the following message:
Root (HD,1)
Error 22: No Such Partition

I had wanted Grub to have my PC to go into Windows at startup after 8 seconds, but to choose OpenSUSE if I want to run a Linux session. Grub defaults to my Windows drive, but I can not boot into Linux. If I select the hard drive option on the CD’s startup screen, it also goes to Windows.

I’m assuming that I made an error in configuring Grub. How can I get back to the hard drive installation of OpenSUSE and what settings do I need in Grub for my above boot method?

Any help would be appreciated.


Try the following:

If you have a Linux Live CD, boot from it and log in. Then open a console window and enter su and you will be at the command prompt with root powers and ready to proceed. If on the other hand you have the openSUSE install DVD, boot from it and on the first menu of options select the Rescue System option. That will start an elementary Linux Live operating system and bring you to the login prompt. Enter the username root and you will be at the command prompt with root powers and ready to proceed. Whichever way you started (the openSUSE install DVD or a Linux Live CD) when you are at the root command prompt, first you find the partition containing openSUSE’s bootloader. Then you reinstall Grub with a pointer to that partition. First find the openSUSE installation:
You enter this ---------------- grub
Computer returns like this ---- grub>
You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ---- (hd0,5)
Here, (hd0,5) is Grub’s pointer to my openSUSE installation. Your pointer will be different from my example (hd0,5). Substitute your values for my example (hd0,5). Now that you have the pointer, proceed like this:
You enter this ---------------- root (hd0,5)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
You enter this ---------------- setup (hd0)
You see several lines like this — Checking if /boot/grub/stage1 exists … yes Computer finally returns this-- Succeeded…Done
You enter this ---------------- quit
You enter this ---------------- reboot

Help here too:
All About Grub - openSUSE
HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

It’s maybe menu.lst file problem, please modify the /boot/grub/menu.lst file for your correct drive partition, the file format display as this article BSD/Linux Tutorial Zone: About Windows and Linux dual booting Grub menu

I followed the steps you laid out. It gave me a pointer of hd1,1 and confirmed the file system type.
I then tried both ‘setup (hd0)’ and ‘setup (hd1)’. Both gave me a ‘Succeeded…Done’. I still can’t access the Linux drive from Grub and get the same Error message.

Any other thoughts?


To answer the question you asked first (maybe :confused:):

First: in order to get into openSUSE you will have to choose and use one of these five ways to boot int openSUSE when Grub won t work.

Second: please post here the contents of Grub’s menu configuration file (menu.lst) located at /boot/grub/menu.lst. You can view the file by typing this in a console/terminal window:

sudo cat /boot/grub/menu.lst

Third: We will inspect the file and try to see where it’s wrong

Fourth: and while you’rte there, run this command and post the results back here to help us more:

sudo /sbin/fdisk -l

Well, I was able to get Grub fixed. The sudo command lines didn’t work for me (I got an Invalid Option back on one of them), but the ‘How to boot…’ web page did the trick. I was then able to adjust Grub. The only problem that I have now to being able to access my Windows drive/Storage Drive from inside OpenSUSE, but I’ll work it out.

Thanks for all the help, guys.

Please post the result of this:

cat /etc/fstab

Great news

For future use: probably you used the numeral 1 instead of the letter l in the option at the end (-l, not -1). That would cause that error.

If it’s a fat32 partition, this will help: openSUSE: HowTo set disk access permissions for Fat32 (VFAT) on a desktop PC
If it’s an NTFS partition, this will help: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE 10, 11