Problems With Floppy Drive

I trying to format a floppy and i got this error

mkfs.ext2 /dev/fd0

mke2fs 1.41.9 (22-Aug-2009)
/dev/fd0: Read-only file system while setting up superblock

mkfs.vfat /dev/fd0

mkfs.vfat 2.11 (12 Mar 2005)
mkfs.vfat: unable to open /dev/fd0

im running as a root, the floppy switch is no lock and I try with a few floppy.

Have you tried using your desktop respective Floppy formatting tool?

Does the disk have a valid partition table? What’s the output of (as root):

fdisk -l /dev/fd0

That’s a lowercase L before /dev/fd0.

Have your floppies been low-level formatted? Floppies are so old that many people forget that you once had to low-level format them. Sometimes they come from the factory preformatted but it’s always best to do it again yourself, or whenever needed, because floppies are notorious nowadays for losing their low-level format.

The command is:

fdformat /dev/fd0u1440

After than you can create a filesystem on it. This is not formatting, but creating the initial filesystem skeleton.

The other thing that is possible is a faulty write-lock sensor. In which case you need to change the drive. I’ve got a pile here if you want to come around. :slight_smile:

fdisk -l /dev/fd0

Disk /dev/fd0: 1 MB, 1474560 bytes
2 heads, 18 sectors/track, 80 cylinders
Units = cylinders of 36 * 512 = 18432 bytes
Disk identifier: 0x00000000

Device Boot      Start         End      Blocks   Id  System

///////////////////////////////////////////////////////

fdformat /dev/fd0u1440

/dev/fd0u1440: No such file or directory

///////////////////////////////////////////////////////

I dont think is the device …

Try /dev/fd0h1440. Or /dev/fd0H1440. Have a look and see what fd devices are in /dev now. They changed the names a while back and I don’t remember what to.

No such file or directory in both the only device in dev directory are fd and fd0

Ok, try fdformat /dev/fd0 then. Maybe the naming has all changed with udev these days.

fdformat /dev/fd0

/dev/fd0: Read-only file system

/////////////////////////////////////////////////////

I cant do anything with the floppy drive I have un block that Read-only file system i guess

any ideas?

I think you have a faulty drive. Or cabling. I assume you already tried several floppies.