Problems with file downloading using KGet in Firefox

I’m (trying to) use KGet to download files in Firefox. Got the FlashGot plugin installed, which is necessary to get this to work. Somehow, however, the downloading behavior is not yet how I want it to be:

I would like to automize the downloading process as much as possible, so that clicking on a downloadable file would lead KGet to take care of the rest.
At the moment, however, after clicking on a file in Firefox in order to download it, I still need to:

  1. choose in the Firefox download dialog what to do with the file (download using Firefox? use flash > KGet? open directly?)
  2. confirm the download in the KGet New Download dialog, which opens after step 1.

Currently, I have …:
(A) … FlashGot’s setting set to “autostart download”.
(B) … KGet’s settings set to “use default download folder” (in Settings > Folders), and “disable confirmation dialogs” (in Settings > Advanced).

But apparently this is not enough. Any idea what I need to do?

mine started automatically after install… don’t remember what i had done and what i did to ‘turn it off’ (i prefer),
here is a pretty good article on flashgot…
perhaps it will help.

Using KGet Download Manager with Firefox | FOSSwire

if i get time, i will look back at what i did. sorry for now.