problems with EVMS

I want to install EVMS n machines with openSuse 11.2. The EVMS installation procedure (EVMS: Installation: Installing the EVMS Tools), point 3, says to do: “make install”.
I’m in the correct folder, there is the file Makeinstall.ini, but just try to run the command I’ve an error (make cannot have install like target).
Is a evms problem or opensuse problem?

this is my output:

linux-vxth:/usr/src/evms-2.5.5 # ls
.makefile.swo INSTALL.initrd aclocal.m4 engine po
.makefile.swp autoconf include tests
ChangeLog README configure kernel
INSTALL SubmittingPatches
linux-vxth:/usr/src/evms-2.5.5 # make
make: *** No targets specified and no makefile found. Stop.
linux-vxth:/usr/src/evms-2.5.5 # make install
make: *** No rule to make target `install’. Stop.
linux-vxth:/usr/src/evms-2.5.5 #

I tried too rename “” into “makefile” and “” into “make.rules”, but then I have other problems

Hello kiaraston and welcome to the community!:slight_smile:

You are in the correct folder, but you need to run this command:


If you’ve done that already then you need to run it again and check for errors.
Could you post the output of ./configure?

Best of luck!:wink:

Yes, I have forgotten to do ./configure :o(
I install C compiler and other packege (linux-kernerl-header and -sorce), but when I install evms it want “PAGE_SIZE”, so I write in page.h:

#define PAGE_SHIFT 12

(it is the same value to the system call getpagesize() , and I ask me : why does it want PAGE_SIZE and not do the system call to runtime? )

Finally, it seems to do everythig… but instead I can use the command “evms” from the comand line, but I cannnot use “evmsgui” and “evmsn”…But I don’t work with evms before so I prefer a GUI to help me…

Hello kiaraston,

Good to hear you’re a step further!:slight_smile:

How do you mean “I cannot use “evmsgui” and “evmsn”…”?
Can’t you run it because the command isn’t found?
Or do you get an error message? If so could you post the error message?

If you’ve run make install successfully then the tool evmsgui is installed under /sbin/.
This means that you need to run it as root.
To make sure the executables evmsgui ans evmsn are in the directory /sbin run these commands:

file /sbin/evmsgui
file /sbin/evmsn

Best of luck!:wink:

I cannot use them because these commands not exist.
In /sbin directory there are:


I try, too, search evmsgui (“cnf evmsgui”) but the answer is “comman not found”


Hello kiaraston,

I couldn’t find it in any documentation of EVMS but maybe you need to compile them separately.
To do this start a terminal.
Go to the directory containing the evms source.
Run these commands:

cd ./ui/
make install

I haven’t tried it myself so I don’t know if it works, but you can still try it.

Best of luck!:wink:

Edward thanks for the answer but if i try to run make inside ui directory:

linux-5zlf:/usr/src/evms-2.5.5/ui # make
make[1]: Entering directory `/usr/src/evms-2.5.5/ui/cli'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/src/evms-2.5.5/ui/cli'
make[1]: Entering directory `/usr/src/evms-2.5.5/ui/utils'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/usr/src/evms-2.5.5/ui/util

And with make install nothing will be installed.

By the way i’m trying to use evms with pacemaker (and corosync), i need to install pacemaker BEFORE evms or after?

Hello kiaraston,

Strange, there should be a folder named gtk and a folder named ncurses.
Could you post the output of this command:

dir /<path>/<to>/<evms>/ui/

If these folders aren’t there then you can download the source with gtk and ncurses form here: Download Enterprise Volume Management System from

Sorry, I have no clue.

Best of luck!:wink:

I am seeing exactly the same thing as kiraston. If anyone has overcome this problem, please post.


Hello nshadowy and welcome to the community!:slight_smile:

There’s a lot of information missing in your post.
So could you tell us which version of openSUSE you use?
If you use KDE or GNOME? Which version of EVMS you run?
What you’ve already did?

It’s been a long time since I helped kiaraston, but I think you should also check which folders are inside /<path>/<to>/<evms>/ui/.
Best of luck!:wink: