problems with changing the wm_default

Hi everyone.

I am very new to opensuse and kde.
I have installed opensuse 12.3 (x86_64) kde. I wanted to try out a different window manager other than the kde-plasma.

I bring up the /etc/syconfig editor, then proceed to Desktop → Window Manager → DEFAULT_WM.

The current value in DEFAULT_WM is kde-plasma. I tried changing it to xfce, one of the wm from the list provided, but that doesn’t work. When I try to save my changes I encounter the following errors

  • configuration module kde failed
  • configuration module profiles failed
  • configuration module susewm failed

The second and third error messages come up up if I click on the ok buttons of each error message that comes up.

I log out and log back in again, then I check the DEFAULT_WM; it shows the new value I entered. But everything actually behaves and looks like the kde-plasma wm still.

So how does one get to activate a new window manager in opensuse 12.3 kde?

Thx

m

Hi and welcome to the forum :slight_smile:

In YaST software management if you select the patterns in the drop down and then select the Desktop environment pattern (eg XFCE), this will be installed (not installed by default). Then you changes should work. You should also be able to select the desired window manager via the login screen.

You’re confusing windowmanagers with desktop environments. After installing XFCE (for example) you log out, and will have to use the Sessions option in the login screen. XFCE will be in the list.