Problems with AMD Catalyst 12.6


I got some problems after installing update to AMD Catalyst 12.6 drivers on my Opensuse 12.1 machine. I have a Radeon 5750 graphics card.

The problem is that when I log in, the screen is small with big black margins on the sides. I know that I can fix this by setting the “overscan” option to 0% in Catalyst. But next time I log in I got the same problem again, so right now I re-configure it every time I log in.

Is there any way to make the setting permanent? I had no problems before the AMD driver update.


I think you have to run Catalist in admin (root) mode. You usually have both options (normal and admin) in the Applications>System menu. Then you’ll be able to save your configuration to xorg.conf.

Alternatively, you may try, as root, to rename /etc/X11/xorg.conf (if it exist) to something else, and restart X (or the computer) to see if the auto detection mode works.

Hi brunomcl

Yes, i tried the admin mode and i had no effect on it.
And also I tried the alternative, I renamed my /etc/X11/xorg.conf to /etc/X11/xorg.conf.old and restarted X (by logging out and in again). And the effect it had was that now i have black margins also in the login-screen.

So the problem still exists, and, if possible, it is worse…

Please help! :slight_smile:


Then I suppose you’ll have to use the command line aticonfig utility.

First preserve your working xorg.conf by copying it with another name, if all else goes wrong you can always rename it back.

Then try, as root:

aticonfig --initial

You may want to check aticonfig options first, type:

aticonfig --help | more

to see which setting options you may want to tweak.

If you can set the display right with Catalist, you can do it permanently with aticonfig, but it is not very user-friendly, you have some learning to do.

Are you sure? In a notebook I have here running oS 12.1 and Catalist 12.6, Catalist in admin mode will modify /etc/X11/xorg.conf when you change something in video properties and press the Apply button. You can try changing resolution, for example, and after applying the changes check the date/hour stamp on xorg.conf, it should change to the current date/time. You can open xorg.conf in any text editor to see the changes you applied.

Just rename the file back to xorg.conf. Also note that, AFAIR, just logging out and in won’t restart X, you have to go to level 3 (login to console in the login options in the KDE login-screen, don’t know about gnome) and then restart X. Since in 12.1 the startx command doesn’t work anymore (at least as it used to work), I find it easier to reboot.

Hi again!

Now i have done a lot of digging and I have managed to solve it.

I started using aticonfig like you told me and i managed to figure out that i should:

aticonfig --set-dispattrib=<display type>,<display attrib>

to set the overscan attribute to the right value that is “0”. But to get to use it i needed to query the monitor-type by:

amdconfig --query-monitor

which unfortunately gave me the error:

Error: option --query-monitor is not supported when RandR 1.2 is enabled!

And after a lot of help from google i managed to find out that it is not the way i should do this with the new drivers. The new way is:

amdconfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0

and that worked directly. I have to be honest and tell you that i am not entirely sure about what i have done but it worked. And i have no idea if it matters that i changed “aticonfig” to “amdconfig” but they both seemed to work.

So now i am happy. Thank you for the help and your time! :slight_smile:


Doesn’t matter. /usr/bin/amdconfig is just a link to /usr/bin/aticonfig.

Glad you got it working. :slight_smile:

I think you’ll find these options are now in xorg.conf, that’s what aticonfig does, parse and edit the configuration file.