Problems with adding Nvidia repository

When I am trying to add Nvidia repository as a community repo, I am encountering with a problems.
When I make it manually - adding by providing URL - no problems occur.
Observe it only with a first adding of this repository.

“Community repo method” gives me “” address.
Manually I use html address “**/**”.

Difference is in the last letter - slash “/”.

I tested that.

And you are right. If I add the repo as a community repo with Yast Software Repositories, it fails and reports a problem with the repo metadata signature. But if I add with “zypper ar” then I get a good repo.

But here’s an oddity. I first tried this on my main desktop, but I found that I had already added that repo. I don’t remember why I added it, since I do not have nvidia hardware. But it was added. And, by all indications, it was added as a community repo. And it was working just fine.

The content of “” on my main desktop appears to be identical to the content of that file on the system (a virtual machine) where it failed.

Something is broken somewhere, but I’m not sure where.

Community worked when I installed. 15.1 so something has broken since