Problems with Acer Travelmate 7730G

Hallo!
I have installed opensuse 11.0 KDE 3.5 into this laptop, but my soundcard and some other applications don’t work.

My Realtek High Definition Audio (NVIDIA HDMI Audio) does not work!

My Acer Crystal Eye webcam don’t work!

I have also a big problem to use my U96 Optical Wheel Mouse (Logitech USB Mouse) together with my Touchpad.
My Touchpad works good but my Logitech USB Maus don’t work normal.

I hope that someone can help me?

Welcome to our forums, … you can find guidance here to getting your sound card working:
SDB:AudioTroubleshooting - openSUSE

You can provide guidance here to get your webcam working:
HCL/Web Cameras - openSUSE

Thanks!

And where can I get help for my Logitech USB Mouse problem?

SDB:AudioTroubleshooting - openSUSE

I have tried this page out, but if I make the command

speaker-test -Dplug:front -c2 -l5 -twav

it comes this back from my konsole



speaker-test 1.0.16

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left

the sound comes tick from my soundcard.

My soundcards name under YAST > HARDWARE > SOUND > is HD Audio Controller (82801I (ICH9 Family)) driver is snd-hda-intel.

What does “sound comes tick” mean? You should hear a female voice saying “Left front”, “Right front” … 5 times.

If you can not get your sound working with that troubleshooting guide, please provide us some more information (I need really detailed information in order to provide what I hope will be a helpful recommendation). So please, to provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

Once I have that information, I believe I may be able to provide helpful recommendation(s).

I don’t hear a female voice!
I meant when I wrote “sound comes tick” that my sound comes not at once from my soundcard but I hear some sound and this sound is “staccato” or “snatchy” or “choppy”.

I tried your command

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'

into my terminal and as answer comes this out

tsalsa.txt - nopaste.com (beta)

With the command “rpm -qa | grep alsa” comes this

alsa-utils-1.0.16-35.1
alsa-1.0.16-39.1
alsa-plugins-1.0.16-57.1
alsa-firmware-1.0.16-24.1
alsa-oss-1.0.15-48.1

With the command “rpm -qa | grep pulse” comes this

libpulse0-0.9.10-26.5

With the command “rpm -q libasound2” comes this

libasound2-1.0.16-39.1

With the command “uname -a” comes this

Linux linux-h4v3 2.6.25.16-0.1-pae #1 SMP 2008-08-21 00:34:25 +0200 i686 i686 i386 GNU/Linux

With the command “cat /etc/modprobe.d/sound” comes this

options snd slots=snd-hda-intel
# u1Nb.U9oyRIdv6eB:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Please forgive me my “bad” english!

Thank you for good help!

Thanks. I looked at your mixer settings, and I could not see any obvious mistaken settings.

I note your 32-bit openSUSE-11.0 has the latest 2.6.25.18 kernel, with an ALC268 hardware audio codec. Your sound device is using IRQ3, which is IMHO a bit unusual. I hope that is not the cause of the problem, as the choppy/clicking behaviour you decribe could be due to an interrupt problem.

Are you using the ndiswrapper for your wireless?

What does the following give for IRQ3?
cat /proc/interrupts

Anyway, all that aside, lets try to see if a custom setting to your /etc/modprobe.d/sound file will help. You reported:

Please add an extra line on the end of that file, and save it, such that that file reads:

options snd slots=snd-hda-intel
# u1Nb.U9oyRIdv6eB:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=auto

and then restart your audio alsa driver with: su -c ‘rcalsasound restart’ and test your audio with the test I gave.

If that doesn’t work, then in the revised /etc/modprobe.d/sound file, replace “auto” with “acer”, and restart your audio alsa driver with: su -c ‘rcalsasound restart’ and test your audio with the test I gave.

If that does not work you can try some of the other model options for an ALC268. They are listed here for alsa 1.0.16:

	ALC268
	  3stack	3-stack model
	  toshiba	Toshiba A205
	  acer		Acer laptops
	  dell		Dell OEM laptops (Vostro 1200)
	  zepto		Zepto laptops
	  test		for testing/debugging purpose, almost all controls can
			adjusted.  Appearing only when compiled with
			$CONFIG_SND_DEBUG=y
	  auto		auto-config reading BIOS (default) 

And if that doesn’t work, please after a fresh reboot, type the following:
dmesg > dmesg.txt
and then open the file dmesg.txt with a text editor, and paste the output of that file to general pastebin - simplified internet collaboration (the file is too big to paste here) and then submit that file, and post the URL you are given here. There may be an error message in that file that will help provide a hint as to the problem.

I ask this because the ndiswrapper is known on occasion to interfer with one’s sound driver.

Your command “cat /proc/interrupts” gives thisout:

           CPU0       CPU1
  0:      10459      10235   IO-APIC-edge      timer
  1:         37         30   IO-APIC-edge      i8042
  2:          0          0    XT-PIC-XT        cascade
  3:          0          0    XT-PIC-XT        HDA Intel
  4:          0          0    XT-PIC-XT        uhci_hcd:usb7
  5:          0          0    XT-PIC-XT        uhci_hcd:usb2
  7:          0          0    XT-PIC-XT        uhci_hcd:usb5, ehci_hcd:usb8
  8:          1          0   IO-APIC-edge      rtc0
  9:         19         18   IO-APIC-edge      acpi
 10:          0          0    XT-PIC-XT        yenta
 11:          0          0    XT-PIC-XT        ehci_hcd:usb1, uhci_hcd:usb3, uhci_hcd:usb4, uhci_hcd:usb6, sdhc0:slot0, jmb38x_ms:slot0
 12:      11029      11084   IO-APIC-edge      i8042
 16:          1          0   IO-APIC-fasteoi
 19:          0          2   IO-APIC-fasteoi
217:        684        679   PCI-MSI-edge      eth0
218:       6655       6716   PCI-MSI-edge      ahci
NMI:          0          0   Non-maskable interrupts
LOC:      10554      11912   Local timer interrupts
RES:       6825       5956   Rescheduling interrupts
CAL:        382        187   function call interrupts
TLB:        377        344   TLB shootdowns
TRM:          0          0   Thermal event interrupts
SPU:          0          0   Spurious interrupts
ERR:          0
MIS:          0

If I write into the file sound this options

options snd-hda-intel model=auto

and restart the soundsystem with the next command it comes this failure

su -c 'rcalsasound restart'
Shutting down sound driver                                           done
Starting sound driver:  hda-intelFATAL: Error inserting snd_hda_intel (/lib/modules/2.6.25.16-0.1-pae/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
                                                                     failed
linux-h4v3:/home/fmg #

After this my terminal hung up I have to open a new terminal and put this command into my terminal

su -c 'rcalsasound restart'

to restart my soundsystem!!

If I chance “auto” to “acer” the sound comes a little louder from my speakersystem but this sound is also “staccato” or “snatchy” or “choppy”.

How can I chance

the model options for an ALC268.

Thanks!!

Changing from “auto” to “acer” ( … etc … ) is changing the model option. When you get the “staccato” or “snatchy” or “choppy” sound, I presume it is with this test:speaker-test -Dplug:front -c2 -l5 -twavPlease continue to use that as your common test.

Did you have any luck providing this information?

If you recall, I noted above the options for the ALC268, from the ALSA-Configuration.txt file are as listed:
ALC268
3stack 3-stack model
toshiba Toshiba A205
acer Acer laptops
dell Dell OEM laptops (Vostro 1200)
zepto Zepto laptops
test for testing/debugging purpose, almost all controls can
adjusted. Appearing only when compiled with
$CONFIG_SND_DEBUG=y
auto auto-config reading BIOS (default)So for example, you could now try 3stack, toshiba, and dell and see if they work any better than “auto” or “acer”. Restart your alsa sound driver after each change.

If they fail, then lets try updating your alsa modules/driver. There are cutting edge alsa rpms that enable you do make such an update very easy.

To do that, please open a gnome-terminal or konsole, and with your PC connected to the internet, type “su” (no quotes, and enter root password) to get root permissions, and then please copy and paste the following size commands, one at a time, into that gnome-terminal or konsole, and execute the commands.

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.0/ multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.0_Update/ multimedia
zypper install alsa-driver-kmp-pae
zypper rr multimedia

And then restart your PC and test your sound.

What should I do now??

I have maked your updades but nothing is better. Now I hear nothing from my soundcard when I give the command

speaker-test -Dplug:front -c2 -l5 -twav

I get this answer

speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.18rc2

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt
Playback open error: -16,Das Gerät oder die Ressource ist belegt

Do you know another tip for me??

  1. reboot and immediately create and provide dmesg.txt output like I requested.
  2. then update your alsa like I recommended (and then reboot).
  3. then after reboot test your sound.

If that has no luck, I will need you to run diagnostic scripts, and provide list of various rpms that you have installed again (to see exactly where we are).

Where is the dmseg.txt output?

Again, I need to see this.

So, as noted previous … please, to provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa' 

when prompted for a password please enter your root password. Please try to accurately answer the question on the number of plugs/jacks on your PC (for example my PC has 3 i/o plugs/jacks). When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

My dmesg.txt ist here -> general pastebin - dmesg.txt - post number 1203137

What to you mean with this command?

If that has no luck, I will need you to run diagnostic scripts, and provide list of various rpms that you have installed again (to see exactly where we are).

My

rpm -qa | grep alsa

say now this


alsa-tools-1.0.17.git20080715-1.11
alsa-plugins-1.0.16-57.1
alsa-driver-kmp-phttp://forums.opensuse.org/newreply.php?do=newreply&noquote=1&p=1871123ae-1.0.16.20080914_2.6.25.16_0.1-1.1
alsa-firmware-1.0.17.git20080617-2.1
alsa-1.0.17.git20080910-1.1
alsa-oss-1.0.15-48.1
alsa-utils-1.0.17.git20080820-1.1

My

rpm -qa | grep pulse

say now this

libpulse0-0.9.10-26.5

My

rpm -q libasound2

say now this

libasound2-1.0.17.git20080910-1.1

My

uname -a

say now this

Linux linux-h4v3 2.6.25.16-0.1-pae #1 SMP 2008-08-21 00:34:25 +0200 i686 i686 i386 GNU/Linux

My

cat /etc/modprobe.d/sound

say now this


options snd slots=snd-hda-intel
# u1Nb.U9oyRIdv6eB:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=acer

The answer of the command

wget http://home.cfl.rr.com/infofiles/tsalsa && su -c 'bash ./tsalsa'

is here
tsalsa.txt - nopaste.com (beta)

Thank you for your help!!

The output of this command “rpm -qa | grep alsa” came across corrupted, with an http in the middle of the most critical rpm. :open_mouth: Rather than my take a chance on an assumption as to what that rpm is supposed to be, would you please repost that output again for that specific rpm command? Thankyou.

That is all? Only 22 lines?

Typically there are hundreds of lines.