problems with 11.3 and KMS

Hello, I Just installed 11.3 and have some problems. since I installed it the fan is running full speed. I have installed nvidia-texture-tools and vdpau-video-nvidia. That doesn’t work. I read the releasenotes about KMS openSUSE Factory Release Notes. I wanted to try nomodeset when logging in trhu console, but that didnt work cause it started hanging, I didnt reached the console. So I restarted it manually. when it powered up again the taskbar was suddenly black, just like the numbers in the clock. after that ive tried NO_KMS_IN_INITRD trhu yasts etc/sysconfig-editor by setting it to yes. That doesnt work either. Sometimes when I try to enter yast or load something within yast or try to change the settings of the taskbar everything freezes. Do other people have experienced the same problems? im used to bugs in the beginning of the release but I never had such annoying ones, especially the fan and the black taskbar. Does someone have a solution for the fan and taskbar?


So are you using an nVidia video card or chipset as well? A black taskbar means some sort of video issue such as Compositing being Suspended. If you are using KDE you might want to run the Menu / Personnel Settings / Advance Tab / Power Management to see if your CPU is set for Dynamic (on Demand) or Performance operation. On my PC if I set the CPU for Performance, the fan seems to go to full speed, perhaps due to the heat. If I set it for Dynamic, the CPU fan runs at a much slower speed, perhaps due to low heat being produced. You might want to look at the following information, if you have not already seen it.

SDB:Configuring graphics cards - openSUSE

The Kernel run option nomodeset (same as used in the failsafe mode) allows one to load the binary nVidia driver in run level 3 and afterward allows it to continue to load for each session. The NO_KMS_IN_INITRD=Yes seems to prevent loading both the default nVidia driver and the binary driver at the same time, if you loaded the binary driver manually.

These are just my observations so far.

Thank You,


After you change the NO_KMS_IN_INITRD option to yes, you must actually rebuild the initrd. As the root user, run “mkinitrd” and reboot. After doing this, the proprietary nvidia driver worked great for me … :slight_smile:

Thanks, everything works again.