problems using exfat in 42.3

I have a usb thumb drive formatted to exfat
in 42.3 have installed exfat-utils & fuse-exfat (exactly the same setup I had in 42.2)

When I plug in my drive I can mount it and browse it but as soon as I try to open a file something goes wrong.
I’m trying to open some jpeg files in gwenview and as soon as I try opening one the image half loads then I get a popup message

Could not enter folder /run/media/farcus/TOSHIBA/Pictures

If I open up dolphin I can see that the drive is no longer mounted (or at least it is no longer present in “/run/media/farcus . . .”
However, device notifier still shows the drive as mounted.
If I try to open the drive again from device notifier I get the message

Unable to run the command specified. The file or folder /run/media/farcus/TOSHIBA does not exist.

This all worked perfectly for me in 42.2 with the same drive.

For an issue like this,
You should always post the exact command that’s failing.
Without that, we’re guessing exactly what you’re doing and whether there might also be a simple syntax error.

TSU

Check permissions

ls -lh  /run/media/farcus/.......

permissions look fine before I try opening a file

farcus@linux-aw6a:~> ls -lh  /run/media/farcus/TOSHIBA
total 128K
drwx------ 1 farcus users 64K Jul 29 16:04 **Pictures**
drwx------ 1 farcus users 64K Jul 29 09:54 **System Volume Information**
farcus@linux-aw6a:~> 


For an issue like this,
You should always post the exact command that’s failing.

I’m not actually running any commands.
I simply double click a jpg file and it opens Gwenview . . . then I get this
https://paste.opensuse.org/view/raw/97997312
https://paste.opensuse.org/view/raw/97997312
https://paste.opensuse.org/view/simple/97997312
https://paste.opensuse.org/97997312
SUSE Paste can see it starts to load the jpg but then fails.
If I navigate to
/run/media/farcus/
[FONT=arial]the drive is no longer present

it seems to be related to exfat. My usb drives formatted in fat32 and ext4 behave just fine
[/FONT]

Hi
Are all the devices USB 3 or 2, using USB 2 or 3 ports on the computer?

flash drive is usb 2.0 and the usb ports on my laptop are also usb 2.0
My system doesn’t have any usb 3.0 ports

Hi
Have you checked the filesystem on the device is ok?


mount |grep media

/dev/sdc1 on /run/media/malcolml/E692-E5DB type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

fsck.exfat /dev/sdc1

exfatfsck 1.2.4
Checking file system on /dev/sdc1.
File system version           1.0
Sector size                 512 bytes
Cluster size                 32 KB
Volume size                7787 MB
Used space                   32 MB
Available space            7756 MB
Totally 1 directories and 10 files.
File system checking finished. No errors found.

Tried a different USB port?

so I guess something must have become corrupt on the drive . . .
I plugged the drive into a win10 computer and it was able to read/write just fine. So while there I copied the data off the disk, reformatted the drive in exfat and then put the data back onto the disk.
It seems to be playing just fine with 42.3 now

When an graphical app fails, your SOP should be to execute the command in a console because you may see more detailed error mesages.

So, for instance, I assume that the default behavior of double-clicking on a file is to run the following in a console

gwenview *some_file.jpg *

I’d first use a console to check whether the specified path exists. Maybe gwenview is looking in the wrong location. Permissions might be an issue but I doubt it.

Whether the location exists or not,
You should use the console command as at least part of a standard troubleshooting process.
It’ll also force you to verify the exact location of the file.
Run from the location of the file

gwenview *somefile.jpg *

or, if your console isn’t in the same location as the file

gwenview* fullpath_to_somefile.jpg* 

Permissions might be an issue if you set up your thumbdrive without configuring permissive permissions.
After verifying location, maybe use “kdesudo”

kdesudo gwenview* fullpath_to_somefile.jpg* 

TSU