Problems updating or dowloading certain softfware openSUSE 11.4

This is my first post so apologies if it’s in the wrong section

I’m not a Linux expert but have been using Suse since version 9.0. I installed opensuse 11.4 about two weeks ago and this time I reformatted my hard drive and did a fresh install. The installation appeared to go through OK without any problems. I ran the updates during the installation process which again was successful. The problems I have experienced have been trying to install either acroread, vlc or the restricted formats either through one click install or manually. Software manager always hangs on downloading either, acroread, vlc-Nox, or in thr case of one click install Ladspa. It’s always the same files and the same place. I’m now getting the same problems with updates, either using yast online update, KPackageKit or booting into failsafe and trying to update or download from there.

I’ve reinstalled the system several times and still had the same problems every time, the same files hanging in the same place. I even tried installing from a different DVD(from a magazine rather than my downloaded one) but got the same problem.

The error I get is like this for the update

Cannot access installation media http://downloadopen suse .org/update/11.4/updates for openSUSE 11.4 11.4-0 (Medium1)
Check whether the server is accessible

Timeout exceeded when accessing ‘’.

I get the same when trying to install acroread, vlc, or the restricted formats but it obviously points to the appropriate repo. I’ve even tried changing mirrors but still get the same problem with exactly the same files at the same point. Other programs can be downloaded through the software manager without any problem such as audacity, chkrootkit, aide.

the output from zypper lr -d is

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
1 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |
2 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | No | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-ARTEC_BKM-52X16,/dev/sr0 |
3 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.4/repo/oss |
4 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
5 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
6 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.4/repo/oss |
7 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.4/repo/oss |

I’ve been struggling with this for about two weeks now and never had any problem of it’s kind before with openSuse. Version 11.3 updates and downloads software with no problem on this PC and I’ve just tried Ubuntu and that installs and updates with no errors as well. I don’t think this is an ISP problem regarding file sizes etc as I can download the DVD images.

Can anyone help me please and is anyone else experiencing this problem? I’ve trawled the forums but can’t find this problem elsewhere. I always been able to fathom out any problems I’ve had with previous releases but this one has got me. Again apologies if this is posted in the wrong section or this problem has been posted before.

Many thanks


Make a

# zypper refresh

Send the output here.

Retrieving repository ‘Updates for openSUSE 11.4 11.4-0’ metadata [done]
Building repository ‘Updates for openSUSE 11.4 11.4-0’ cache [done]
Repository ‘openSUSE-11.4-Non-Oss’ is up to date.
Repository ‘openSUSE-11.4-Oss’ is up to date.
All repositories have been refreshed.

Your updating problems has already solved with zypper refresh.

Downloading problem now

# zypper install celestia

This is output:

zypper install celestia

Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following NEW packages are going to be installed:
celestia kde3-i18n-en_GB kde3-i18n-en_GB-base kdelibs3 kdelibs3-default-style libart_lgpl_2-2 libdns_sd libpng12-0 qt3

The following recommended package was automatically selected:

9 new packages to install.
Overall download size: 53.2 MiB. After the operation, additional 123.2 MiB will be used.
Continue? [y/n/?] (y): y
Retrieving package kde3-i18n-en_GB-base-3.5.10-14.2.noarch (1/9), 1.4 MiB (5.2 MiB unpacked)
Retrieving: kde3-i18n-en_GB-base-3.5.10-14.2.noarch.rpm [error (3 B/s)]
Timeout exceeded when accessing ‘’.

Abort, retry, ignore? [a/r/i] (r):
Trying again…

I’ve also just tried online update again and that’s not working either, still hangs in same place as before. I’ve tried refresh before but doesn’t seem to make a difference.

Many thanks,


You are ok now. Maybe a problem with connection you had.

Hi Stamos,

I probably wasn’t very clear with my last answer. I still have the same problem. Downloads and updates do not work. I don’t think it’s a connection problem as I can download from other sites using the browser. It’s just updating opensuse ans installing new packages where the problem is.

Have you tried different mirrors?
are you using proxy? or in a Campus?

Yes, I’ve tried different mirrors several times but always fails at same point on same files. Not using proxy, not in campus.
What I don’t get it only happens on 11.4, and it will update ok during the install process. It only seems to be certain files that are not downloading as many will download with no problem.

Not sure.
You could disable all repos except the DVD, you used the DVD?

Then make a local repo of the current Update repo
That would let you update to current level

Then try again

But with a zypper refresh you have posted me the output

Retrieving repository ‘Updates for openSUSE 11.4 11.4-0’ metadata [done]
Building repository ‘Updates for openSUSE 11.4 11.4-0’ cache [done]
Repository ‘openSUSE-11.4-Non-Oss’ is up to date.
Repository ‘openSUSE-11.4-Oss’ is up to date.
All repositories have been refreshed.

Ahhhh I see now

Timeout exceeded when accessing ‘’.

Here is the problem.

And now I Understand.

As I can see in output the problem based on openSUSE-11.4-Oss. So try with a different mirror.

Yes I did use DVD to install, but after several attempts to add packages or update failed, I disabled it thinking it might help.

Not sure what you mean by making a local repo, do you mean copying the repo to Disk? if, so how is that done?.

I have tried different mirrors, the problem is always the same

Try with that mirror
Index of /distribution/11.4/repo/oss
In openSUSE-11.4-Oss repo

These are my repos. Check with URLs

# | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                               | Service
1 | Packman Repository               | Packman Repository               | Yes     | Yes     |   99     | rpm-md |                       |        
2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md |                         |        
3 | libdvdcss repository             | libdvdcss repository             | Yes     | Yes     |   99     | rpm-md |                              |        
4 | openSUSE-11.4-11.4-0             | openSUSE-11.4-11.4-0             | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-_NEC_DVD_RW_ND-3520AW,/dev/sr0 |        
5 | repo-debug                       | openSUSE-11.4-Debug              | No      | Yes     |   99     | NONE   |    |        
6 | repo-debug-update                | openSUSE-11.4-Update-Debug       | No      | Yes     |   99     | NONE   |                   |        
7 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2  |      |        
8 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2  |          |        
9 | repo-source                      | openSUSE-11.4-Source             | No      | Yes     |   99     | NONE   |   |        

Hi Stamos,

I looks like I’m using the same repos as you are using. I’ve just disabled the update repo and tried to install acroread but it stops again in exactly same place at 99%. then download speed dramatically drops to about 1 or 2 b/s and then error message appears, as it always does.

It worries me that I cant do security updates. I don’t have a problem getting updates or downloads on any other op system I install on this PC, including Ubuntu, Linux Mint, earlier releases of Suse, or even Windows. I only get the problem with 11.4.

Thanks! I was having a problem with the YaST updater. The openSUSE-11.4-Update kept failing with a curl error (?) on So I tried zypper

$ sudo zypper refresh

Repository ‘openSUSE-11.4-Source’ is up to date.
Retrieving repository ‘openSUSE-11.4-Update’ metadata [done]
Building repository ‘openSUSE-11.4-Update’ cache [done]
All repositories have been refreshed.

The update ran just fine.

Now on to figuring out gPodder 2.14’s “global name ‘keymap’ is not defined”

On 04/14/2011 02:06 PM, akwatton wrote:
> I have tried different mirrors, the problem is always the same

@akwatton, there was another here (last week i think) with almost
exactly the same problem on 11.4, see here:

maybe one of those will be helpful…i think there may be a bug in there
somewhere that needs to be logged to bugzilla…if you can find the
reproducible path to failure please post the bug, see here:

[you may not want to call yourself an expert (neither do i) but, with
experience from 9.0 and forward, i have confidence you can do this
right! if you do log one, please return here with the number/link so
others who google in can get on your path. tia]

[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]
Q: Why do you upgrade?
A: Because the Gecko is always greener on the other side!
So said k428 in

Thanks DenverD for pointing me in that direction.

The problems indeed do look very similar, although the others seemed to get a work around by logging into failsafe mode. I’ve tried this but still get the same problem. They probably won’t appreciate me saying this as it doesn’t fix anything, but I’t’s reassuring for me to know that others are having problems with this as well. I was beginning to think it was me. I’m sure it’s a bug now, but a very quirky one!

I had though like one of the others that there may be a conflict with Kpackagekit. I might try and uninstall it as see what happens. Strange thing was though when I first installed about two weeks ago kpackagekit was working, it was just trying to add certain other packages that was the problem. Now it seems to have got more widespread over the last day or two and affecting updates as well. I bet if I re-install the system again after fdisk to ensure a ‘clean’ installation, the initial update performed during the install will work. It has done every time so far.

On 2011-04-14 12:06, akwatton wrote:

> Timeout exceeded when accessing
> ‘’.

Ok, then try downloading that file using wget, and then try with different
mirrors. Then post the results here (between code tags (advanced edit)).

This problem is typical, it seems, of people being in some kind of
corporate network, or in a campus; the kind of network that has a proxy
that caches the files and serves the file from the (bad) cache instead of
the real thing. It has even been the case that some ISPs have a transparent
proxy causing that problem: they cache the file by name.

At least, that is what it seems.

But it does not make sense when those people can download the same file
from the same place using 11.3, for instance, or using 11.4 in safemode. It
does not make sense, but those people that had the same problem as you,
could download the same file booting again in failsafe.

This problem has happened to several people, we don’t know the cause.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

You could try a level 3 boot
Like this:

login as user

become su -

zypper up

A local repo is where you download the contents of: Index of /update/11.4
And store it on the computer as a local repo
I use gftp to do it

Then add it to yast with just the DVD enabled