Problems trying to install 13.1


I’m trying to install OpenSuSE 13.1 on a computer equiped with a ECS 760GX-m motherboard and am having video problems. For starters I’m trying the live KDE DVD. I get the initial menu, the splash screen, and even entered into line/text mode, but apparently when KDE starts is when the video os messed up. The top third of the screen will be a color pattern of some sort while the lower two-thirds of the screen is black. I’ve also tried another video card in the AGP slot as well as an old PCI video card in the PCI slot but ends up the same way.

Any ideas on how to remedy this situation?

Am I right in thinking this is an old motherboard? You may need to use a lighter desktop such as LXDE or even openbox. I believe both are available from the Main DVD disc but it isn’t a livedvd, just an installation disc which also weighs in at 4.7GB. If this is an issue and you want to try my theory out without committing to a large download then you could try Chrunchbang; it uses openbox desktop and is much more suitable for older hardware. If It does work then you can either stick with it or try the installation DVD from opensuse.

LiveCD will not work for you as it comes with a full desktop that is too heavy for the hardware.
try to get the full DVD and use something like LXDE or liter desktop.

I had the same issue with my laptop because of nVidia graphics card.
full KDE would not run on it at all until the proper nVideo drivers were installed.
but to do so was a quest in its own.

I’m not of the opinion that KDE is “too heavy”. But this is obviously a graphics driver problem.
It could very well be that the sis driver isn’t working very well any more. (strange though that you would have the same problem with two other cards as well? Are they all SIS based?)

You could try the XFCE LiveCD (“Rescue CD”) , but it might have the same problem (or maybe not).

I would suggest to press ‘F5’ and select “Safe Settings”, or try to add “x11failsafe” (maybe in combination with “nomodeset”) to the boot options (just type that at the boot menu). Then the KDE LiveCD should work as well (using the fbdev driver instead of sis).

On second thought:
It could be that in this case maybe the generic “modesetting” driver is used (not “sis”) and has problems with the card(s).
So just specifying “nomodeset” on the boot menu (or pressing ‘F4’ and choosing “No KMS”) might be sufficient.

I would guess that it is an older motherboard as it has been a while since I’ve worked on this machine. One thing I like about OpenSuSE is that it could work with the older machines and still out-do Windows. By the way, this machine ran Windows XP. The other video cards are non SiS based. As a matter of fact the oldest video card probably has a 256k buffer and fits in a PCI slot.

Will give your suggestions a try and report back.

Thank you!

I do feel that KDE on LiveCD is too heavy for some older hardware and/or when an nVidia card is used. reason for my POV is I had tried booting using LiveCD KDE and Gnome on my laptop (6 yo HP pavilion with an nVidia card) and not a good results on both. the system was practically unusable.
installing from DVD using full KDE resulted in same.
installing from DVD using light weight desktops worked from the get-go with the system driver. I think full KDE or Gnome install has too many bells and whistles turned on by default that coupled with an unsupported out of the box video card simply does not work.

on system where video card is supported it is not an issue.

But those video problems have nothing to do whether KDE “is too heavy” or not.
Those are issues with the driver.

Of course KDE uses the driver in different ways than other Desktop Environments, but that doesn’t mean that in the OP’s case they would not have any problems.

And GNOME3 is a completely different story. GNOME’s window manager requires OpenGL, so if that is not supported by the driver, everything will be sluggish because it uses Mesa’s software 3D renderer then (I noticed that during the weekend when I tried a GNOME install in VirtualBox for the first time ever).
KDE’s kwin works without OpenGL, and even turns it off automatically if the driver doesn’t support it. There are problems of course if the driver claims to support it but doesn’t work fully, as can be the case with nouveau (that happened in your case I suppose).

Of course KDE needs more resources than XFCE f.e., but that is not the issue here.
The OP has corrupted graphics, no mention of KDE running slowly.

Please note, that I’m not saying that KDE will run perfectly fine on this hardware, it might or might not, that also depends on other factors like the amount of RAM of course.

sorry I guess I need to clarify what I am saying.
I did not mean that KDE or Gnome are heavy and run slow per see.

what I have seen several times I tried to load OpenSuse 13.1 on my laptop is that if you use LiveCD or Install DVD and choose to install full KDE desktop for example
it installs with all bells and whistles turned on by default.
this could be (an was in my case ) an big issue that seams to me OP is come across as well.
if the basic default video driver is not compatible with your video card things all the superficial effects features make system unusable and only get in the way.
when I first did the setup on my laptop it took me several hours to run through all the things I needed to find and install video drivers that worked on my system.
it was like doing it blind, by feeling the needed buttons and prompts.

no when I loaded LXDE it just worked. nice and easy.
the default generic driver handled my video just fine giving me perfectly usable system. and installing the nvidia driver took less than 20 min including the search for it.
in fact I had just reinstalled the whole thing from ground up on my new SSD
and did not even bother installing the nvidia drivers at all. my system just work with generic. watched movie and all.

so if you come across situation like OP I say first thing first try loading lighter desktop and see if it can handle your graphics. then go from there…

I suggested this as well in my first post.
But even XFCE might have problems with a sis chip, when:

The top third of the screen will be a color pattern of some sort while the lower two-thirds of the screen is black

(depending on which driver is used)

And again, KDE should automatically switch to XRender and turn off most desktop effects when the driver doesn’t support OpenGL. It doesn’t with nouveau, since nouveau claims to support OpenGL. And as I understand it that’s why you had problems, because nouveau’s OpenGL support apparently has problems with your card. It (and KDE’s desktop effects) works fine on some nvidia cards (one is even a stone-old Riva TNT 2) here even with nouveau, btw.

I do not dispute this. the full KDE/Gnome(I did try both.) install was very uncooperative in my case.
mind you after the proper nVidia drivers were installed all was working ok.
not great as the system was very slow, not at all what I had expected from Linux.
but with LXDE it is very nice and responsive, even better now as I had it installed on new SSD.
I like it very much.

Just to let you know, the second and main video card I’ve been trying to use is an ATI Rage 128 Pro since it is one of the very few video cards I have laying around. One of the other things I’ve tried is pressing the F4 key and setting it to safe mode, which didn’t work either. Nomodeset didn’t work. Couldn’t press F4 and and select nokms as there wasn’t an option for that, but I did type in nokms and that didn’t work either.

Well, I don’t think the r128 driver is in good state either unfortunately.

One of the other things I’ve tried is pressing the F4 key and setting it to safe mode, which didn’t work either. Nomodeset didn’t work. Couldn’t press F4 and and select nokms as there wasn’t an option for that, but I did type in nokms and that didn’t work either.

Right, both the sis and the r128 driver don’t support kernel modesettig, so that’s why nomodeset doesn’t help (it would only prevent the “modesetting” driver from being used, which might help with certain cards).
The “No KMS” option with F4 would be the same as specifying “nomodeset”.

Have you tried to enter “nomodeset x11failsafe” as boot options as I suggested as well?
This would force the use of the fbdev driver, which should work with all cards.

I certainly agree with this. I have several machines running openSUSE with nVidia cards, and am very pleased with them all.

Well I tried Linux Mint and that had problems too. Installing OpenSuSE for something like six releases has never been a real issue before. Suspect Linux has problems with the SiS video card and/or the SiS chipset. Well I put in place Windows 7 on the machine and that should be OK.

Thanks for trying!