Problems to install 13.2 dual boot with win 7


I am having problems to instal openSUSE 13.2 and hope someone could help me to fix things.

I just bought a new computer with one hard drive for Windows 7 and another for openSUSE.

I installed Win 7 without problem. I also installed the usual applications, like Firefox, Skype, etc.

When I started the computer with the 13.2 install DVD (MD5 and SHA 1 verified OK) and chose the menu option “Install”, the system started the process and a lot of lines where printed on the screen, but after 2-4 minutes everything froze after printing the lines:
>>> openSUSE instalation program v5.0.26 (c) 1996-2014 SUSE Linux Products GmbH <<<
Starting udev…

The same hapens when I chose the menu option “Verify Media”.

Thanks for the help!

The download or burn to DVD (maybe?) is bad using a torrent it can fix it if it is the problem is in the download. Or download again and follow instruction on the download page to check the check sums of the file.

Thanks for your answer, but I have burned 2 install DVDs and one KDE live DVD, and verified both MD5 and SHA1. The results were quite the same: the instalation stals at some point, after displaying a bunch of lines. The same behavior occurred with the openSUSE 13.1 DVD.

It seems to be some component on my computer wich is not correctly recognised or some fine tunning of the bios.

My hardware is:
mother board Gigabyte GA-H97-D3H
processor intel i7 4970 3.6GHz
16 GB memory
Graphic card PNY GTX970
DVD driver Asus BC-12D2HT
two HD seagate 1TB

So you did both check the check sums on the downloaded iso and run the check media from the boot menu??

May be the video card that is one of the newer NVIDIA cards. If you have fully verified that the download is 100% correct and the media check has been run and it passes

At the boot press e to enter edit mode
find the line start linux go to the complete end of that line (it wraps) and add a space and nomodeset. This will force a less advanced driver and should let you proceed to install. If you succeed in installing you can install the NVIDA driver to get all the gooey goodness out of that awesome card.

Hello there,

Another chapter of my trials and tribulations:

I found a CD with Ubuntu 9.10 (karmik koala) and, just for fun, I tried to install it and it worked…
Well, I didn’t go all the way but it worked well till the point of initiating the partitioning procedures and then I quit.


Different OS different kernel different video driver at install. Apples and oranges

Yes, after the download I checked the sums. Then I tried to check the media using the menu option “Check the intall media”, but after a while the computer stalled and I had to reboot.

I did the trick and the instalation started normally, but I had to abort in order to have time to learn about the new technologies like UEFI, GPT and some new file systems…

Again, thanks a lot for your help!

EFI is not hard just be sure to boot the media in EFI mode. Note if you don’t see options at the bottom of the screen then you are in EFI mode the options only show in legacy.

As a further check but should be automagic. You should have a FAT formatted small partion for the EFI boot it should be mounted as /boot/efi (may already exist if dual booting)
Should have 3 partition swap (~1-2xRAM), root (40+ gig if BTRFS file system or 20-30 if EXT4), home the rest of free space or what tou want to give it, The boot should be via grub2-efi. If secure boot is set in the UEFI then you will want to check the box for secure boot. Always carefully look at the final partitioning scheme to be absolutely sure it is what you want and you fully understand it. Nothing is done until you accept that screen. But then you are committed. Ask here if you don’t understand something.

Good luck

I´ve done everything like you said, but using ext4 all araound. The only issue is that I always have to choose the start up device on the bios menu every time I want to use Windows 7 (it´s not a big issue since I don´t use it frequently). There is no Windows option on Grub menu, although I have access to the windows disk (as root). I´m very happy with the present instalation and the minor problems will be resolved as soon as I get more aquainted with these new technologies. I hope in the future to be of some help in this forum…

Thank you for you help!

Unless you tell it otherwise I understand that Windows 7 installs in the old MBR format or hybrid mode. Chaining the OS’s one in MBR the other in EFI does not work.

You might look in the /boot/efi directory and see how the windows files look. Are there Windows files there? if not it is MBR booted and the system is hybrid. Some BIOS work that way some don’t. If there is a windows director there then we should be able to chain from grub2

Yes, windows 7 was inatalled via MBR and everything is working fine. I will wait the Windows 10 and see if it is worth putting everything in EFI mode.

Besides the main and swap partitions I have a third partition named EFI, with two subdirectories:

|_ boot
| |
| |_ bootx64.efi
| |_ fallback.efi
|_ opensuse
|_ boot.csv
|_ grub.cfg
|_ grug.efi
|_ grubx64.efi
|_ MokManager.efi
|_ shim.efi


You can install Win7 in EFI mode it just does not support secure boot.

Also note that is it best to have also a separate home partition . It makes upgrades or OS change sooooo much eaiser