Problems syncing GPT / MBR partitions tables on OS-X and Opensuse dual boot

I’ve been successfully dualbooting OS-X and various debian based linux distros for a while now on my macbook pro. I use rEFIt. gptsync gives me the following error message:

Current GPT partition table:
 #      Start LBA      End LBA  Type
 1             40       409639  EFI System (FAT)
 2         409640    390772495  Mac OS X HFS+
 3      390772736    620943359  EFI System (FAT)
 4      620943360    625141759  Basic Data

Current MBR partition table:
 # A    Start LBA      End LBA  Type
 1              1       409638  ee  EFI Protective
 2         409640    390772494  af  Mac OS X HFS+
 3 *    390772736    620943358  83  Linux
 4      620943360    625141758  82  Linux swap / Solaris

Status: Analysis inconclusive, will not touch this disk.

Is there any way to force the partition tables to sync? Currently, I have to use the OpenSUSE live DVD to boot into my OpenSUSE install. Any help would be much appreciated.

Don’t know if you are beyond this stage but there is a good description of the issues in the System Rescure manual at Sysresccd-Partitioning-EN-The-new-GPT-disk-layout - SystemRescueCd. As openSUSE still uses legacy Grub by default, you need to install Grub2 to enable you to take advantage of GPT; the next chapter in the System Rescue manual covers this.

I fixed the problem I was having by booting from a live CD and using gparted to remove the boot flag from my opensuse partition. After I did this the partition tables synced and I had no problems booting.