Problems setting permissions on NTFS partition

Hi everyone.

I’ve recently installed an OpenSuse 11.2 in what I’d like to be a definitive jump from windows environment.

I’m not very confident yet with my linux skills, so at this moment I’ve yet have both systems installed with a data NTFS partition to store music, movies, documents, and general data that I’d like to use in any of the two systems.

The NTFS partition has no writting permissions for anybody except root user, so I can’t work anything from my personal user without starting an app like su or login as root.

I want to change this by making a group (windowsWriters) where my usual user is included wich I pretend to make the group owner of NTFS partition.

I’ve created the group and inserted my user into it, but I’m unable to change the owner group nor any permission on NTFS partition or any of it’s subdirectories.

I’ve tried to made it through opening dolphin as su (Alt+F2 kdesu dolphin) and through chmod in consolemode logged as root, in both cases the action seems to work correctly and no error is spotted, however when I look again at the partition/folder/file permissions/ownership no changes have been made.

What could am I losing?

I assume that the NTFS is mounted at boot. Post the output of

cat /etc/fstab

You can set permissions in that file. But first we need to see what is there.

Both, system and data partitions are mounted as proposed by default in installation.

Here the result of the fstab:
/dev/disk/by-id/ata-ST3200827AS_4ND4LGBP-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-ST3200827AS_4ND4LGBP-part6 / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-ST3200827AS_4ND4LGBP-part7 /home ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-ST3200827AS_4ND4LGBP-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=es_ES.UTF-8 0 0
/dev/disk/by-id/ata-ST3500320AS_9QM4B9NC-part1 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=es_ES.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Chown and chmod don’t work on NTFS partitions because they’re not Linux filesystems. You control the permissions from the mount command; e.g. the line for the partition in fstab.

Ususlaay you can make an NTFS mount in fstab world-writable by making your mounts like this (edit of existing):

/dev/disk/by-id/ata-ST3500320AS_9QM4B9NC-part1 /windows/D ntfs-3g locale=es_ES.UTF-8 0 0

That chopped out these options which were constraining the mount to be root-only writable: users,gid=users,fmask=133,dmask=022,

FFI read here: HowTo Mount NTFS Filesystem Partition Read Write Access in openSUSE

If you really want to adhere to your plan, this will make the partition writable owned by user “suzette” and group “windowsWriters”:

/blah_blah-part1 /windows/D ntfs-3g uid=suzette,gid=windowWriters,umask=0022,locale=es_ES.UTF-8 0 0

and this will make it owned in the more-usual Linux fashion by suzette:users

/blah_blah-part1 /windows/D ntfs-3g uid=suzette,gid=users,umask=0022,locale=es_ES.UTF-8 0 0

Thank you both. Swerdna, the link you provided resulted very useful, now I have my desired environment.

A couple of questions come to my mind, I wonder if you could answer it if you dont mind.

I supose that “suzette” is some nick of opensuse root. Is that correct or am I nobbing loud and clear?

Respecting permissions masks, what is the logic that applies to assign a number to any rwxrwxrwx permission string? I remember something about adding values of every permission to obtain a final value, but I’m not so sure of how that it worked…

I guess ‘suzette’ is from creativity, never heard it as a nick/alias.

About the logic of ‘rwxrwxrwx’:
it’s three parts, for owning-user :: owning-group :: others
Each parts has three bits for switching read write and exec/access on/off (1/0). So rwx → 111, r-x → 101. If you now convert the binary number to decimal you will see that rwx → 111 → 7, r-x → 101 → 5, rw- → 110 → 6 etc. So chmod 664 means rw- for the owner of the file/folder, rw- for the group, r-- (read only) for the rest of the world.
Hope that makes things more clear for you. It’s a good thing to study this and get to understand it, makes life on a linux machine easy.

lol briefly. I was obscure. I should have said: if you want to mount it with yourself as the owner, use your username in the “uid=” option in the mount command. And I just used suzette as a typical example. [and I often use that name because it’s the name of the mother of two of my grandchildren :)]

The logic of permissions? Yes there is an aritmetic way to sort out the so-called “mask”. I can never remeber it so I have a reference that I refer to: Notes on chown and chmod

Ok, understood. I’ve studied it long ago, but I simply couldn’t remember. Thank you.

Np lol! It’s good to make some noobing. I think of it at the beginning… but… Suse –> Suze –> suzette… well, it has some sense in my twisted mind…