Problems right after logging in.

I’m not sure if this is the right place for this, but I’ll explain anyway.

First off, I’m new to openSUSE. I just installed it a few hours ago as I was facing issues with other distros, but I’m really loving openSUSE. Anyways, right after logging in, I face an issue of my entire desktop being unresponsive. The only thing that seems to work is the Activities tab of Gnome 3’s panel. But, even that’s not fully functional as I cannot open any applications from it. I can only switch the dashboard (or whatever it’s called) on and off. The only work around is that I have to put my computer in Suspend and wake it back up. Right after that, everything is fully functional and I don’t run into any issues after that.

I understand that this isn’t much information to go off of, but any help would be greatly appreciated. Here are some of my specs, for what it’s worth:

CPU: AMD Phenom II X4 955
GPU: Nvidia GTX 660ti

I tried going through the logs to see if anything happens, but the log file just grows insanely too big by the time I suspend my system and wake it back up.


you ether love it or hate it
me , i dislike it so

your “problem” sounds like a not configured Gnome 3 install ( i found gnome3 unusable for my daily work ) others do not

– your choice –

i would use the xfce of kde desktop
xfce is a bit more like Gnome2 was

I would suggest to install the proprietary nvidia driver:

For your card you can use the latest one (G03), labelled “For GeForce 8 and later” on that page.

As GNOME3 unconditionally uses OpenGL AFAIK, this should definitely speed things up.
And it might even solve your unresponsiveness problems.

This definitely sped things up, but I’m still facing the unresponsive issue. I’m going to try out KDE to see if that helps.

And which version of openSUSE is that?

It’s openSUSE 13.1. I installed KDE and I have the same issue, but a logout alleviates it.

I can’t seem to edit my original post, but I finally figured it out, guys. It was my freaking mouse. It was the mouse causing the seemingly graphical hiccups. FYI, don’t use a gaming mouse that has different modes with linux, because it doesn’t play well. I had to make a custom xorg.conf file to disable the mode button because it would cause certain processes to not recieve input from the mouse. I can’t believe I completely overlooked that. Anyways, I’ll post a link to a fix (Ubuntu community):

You may have to customize the script depending on your mouse if you end up having the same issue and it’s possible that this only works for the Mad Catz cyborg/R.A.T series of mouse.

Nice you found it.

BTW you can not edit your original post because that would falsify what you posted and it would probably create a confusing sequence of the discussions.