Problems right after installation

Okay, well I downloaded OpenSUSE 11.4 and installed it on my PC, this Friday. Since then, I’ve installed it like 7 times and the most I can get to, is launching the failsafe. I’ve checked the disk’s content, scanned it, bought a new DVD, to make sure the one I was using wasn’t scratched or anything, I even tested my laptop to see if that was the problem, and no errors anywhere. I’ve searched and searched, but haven’t found anything that can help me. I have reason to believe that the problem with the installation is that it never gets to the Automatic Configuration part, because whenever it finishes installing, it can never restart on it’s own. I always end up pressing the power button because the screen just goes black. And I’ve just left it there, to see if it didn’t restart on it’s own because it needed some time, but I doubt it needs more than half an hour for it to successfully reboot. Am I doing something wrong? Is there something I should know? Is there a trick to it? I need help, I’m a student, I need my laptop!

What video card/chip do you have? It sounds like a classic problem with the video. Does it start ok in failsafe mode? Note that is not a solution just gives you the chance to fix things.

BTW simply running the media check option in the first install menu will tell you if the disk is good or not. No need to buy another. The download is free in any case.

It’s a Mobile Intel GM45 Express Chipset. Can I do anything about this? I already erased Windows, and I’m in desperate need of a good OS.

What’d you recommend?

Yes, it starts fine in failsafe. I did notice that my wireless does not work. Is that because of the failsafe?

Did not answer my question does it boot to the desktop if you select failsafe?

Yeah, it boots in failsafe…

My wireless does not work, I noticed. Is that because I’m in failsafe?

I successfully installed openSUSE 11.4 on my netbook but now I’m having the same exact problem as the OP with my desktop, which worked fine under 11.2. I’ve tried installing via DVD and USB (the same as the one I used for the netbook) - no luck. The system goes blank (no more keyboard even) after the reboot after the initial install. The Automatic Configuration doesn’t run. I’ve discovered that powering down and then booting the system into failsafe immediately after does allow the system to go into Automatic Configuration, which completes and then goes to the login screen. Unfortunately for me, the network interfaces don’t work so I can’t continue the install and get all the Patches.

I’m basically stuck. Further reboots go to the same frozen state.

@BClass: Though 11.2 is old and losing support, it’s been the best install of openSUSE I’ve had. If you need your machine back, maybe try it.

I tried a clean install of 11.2 and then upgrading to 11.4. This led to the same blank screen/hang.

Thoughts anyone?


You might want to read this

openSUSE Graphic Card Practical Theory Guide for Users

I use NVIDIA graphics so can not be much further help.

I use NVIDIA graphics too. I’m able to cleanly install 11.2 and install all the patches. And until recently, use one-click to install the NVIDIA drivers.

Under 11.4, the system doesn’t come back after the reboot. A power down, then failsafe allows the install to continue to Automatic Configuration and GUI login. From here, the network interfaces aren’t recognized even though the chipset was recognized. Without the network, it’s not possible to get patches or one-click the NVIDIA drivers.

I know what’s happening! The screen doesn’t go black, the brightness just drops a lot. The computer is still on, though. The only way I can boot without failsafe is if I turn on the laptop and just close the lid. For some reason, when I open the lid, it’s completely booted and I can use it normally. Though my wireless still doesn’t work.

I’m up and running with 11.4…

  1. booted from DVD

  2. instead of using the GUI, I switched to text mode install

  3. installed 11.4 packages

  4. system rebooted to blank screen

  5. powered down

  6. powered up again and selected text mode

  7. Automatic Configuration takes place

  8. system goes to GUI login

  9. logged in

  10. network up

  11. YaST and installed all patches

  12. started up Firefox

  13. installed one-click for NVIDIA drivers, media drivers

  14. rebooted

  15. switched off Pulse Audio for microphone on webcam to work