Problems, problems - nVidia and VirtualBox

I had some serious problems with my installation last week, following a failed Skype install. No YaST, no KDE - prompting me to upgrade to 11.1, 64-bit. All my data was backed up before I did this.

The problems have been replaced with new ones…

Firstly, nVidia. I’ve tried the one-click install, I’ve tried the hard install from the nVidia site, I’ve tried various things…but to no avail. I have the nVidia control panel installed, but when I run it, it tells me that I need to use ‘nvidia-xconfig’ - all well and good, but having done that, my XWindows fail and I only get a console window. Can anyone help with that?

Secondly, I had VirtualBox installed. I’ve re-installed it, but my new installation won’t open my backed up virtual system (Windows XP). I need it for one program only. I get a “VERR_ACCESS_DENIED” and a “x08000405” error when I try. Does anyone have any ideas about that?

Sorry for the long post, but I’d hoped that the new install would be a bit easier than this!

For the NVidia driver:
it looks like you forgot to run
‘init 3’ followed by
‘sax2 -r -m0=nvidia’
to configure /etc/X11/xorg.conf

For VirtualBox:
You may probably have to reconfigure it, attach the virtual hdd('s) again. I get these messages when I move VM’s around on my system.

Don’t mind about the length of the post. What worries me is that something prompted you to upgrade to 11.1 64bit. What prompted you? I’ve never seen things like that, using (open)SUSE since 7.0.

I’ll try the init 3 - presume I need to go back to init 5 afterwards?

I’ll keep trying the VBox stuff - there may be other posts on this, although I’m not hopeful…

Re the 11.1/64 bit - it’s new. It’s shiny. I’m male. Do I need to go on?

Yet you’re still on KDE 3.5 - is that your feminine side showing through? :wink:

No - I can configure my desktop much more than I can in 4.2.

I’ve got the dual screens working now - thanks.

Re VirtualBox - it’s (almost) working. I’ve been able to access my guest system; however, it seems to be quite an old version of the guest system. I really need the one I backed up last week… I had made a number of changes to the guest, but these aren’t reflected in the restored machine. Hmmm…

The problem with accessing the VBox disks was, by the way, file permissions. They’d all been restored as “root”, so when I changed ownership, they started fine.:slight_smile:

I’ll look at the VirtualBox forums for help with this, unless you know a way round the problem.

Hooray. I’ve been able to restore my virtualbox to its required state. Thanks for all your help.