Problems printing with new kernel

I am on openSUSE 12.1 x64, KDE. I have a Canon MP560 wireless printer which had been working flawlessly with the driver supplied by Canon. I had been using the official kernel from openSUSE (3.1.10-1.16.1) but wanting to be on the leading, if not bleeding, edge, I installed the 3.4.4 kenel from openSUSE factory. Everything worked except the printer. The printer seems to install (it is detected by the installation script) and it appears in the CUPS administration page. When I attempt to print to it, however, it either errors out immediately or prints a line or two and then spits out the rest of the page. The error indicated by CUPS is “Unable to open print file: No such file or directory”. This happens no matter what the print source, including the “Print Test Page” in CUPS. I have since reverted to the 3.1.10 kernel and all is well again. I don’t know if this is a kernel bug or some configuration error ( a file permission, etc) that I can correct myself. I wonder if anyone has experienced a similar problem or has any insight into how to correct it.

Tnank you.

Since this is very hardware specific, I wonder if you wanted to perform a test? You can download kernel 3.4.4 from The Linux Kernel Archives and compile it from scratch using my bash script SAKC you can find here:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.75 - Blogs - openSUSE Forums

By default and NOT using SAKC’s Turbo Mode, SAKC will use your default kernel 3.1.10 configuration, which does work. If you still have kernel 3.4.4 installed, it may be renamed to .old after the new compile with the same version is installed. But, using the SAKC compiled kernel would be solely based on your kernel 3.1.10 config and if this kernel you compiled using SAKC works, you know its a kernel config problem from the kernel repository where you got the first 3.4.4 kernel. Anyway, its just another way to test any kernel version that you like.

Thank You,

I’m on vacation now and I won’t be able to try anything for a couple of weeks, but before I left I did in fact try the 3.4.4 kernel. Not only did I have the same problem with that one, but it turns out that the 3.1.10 kernel doesn’t fix the problem consistently either. I suspect that I have probably borked my installation by mixing too many repositories. I have also been getting weird KDE crashes lately as well. I’ll probably just bite bullet when I get home and reinstall, and hopefully learn once again the hazards of indiscriminate inclusion of too many repositories.

That is fine and when you get home, do let us know if we can help in any other way. Having too many repositories can get you in trouble. In general, we suggest only adding in the Packman repository. I have added in the KDE 4.8 ones to also get the latest KDE, but it is always taking a chance something might go wrong.

Have fun on your vacation and ask for help if needed when you get back. There is nothing wrong in deciding to reload but if you could limp along until openSUSE 12.2 comes out, that is a suggestion. Its is up to RC1 right now and looking good, but it is running behind schedule and I have not seen an absolute release date for it though mid September was mentioned.

Thank You,

I feel a need to point out that there is nothing in the kernel that is specific
to printing, with the possible exception of the parallel port driver, which has
few other uses.

The kernel parts used in printing are used by lots of other things, thus I agree
with the conclusion that indiscriminate use of extra repos has likely screwed up
the system. One rarely needs a repo besides the essential oss, non-oss, update,
and perhaps packman and a video driver source. When others are needed, enable
them for that purpose, and disable them immediately.

This problem is not hardware specific. I have been printing to an old HP4 for years with Opensuse. I can now no longer print to it, or any of my other printers via tcp/ip. They all get the same error. A packet trace shows an invalid packet sent, with an error msg returned from the printer. I thought it was something wrong with HP’s hplip implentation, but it is not the issue, since Samsung and other brand printers are having the same issue. It is wide spread, and needs fixing asap. Hope someone figures it out. Everytime I think I have it figured out, it quits again.