Problems login on tumbleweed

Hi to all,
after applying upgrades to opensuse 2 days ago, I started to have some login issues on opensuse tumbleweed. The initialization is good but for some reason when it needs to start de X session the windows turns black, so I need to press ctrl F7 to be able to get the X session init. When I tried to switch to console I get this messages:

Node.js version v19.0.0 detected.
Odd numbered Node.js versions will not enter LTS status and should not be used for production. For more infor
mation, please see

Maybe this is caussing trouble but how to solve it? Why is X session not working?
How can I debug this problem? I tried to look for the Xorg folder but can’t find it-

Just to clarify, how did you upgrade Tumbleweed, and have you any additional repositories enabled?

I just update through “sudo zypper dup”. Tha’s all.

Can you start with an older kernel? Do you use snapshots to roll back in case? Which packages got updated? Which hardware is in use? Do you use proprietary Nvidia drivers?
…so many informations missing…

What about starting with the NodeJs problem? how do I solve that? How can I check if the X session has some issues? Then move forward. I know how to use the snaptshot but will solve anything? how do I know if there is a bug? theres 1000 of upgrade on opensuse, which one is? If you are not part of the solution move aside a let other people help to solve this problem. Anyone else available?

You are welcome to not provide any useful informations so that nobody want to help you. You could have found youself regarding NodeJS that this is only a status information if you would have used google…

I got this on xorg-session.log
Now all that gets logged there is
gpg-connect-agent: no gpg-agent running in this session
gpg-connect-agent: no gpg-agent running in this session

Please take note.

This is a user to user forum and all users are volunteers that spend some spare time if they think they can help their fellow openSUSE users. There is no need to shove away any of the people that try to help you. Their approach to problem investigation might be different to yours. And then asking for “anyone else” as if you only have to order a new helper from a pool that is urgently waiting to help you, might be counterproductive. Who wants to have a chance that they got done away with which such disdain?

1000’s of upgrades? Are you not updating on a regular basis? The default nodejs is 18, did you install 19 for a reason?

Normally X issues are graphics related, what is you system hardware?

/sbin/lspci -nnk | egrep -A3 "VGA|Desplay|3D"

Likewise, can you please provide a repository list.

hI malcom long time no see,
NodeJS last release is 19 (I checked on Yes I update tumbleweed everytime the system check there is new ones. I use Angular for programming and maybe due to this was installed the latest release of NodeJS, I found that this is not an error, just a warning.
the output of the command you send me is :

38:00.0 **VGA** compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Raven Ridge [Radeon Vega Ser
ies / Radeon Vega Mobile Series] [1002:15dd] (rev c8)
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:7b07]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

First I though it was a driver error but the initialization of the X server takes about 2 min to start the GUI and when I tried to check the log on $HOME/.local/share/sddm and I got this:

gpg-connect-agent: no gpg-agent running in this sessiongpg-connect-agent: no gpg-agent running in this session

searching I found this thread with the same error, but without response of what could be the error.
thanks again.
PS: A long time ago forums means a place where you help people, because it really needs help and not just reading unconstructive stuff. Entering to a thread means put some links as references or if for some reasons you had have the same problem as mine, write the solution that was helpfull to you. Nobody wants to read “there a lot of things…”, if that is your answer, close the thread and move on with your life and let toher people who really wants to help write some references.

So are you running Xorg or Wayland? If running X11, then you should see a $HOME/.local/share/xorg/Xorg.0.log with more information as to what’s happening. Likewise I assume there is a sddm log somewhere, I don’t use that login manager.


hi to all,
I have on the folder /.local/share/ssdm the file xorg-session.log and inside this file I have only this:

gpg-connect-agent: no gpg-agent running in this session
gpg-connect-agent: no gpg-agent running in this session

it really takes a time to opensuse start the gui session (I have opensuse running on SSD disk)
Thanks anyway.

So was there anything out of order shown in “var/log/Xorg.0.log” or the journal. The “gpg-connect-agent: no gpg-agent running in this session” isn’t relevant, I see that also on a working system.

Is it X that fails to start, or does SDDM hang with a blank screen? The latter was a fairly common issue on some systems, in fact I no longer use SDDM as one of my own machines exhibited that bug and I was unable to resolve it.

Temporarily try a different DM to see if the issue persists.

If not already installed, then as root:

zypper in lightdm


update-alternatives --config default-displaymanager

and select lightdm

maybe your right, i guess that the SSDM is causing this problem. I will replace it and check if this problem persist. Thanks for the info and your help.

Let’s not be too hasty to blame SDDM - But by temporarily using lightdm then SDDM can either be implicated in the issue, or excluded.