problems loading updates; WINE

So I have sucessfully installed 11.2 on my laptop (toshiba satellie m45-s265) without any issues. I mean none, it even autocfg’d the wireless.

  1. I did the first round of automatic updates and “SUSE” showed up on my bootsplash screen (GRUB OS selection). No biggie, went into grub/yast and deleted it off of the menu. I went to go do my next round of automatic updates that popped up on the bottom right corner of the desktop and it won’t let me do any of them. It appears they are mostly security updates, and even if I just choose one of them randomly I get the same message ( something like: this is a protected package - I’m assuming that its trying to replace, or package X does not exist, sometimes its both)… I always thought security updates were vital and I want them to avoid future probs, any suggestions??

  2. I downloaded WINE, and just can’t find it anywhere. Not quite sure if it just installed itself (doubt it) or not, but it is nowhere to be found, any tips?

note: I am very new to suse, and linux in general. I mean very new so if these are simple questions, please have mercy, and thanks ahead of time for your time…

  • cheers

I’m sorry to say it that way but you may have to try harder in providing information for the things you have done.

  1. Did you try too to update with yast online update modul?
  2. How did you download wine? With firefox, with yast (install/remove software)?

However, please take a look at this thread for dealing with wine.
Wine - windows apps in Linux - openSUSE Forums

quick answer is yes, I did both through YAST. However bear in mind ( if it even matter, which I think it doesn’t) the actual updates popped up by the clock on the taskbar…its been a few days but yes from what I remember YAST! popped up when I clicked

  • cheers

You can have only one update process running at a time. So be sure that Software management window is closed when you run the updater and visa versa.

BTW I have my updater only updating once a week much less guess work about multiple update type programs running.

Also it helps if you give use the actual error message.

For wine at a CL (command line) run


You will not see wine in the menu. Go to winehq web site for more info on wine

thanks bud…


I’m having new issues w/ wine again. I have since put 11.2 on a new computer.

  1. can’t get the winecfg window to open after installing the package. This is also the case after logging into root (su -).

  2. I have also tried to reinstall it a couple of times. When I do this, does it overwrite the existing installation like in windows, or do I have several wine(s) installed on my computer. If this is a the case, how would I go in there and get rid of the duplicate files. I’d rather do it from commandline as I am very new to linux and trying to learn commandline primarily.

Thanks ahead of time guys,



This is also the case after logging into root (su -)

Please don’t do this :wink:

can’t get the winecfg window to open after installing the package.

Did it work before and now it’s crashing?

  1. I have also tried to reinstall it a couple of times. When I do this, does it overwrite the existing installation like in windows, or do I have several wine(s) installed on my computer. If this is a the case, how would I go in there and get rid of the duplicate files. I’d rather do it from commandline as I am very new to linux and trying to learn commandline primarily.

I’m not completly sure about that but here is what it think.
The installed version of wine does not matter, the first time you run winecfg a windows-like folder structure is created wiht the path
As long as you do not remove this folder, winecfg will not create another wine folder and it will not update the exesting winefolder to newer wine versions even if you have installed a never package.

Maybe it helps removing (renaming for backup issues) the exesting wine version first before again executing winecfg again.

rm -r .wine
(rm = remove)


mv .wine wine_backup
(mv = move, in this case used for renaming the .wine folder)

Wine is a fantastic piece of software, that has sen tons of improvement in the last year or so. That having been said, using it is still something of an art.

First-- this may seem basic, but I want to clear up any possible misconception-- wine allows you to install and run windows programs in linux. You won’t find a “wine” shortcut on your desktop or in your start menu (though in dolphin or konqueror you shoult be able to right click a “.exe” file and see the option “open using wine”.).

Windows programs get installed per-user rather than for all users like linux ones. That is, each user gets a “~/.wine/drive_c” directory with a “Program Files” for programs and a “windows” directory for installing windows DLLs. When wine gets re-installed, your local .wine directory tree is untouched. If you copied any microsft or proprietary DLL files there they will remain and all your installed programs will still be there. In fact, as long as you have your /home mounted on a separate partition (which I’m pretty sure opensuse defaults to) then you can actually upgrade or re-install opensuse and your windows programs will still be there waiting for you. (how cool is that?)

Getting programs installed and working correctly is now often as easy as typing “wine setup.exe” at the command line after inserting the program CD. Many programs still require a bit more work than this though-- check out and search there for the programs you care about. If you only want wine for games, consider playonlinux, which is wine combined with a bunch of scripts to automatically set up certain popular games.

If wine is installed correctly, then opening a command window and typing “winecfg” should spit out a bunch of scary-looking debug information before popping up a window. If wine is not installed you’ll get a message like “winecfg – not found”.

I’ve had trouble updating to the latest version of wine recently due to some kind of dependency issue but the version that comes with your DVD should work reasonable well as long as you’re using opensuse 11.1 or 11.2

  1. SU - , why not? should I just stick w/ (su)?

  2. No, wine has not been successfully installed on this computer yet. I have also been unable to pull up the winecfg window, ever.

  3. Rather than renaming, wouldn’t it be more effective to get rid of all files and attempt to start from scratch?? would {rm} - no brackets of course - actually remove the files and and rid them from my computer?? again, I’m new

Incognito9 – I am running the 32 bit 11.2. I have it on anouther computer, and when I downloaded and installed the package, opened a terminal, and typed winecfg, the window popped up on the first try. This time, a window doesn’t pop up, and there is no scary looking script after typing it. If I already have wine on 11.2, why would it gladly accept it when I downloaded and installed the package the first time, or even notify me that I already had it?

Thanks guys,


ok yes… yes…

this is confirmed, I’m also having the same dependency issues. I am actually getting several different notices resulting after a few attempts. I’m still using opensuse 11.2, your saying I shouldn’t be having these problems ?


I haven’t figured out how to lick the dependency issue. I get a requirement for that seems to come and go for me with about every other release of wine.

The good news is wine has been very functional for a long while now, and there’s a new release of it about every two weeks.

So your options are:

  1. install an older version of wine and upgrade it later. I’m pretty sure it’s on the DVD release of 11.2

  2. wait a week. The dependency issue will likely be resolved with the next rpm package, and the developers have been pretty good at keeping to a two-week release schedule.

well I got it working, but the software I’m trying to use for work isn’t going to well. Its not exactly popular software (ACT! 6)…So could that be the issue? Seems to crash out towards the end of setup, or initial opening of the software, tried a few times.

…If I’m trying to knock out a few things in root, shy is it better to stick w/ “su” as opposed to “su -”, doesn’t adding the - mean I’m in absolute root, including backround performances?

thank guys,


For win business apps it is far better to use a VM with some flavor of Windows installed rather then fight wine. IMHO

VM ?? not quite sure what that is :frowning:

Virtual Machine like Sun’s VirtualBox or VMWare Server.

It allow you to create a virtual machine and install another OS.

For example I develop Window software. But I run Suse Linux. So I installed VirtualBox and then INstalled XP into the VBox machine. This runs like any other app on my desktop but instead of just an application I’m running XP in a window on Linux. I can even copy and paste between and can connect to eachs file system to move files back and forth as if the are on a network.

The down side of VM’s is they do not fully support 3D graphics. So high end PC games are out. Also they take some resources. One, a modern CPU that supports VM’s (some low power CPU even if 'new" may not). Two, a bit of memory. I’d recommend 1gig minimum. 2+ would be better.

As to wine where are you getting it? It should install fine form the Suse repositories.


honestly the wine situation is good, made a few mistakes, worked them out…etc.

I have picked up on the idea that wine is (to a point) geared towards gamers. this is more of a contact data base (very small, the whole program is less than 25 meg.

can you point me in the right direction for a VM, or whichever the best of the two would be.

this is more of a learning process than anything, however at the same time, it will make my job easier also…




VirtualBox - openSUSE

The virtual machine is a great solution for some things. ACT is accounting software, right? If so, and you use a virtual machine remember that you’ll need some anti-virus software in addition to a licensed copy of windows, as your VM will be prone to viruses.

Could look up your program in the appdb at winehq and see if someone else got it working. Could also mess around with winecfg, which allows you to change the behavior of wine for each windows app you install. If the program is older, you may want to try having wine present itself as an older version of windows (some programs will work when wine tells them they’re running win98 instead of winxp). Finally, if a program is failing you can run it from the command line, and look at the output-- sometimes there’s a particular DLL that your app doesn’t like, and often you can download the windows version of the DLL from microsoft and then tell wine to use the microsoft version of the DLL instead of the wine implementation for that App,

So, why use wine? its sounds as if you can not only get the same, but a lot more capabilties through VM. Why not do everything through VM?

is wine really that much better for games?


If you use cutting edge 3D games yes. VM’s are not so good for those. 3D support is not totally there yet.

I see no reason to struggle with a buisness app in wine unless you are trying to save the expense of a Windoz tax^H^H^H license.