Problems installing with software RAID 1 on Dell 670


I’m trying to install OpenSUSE 11.0 on a Dell Precision 670 with 2GB of RAM and 4 320GB SCSI drives hooked to the motherboard’s AIC-7901 controller (no SATA drives are present, there is a DVD-ROM and a DVD+RW drive as well as a floppy). I have tried both with HostRAID enabled and with no HostRAID set up. I have tried a 128MB /boot, non-mirrored swap (6GB each on /dev/sda and /dev/sdb) and 130GB / on the first two drives (with md0 and md1 in use and md2 on the 2nd set of drives for /home).

The problem is: the system installs fine, even finishes autoconfigure, but does not boot from the hard disk after the install.

So far, the non-HostRAID seems to work “the best” (Linux seems the least confused), but it still won’t boot. No GRUB, etc. Perhaps I’ve missed a newbie issue (e.g., not setting the partition active) and I was not prompted in the install as to grub options (as I’m used to with other Linuxes), but failing that it’s not working (and note that I didn’t have to specify the active partition to get a laptop to boot 11.0). I thought I’d ask before I just created a non-mirrored first disk and installed the OS on it, leaving the 2nd disk for hot backups and the only RAID on /home for data.

Thanks in advance,


Correction: 4 147GB drives (136GB real), U320 SCSI.

Also: OpenSUSE 11.0 x86 64 bit.

Did you ever solve this? I’m having an identical issue here, with openSUSE 11.1 x86_64.

I’m backing up some data now so that I can reinstall without a RAIDed /boot. It seems like a bit of a loss to have to do it, but there it is.