Problems installing VMware Workstation 6.0.5 on OpenSUSE 11.3


I have installed VMware Workstation 6.0.5 on OpenSUSE 11.3. When I run the vmware-config.p, I get the following prompts.

Your kernel was built with “gcc” version “4.5.0”, while you are trying to use
“/usr/bin/gcc” version “4.5”. This configuration is not recommended and VMware
Workstation may crash if you’ll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
“/usr/bin/gcc” version “4.5” anyway? [no]

If I enter Yes to go past this prompt, the next one is

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]


  1. Will gcc version 4.5 work.
  2. What is the correct location of the C header files?

Thanks in advance


Should be fine with 4.5. Why not upgrade to 6.5.4?

Anyway, this should help;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 18:41, 3 users, load average: 0.24, 0.26, 0.18
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.12

Hi Malcolm,

Thanks for the information. I will try and it and post feedback.

The license I have does not work on version 6.5


Upgrade to version 7 and you’ll not have to run vmware-config ever again.
It compiles itself whenever there is a kernel update. Lots of other nifty
changes. Unity mode works well.

Hi again,

Thanks GofBorg. Definitely something to consider. Right now, I just need to get 6.5.4 working.

Malcolm: I decided to install 6.5.4 rather. The procedure works fine until the Patching

When I run vmware_workstation_fix, it gives the following:
Creating backup files
Directory exists
patching file vmci-only/linux/vmciKernelIf.c
patching file vmnet-only/vnetUserListener.c
patching file vmmon-only/linux/hostif.c
gcc and kernel headers must be installed

gcc, ‘kernel-source’ and ‘kernel-syms’ are installed. The kernel version is 2.6.34-12-desktop.

Any ideas?