Problems installing tools on OpenSUSE 12 for Roccat ISKU FX Keyboard

Hello, I’m having issues installing the roccat-tools for a brand new Roccat ISKU FX on OpenSUSE 12.2 linux. Downloaded everything, latest vs. from sourceforge . The drivers are installed but I can’t build the tools.

rpmbuild -ta --clean roccat-tools-0.15.0.tar.bz2 error: Failed build dependencies:         libusb1-devel is needed by roccat-0.15.0-1.x86_64         dbus-glib is needed by roccat-0.15.0-1.x86_64         dbus-glib-devel is needed by roccat-0.15.0-1.x86_64         libgudev1-devel is needed by roccat-0.15.0-1.x86_64


cmake -DCMAKE_INSTALL_PREFIX=\"/usr\" .. -- Installing libraries in /usr/lib64 -- Installing udev rules in /lib/udev/rules.d -- Compiler supports attribute pack -- checking for module \'unique-1.0\' --   package \'unique-1.0\' not found CMake Error at cmake_modules/FindUNIQUE.cmake:28 (MESSAGE):   Could not find UNIQUE Call Stack (most recent call first):   CMakeLists.txt:31 (FIND_PACKAGE)  -- Configuring incomplete, errors occurred!

Problem is I guess have them installed but called… somehow different, for example libusb1-devel is by any chance libusb-1_0-devel? Any thoughts? Isn’t there a repository with rpms or something anywhere for my distro?

OpenSUSE 12.2 x86_64 AMD Phenom(tm) II X6 1055T 4GB Kingston 150GB WD Raptor & 4x 1,5TB ST Asus Radeon HD6950 2GB Asus MB Roccat ISKU fx MS Comfort Mouse 6000 Samsung 226BW 22\" Onboard

Problem solved! Great support from Roccat for linux - they answered in like 5minutes and told me to get in touch with Stefan Achatz, the developer on sourceforge, who was also very prompt and helped me later with my noob mistakes. He told me that Isku FX wasn’t supported but in a few days will be. And guess what - the second day we had a new version of the driver and tools, also prepped for OpenSUSE. I remember tried that once with Logitech, want to know how that one went? :slight_smile: lol

So I did a good choice, if you need quality/gaming gear in Linux, Roccat it is. Will buy a Kone XTD soon :slight_smile:

Got also Roccat Kone XTD - good mouse, also working perfectly in openSUSE, even the pad analysis wich helped me get rid of some problems with a black&textile&sillica mouse pad. Weird problem is with the keyboard can’t select anything in GRUB, it’s like is not there, just goes over the selection screen and loads the OS. Heard about problems with USB devices before but never encountered one. USB Legacy mode is enabled in BIOS, and I can navigate and use BIOS properly. Any thoughts?

My Apple (>:() keyboard shows this behaviour when connected through a USB hub. When connected directly to a rear USB port of the machine all is fine.

I upgraded openSUSE to 12.3; the GRUB glitch is miracously gone :slight_smile: But, now I don’t have the drivers (modules) anymore… kind of normal after a kernel upgrade. So can anyone help me this time as it’s not specifically related to Roccat, but more like a general procedure.

-downloaded Download kmod-roccat-0.8.1.tar.bz2 (94.5 kB)
-extracted, cd-ed in the folder 2.6.39_and_up as my kernel is 3.7;
-make modules_install
-modprobe roccat
-lsmod lists only roccat - but I remember having the devices explicitly there with some more specific names…
-so the tools are not working, announcing I have no keyboard… 'course I have :slight_smile:

That’s some FUS! You have to disconnect and connect the devices. It doesn’t work if you just reboot! :open_mouth:

Module                  Size  Used by
isku                   14313  0 
koneplus               14077  0 
roccat_common          13030  2 isku,koneplus
roccat                 13486  2 isku,koneplus
fuse                   87139  3 
cpufreq_conservative    13822  0 
cpufreq_userspace      13163  0 
cpufreq_powersave      12619  0 
snd_hda_codec_hdmi     41088  1 
snd_hda_codec_via      31811  1 
snd_hda_intel          48082  7 
snd_hda_codec         204641  3 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel
snd_hwdep              13603  1 snd_hda_codec
snd_pcm               110154  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq                69780  0 
raid1                  39606  2 
fglrx                5209395  208 
snd_timer              29371  3 snd_pcm,snd_seq
snd_seq_device         14498  1 snd_seq
snd                    93733  21 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
acpi_cpufreq           19572  1 
edac_core              62034  0 
joydev                 17378  0 
usblp                  18747  0 
mperf                  12668  1 acpi_cpufreq
kvm_amd                59704  0 
r8169                  67643  0 
sp5100_tco             13698  0 
soundcore              15048  1 snd
firewire_ohci          40402  0 
sr_mod                 22296  0 
sg                     36525  0 
kvm                   475491  1 kvm_amd
i2c_piix4              13915  0 
firewire_core          72670  1 firewire_ohci
crc_itu_t              12708  1 firewire_core
serio_raw              13376  0 
k10temp                13127  0 
asus_atk0110           18658  0 
edac_mce_amd           23304  0 
cdrom                  46688  1 sr_mod
amd_iommu_v2           19098  1 fglrx
snd_page_alloc         18711  2 snd_hda_intel,snd_pcm
wmi                    19071  0 
pcspkr                 12719  0 
button                 13953  1 fglrx
microcode              35785  0 
autofs4                42771  2 
xhci_hcd              103975  0 
processor              44950  1 acpi_cpufreq
thermal_sys            24957  1 processor
scsi_dh_alua           17162  0 
scsi_dh_emc            17259  0 
scsi_dh_hp_sw          12895  0 
scsi_dh_rdac           17409  0 
scsi_dh                14844  4 scsi_dh_alua,scsi_dh_emc,scsi_dh_hp_sw,scsi_dh_rdac
ata_generic            12911  0 
pata_atiixp            13272  1 
pata_jmicron           12759  0