Problems installing 42.3 on new Dell XPS 8920 (dual boot)


I have burnt a DVD with OpenSUSE 42.3 and verified it with Yast. I have shrunk the Windows 10 partitions to make space on the disks (M.2 SSD 256MB and 2TB HDD - with most for Suse). I have set it to boot the file: bootx64.efi and put this as priority. (UEFI Secure boot.) It can now boot the DVD and I can begin the installation but it fails early on with:
‘Your computer does not fulfill all the requirements for a graphical installation. There is either less than 96MB memory or the X server could not be started. As fallback, the text front-end of YaST2 will guide you though the installation. This front-end offers the same functionality as the graphical one, but the screens differ from those in the manual.’

Trying to continue gets: ‘Error Failed to set X11 keyboard to ‘english-us’’

Then: System Probing ’ Error No hard disks were found for the installation. Please check your hardware!’

I have had many versions of Suse with several different computers and up to now I have had no problem installing a dual boot with Windows. Any suggestions what I might try next would be appreciated.

Many thanks in anticipation.


Is “secureboot” en- or disabled in your UEFI? As far as i know (i do not use “secureboot”!) you need to boot “shim.efi” (not “bootx64.efi”) if “secureboot” is enabled.

So there might be some problem with your grapghics card. What card(s) is/are build into your machine?

What tools did you use to resize your Windows partition? Do you know what other partions there are on your disks or is there just free available space?



Secure boot is enabled. According to a filename search shim.efi is not on the DVD but shim-0.9-17.10.x86_64.rpm is. It was a bit of a learning curve to get it to boot the file bootx64.efi !
The graphics card is NVIDIA GTX 1060 and the graphics work OK in Windows and even initially when I load the DVD.
I used Windows, Disk Management, shrink volume to get some free space. The partitions are now:
Disk 0 - 398.05GB NTFS and 1464.84GB unallocated on the hard disk
Disk 1 - 500MB EFI System, 122.66GB NTFS OS (C), 99.71GB unallocated, 467MB Recovery, 13.96GB Recovery, 1.06GB Recovery, 16MB unallocated on the SSD.

Thanks for your interest susejunky.



Could you please try to install with “secureboot” switched off (in your UEFI)? If that succeeds you can always enable “secureboot” afterwards.

Another thing worth trying is to disable any “FastBoot”-options in your UEFI.

Does your machine have integrated intel graphic as well? If so, can you define in your UEFI how much memory the intel graphics may use and can you select in your UEFI which graphic card will be used on boot?



Switched off secure boot and tried booting bootx64.efi. It gets to the installation page but fails with black screen after. Incidentally, grub.efi gets the same response but with secure boot gave ‘Secure Boot Violation Invalid signature detected’ and didn’t reach the installation page. (‘Load Legacy Option Rom’ is enabled and ‘Attempt Legacy Boot’ is Disabled)

I can’t see any “FastBoot”-options in my UEFI. Might they be called something else?
(There are some advanced options that are enabled: ‘Intel (R) SpeedStep ™’, ‘Virtualization’, ‘VT for Direct I/O’, ‘Intel (R) Ready Mode Technology’. ‘SATA Operation’ is set for ‘RAID on’, ‘Deep Sleep Control’ is ‘Enabled in S4 and S5’ - is this all OK?)

Windows Device Manager, Display adapters, lists the Intel(R) HD Graphics 630 too. I can’t see any signs of graphics card settings in UEFI.

Thanks for your help.


Turn RAID off unless you plan to run RAID.It has been noted that some manufacturers set RAID on be default .

Try at first install menu press e to edit the boot code

Find the line starting linux or linuxefi go to the full end of the line (it wraps) add a space and nomodeset press F10 to continue

Note if the above works you may need to install the proprietary NVIDIA driver once installed

I do not have those options on my motherboard so i cant give you any advice based on facts.

However, as gogalthorp already proposed, i would disable RAID (probably that was the reason why the installation routine could not detect your drives) and switch off any “special” intel chipset options like “Intel (R) Ready Mode Technology” and “Intel (R) SpeedStep ™”. Disabling “Load Legacy Option Rom” might be worth a try as well. But that is all just guessing. Hopefully someone here uses the same motherboard and can give you better advice.



I’m making progress - but slowly!

Turning SATA Operation to ‘AHCI’ stopped the DVD from booting and failed with Windows too. So SATA Operation is back with ‘RAID on’.

With Secure Boot enabled (and Load Legacy Option Rom disabled) I followed gogalthorp’s suggestion to add a space and nomodeset to the boot code. This is where I have progressed to having a graphical installation :slight_smile:

Language and keyboard are as normal but the next screen is rather empty. Top right is the Network configuration button which finds the ethernet and seems to be OK. In the middle is just a button labelled ‘Configure iSCSI Disks’. This takes me to a page entitled ‘iSCSI Initiator Overview’. The ‘Service’ tab has a text box labelled with ‘Initiator Name’ and is preloaded with ‘’. Next to it is a drop down box labelled ‘Offload Card’ with only one option - ‘default (Software)’. The second tab is ‘Connected Targets’ with ‘Interface’, ‘Portal Address’, ‘Target Name’, and ‘Start-Up’ at the top of the page and ‘Add’ at the bottom. I don’t know how to proceed from here.

I am hoping that I can put OpenSUSE and Swap on the SSD and home on the hard disk but cannot yet see these 2 drives.

Thanks again for your help.


Hm, i don’t understand why that happens.

Well, if Windows is installed using some RAID-level it might not be able to start in a non-RAID-mode?

I have no experience with RAID installations so i will not be able to support you on doing this.


My understanding of iSCSI is that it provides block-level access to storage devices by carrying SCSI commands over a TCP/IP networks. To me that looks like the installation routine is not detecting your local storage devices (SSD, HDD).

Can you access any of your local storage devices (SSD, HDD) with the openSUSE rescue system (from the installation DVD) ?



I’ve just tried the openSUSE rescue system and it gave me a text rescue login. Typing root gave me ‘tty1:rescue:~ #’ and a cursor - but I don’t know what to do next.

Any more suggestions gratefully received.



# parted -l

should give some information on the storage devices in your system.

You can mount an USB stick and save the results to a textfile so that you can post them here (after rebooting your machine to Windows).



I put in a USB stick and this is what I got:

parted -l

Model: USB Flash Disk (scsi)
Disk /dev/sdb: 8179MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 28.7kB 8179MB 8179MB primary fat32 type=0b

No need to reboot to Windows - I’ve still got my old computer with 42.2 :slight_smile:

No sign of SSD or HDD.



Oh! I did not expect that.

Please, could you try

# hwinfo --disk


# hwinfo --block

as well as

# hwinfo --partition

Just to check whether there is a chance to get any information about your storage devices. So no need to show the results here in detail. Just tell us if there was any information returned that deemed useful to you.

To give us a better understanding of your system the following information might help

# hwinfo --storage-ctrl

information on the disk controllers.

# lspci

information on your hardware setup.

# dmidecode -t 0

information on your UEFI

I guess you recognized by now that i’m nearly lost. Is installing your PC from the very start (i.e. re-installing MS Windows) an option for you?



Here is a précis of the results:

hwinfo --disk

mentions the multiple card reader and USB - no SSD or HDD

[FONT=monospace]hwinfo --block

[FONT=monospace]also mentions the multiple card reader and USB - no SSD or HDD

hwinfo --partition

something flashed up but was quickly removed - no further info

hwinfo --storage-ctrl

this seems more interesting so I’ll quote some, it starts:
‘15: PCI 17.0: 0104 RAID bus controller’ missing some out - then:
'Hardware Class: storage
Model: “Intel SATA Controller [RAID mode]”
SubVendor: pci 0x1028 “Dell”
SubDevice: pci 0x07dc
Driver: “ahci” ’ missing some more - it ends:
‘Driver Info #0:
Driver Status: ahci is active
Driver Activation Cmd: “modprobe ahci”
Config Status: cfg=new, avail=yes, need=no, active =unknown’


mentions many things including:
‘00:17.0 RAID bus controller: Intel Corporation SATA Controller [RAID mode]’

dmidecode -t 0

‘command not found’

I did take some photos of the screen so I can enlarge on the above if necessary - just say what you need.

If you are nearly lost then there’s no hope for me!



Looks like something “hides” your storage devices.[FONT=monospace]


So “ahci” is used as SATA driver but you said that your UEFI is set to RAID. So that might be a problem (just guessing!). To see if there are any errors please do

journalctl -b 0 -r -p 3

and post the result here.

Well, there are forum members/visitors who have better knowledge on your hardware and/or RAID. So don’t give up.

I will try to support you but be aware i currently do not have the slightest idea where your problem comes from. Therefor once more:

Is installing your PC from the very start (i.e. re-installing MS Windows) a valid option to you?

If not, we have to be very careful not to damage your installation and so will be limited in what we can “just try”.



Your USB does not look right how did you make it? It should NOT have just a FAT formatted partition

Here is one I created recently

Model: PNY USB 2.0 FD (scsi)
Disk /dev/sdc: 32.2GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      2161kB  6160kB  4000kB  primary               type=ef
 2      6160kB  4640MB  4634MB  primary               boot, hidden, type=17

Note there are two partition the first is the efi boot partition then the second is the installer. This is from a straight binary copy of the iso to the device not a partition on the device

I just booted my openSUSE installation DVD on two different machines (SATA option in UEFI set to AHCI) and it worked fine. So i do not understand why your installation DVD will not boot when you change the SATA option in your UEFI from RAID to AHCI.

Where did you get the openSUSE .iso file from?
Did you verify it against the provided checksum?
Did you run the self check on the DVD?



There’s not much to go on with this:

tty1:rescue:~ # journalctl -b 0 -r -p 3
--Logs begin at Mon 2017-12-11 12:52:38 UTC, end at Mon 2017-12-11 12:52:53 UTC. --
Dec 11 12:52:38 rescue systemd-sysctl[2079]: Failed to open file '/boot/sysctl.conf-4.4.76-1-default', ignoring: No such file or directory
Dec 11 12:52:38 rescue udevd[238]: specified group 'input' unknown
Dec 11 12:52:38 rescue nouveau 0000:01:00.0: unknown chipset (136000a1)
Dec 11 12:52:38 rescue udevd[238]: specified group 'input' unknown

Since the new computer came with Windows 10 pre-installed and no disk for reinstallation I’m not really in a position to reinstall it.
I do have laptop with Windows 8 dual booting with OpenSuse and hardly ever use Windows but I’d rather keep the new version if I can.

In response to gogalthorp, I am trying to install from a DVD but had put a USB stick in to see if that would show up. I wasn’t trying to boot from USB and think that perhaps this is why it ‘does not look right’. Would booting from USB be a better option?

I downloaded the DVD ISO image from I have rechecked the SHA256 with the downloaded file and checked the DVD using the Yast media check. All seems OK.

I have again tried the disk with AHCI but failed to start the installation disk both with secure boot enabled and disabled.

I won’t give up :slight_smile:

Thanks again for all the help


Indeed. I was hoping for some sort of error message related to your storage controller or the like.

So we have to be very carefull …

It’s at least worth a try. Probably you can boot from USB with SATA set to AHCI. If that works please do

# parted -l

and show the results here.

While booting watch out for error messages and if the boot fails please tell us how far the boot process proceeded. Even if you can’t boot from USB could you please show the complete results of

# lspci


# hwinfo --storage-ctrl

Have there been any error messages? How far did the boot process proceed?



I just found this probably it helps in your case as well.