Problems getting Logitech's Bluetooth DiNovo Edge Keyboard to work

I first tried to use this keyboard with openSUSE 12.1 64 bit. It would work during install, then saw it as a Bluetooth device. Unfortunately, I could never get it to stay connected. I have since done a clean install with openSUSE 13.1 64 bit. Again, keyboard worked during install, but after getting everything up and running, this keyboard was completely missing from Bluetooth devices. Any help would be appreciated as I really like using this keyboard.

What desktop are you using? Bluetooth is broken in KDE as stated in the release notes:

5.10. KDE and Bluetooth
The Bluetooth stack is provided by Bluez 5 (a major, backwards-incompatbile version), a necessary upgrade for GNOME desktop and some other components of the base system. Unfortunately, the KDE workspace only supports Bluez version 4 in its currently-released versions.
Therefore, the openSUSE KDE community team offers an unofficial Bluedevil package providing at least basic functionality such as device pairing or support for bluetooth mice; Some other features are known not to work jet, like file transfer.
For the moment, bugs should not be filed against Bluetooth support in KDE as the Bluez 5 port of Bluedevil is still ongoing.

I have been unable to get bluetooth headphones working in 13.1 that are fine in 12.3. I’m hoping it gets fixed soon so I can update beyond my test machine.

That explains everything. I am using KDE and except for this, everything on my computer works. I do prefer KDE as desktop, so hopefully they will release a version that works with Bluetooth. I have several main computers, each with 12 hard drives with main OS Windows 7 SP1 x64. I am using removable hard drive bays to allow switching between OS’s. I have been using computers since 1984, but not much with Linux. I even tried the one that Corel came out with that actually scared Microsoft as it installed and updated as easily as Windows and included Word Perfect office suite. I have tried several versions of Linux, including Mandrake, Ubuntu, but preferred openSUSE, having used several versions from 9.1 on. I find the multi-monitor better on openSUSE then on Windows 7. I appreciate your input. Thanks.

This is a problem I’ve had with all recent versions of OpenSUSE… the system detects that the DiNovo Edge is a Bluetooth device, and appears to allow all of the usual interactions with the BT system… but connection issues and crashes follow. In fact, it appears that the keyboard works as a USB device primarily… i.e. the Bluetooth adapter simply presents a keyboard interface to the USB bus, so my solution was to simply uninstall all of the Bluetooth software, since I have no other BT devices. The system requires libbluetooth as a dependency, so leave that installed.

I hope this info is of use to someone.
Very best wishes to all,