Problems encountered trying to upgrade Firefox on 11.1

Tried a number of solutions from:

http://en.opensuse.org/Firefox

and

http://www.dissociatedpress.net/2009/07/07/firefox-3-5-packages-for-
opensuse-10-3-11-0-and-11-1/

First off the 11.1 instructions do not work at all.
I believe that mozilla.repo is truncated from the visible installation
instructions. Interestingly the same information is truncated off of the
second website I mentioned. I only found the correct info in the comments.
:slight_smile:

If I use the 1 click installer it asks me to save file MozillaFirefox.ymp.
I normally don’t use 1 click, but thought since the repo add wasn’t working
I’d give it a shot.

Ultimately I added in the repo via YaST, but it still places 3.0.15 as the
latest version. Seems to be ignoring the firefox repo…or I’ve added the
wrong one.

How do we upgrade Firefox beyond 3.0.15 and can someone clear up the
appropriate web page at opensuse.org? The published command is incomplete.

The error you will get according to zypper:

“If only one argument is used, it must be a URI pointing to a .repo file.”

Your best bet is to download the disk (DVD/CD) and do a new install from there rather then trying to do it via the repositories.

Do new install and tell the installer NOT to reformat your home partition just mount it as /home. This will save your data and settings. If you have data stored on root (Databases VM’s etc) back them up and restore them after you get a stable new install.

> Your best bet is to download the disk (DVD/CD) and do a new install from
> there rather then trying to do it via the repositories.
>
> Do new install and tell the installer NOT to reformat your home
> partition just mount it as /home. This will save your data and settings.
> If you have data stored on root (Databases VM’s etc) back them up and
> restore them after you get a stable new install.

I think you may have misread my post. :slight_smile: