Problems downloading from repos

Is anyone having problems with downloading/installing packages using yast at the moment, it has just recently been timing out and I have to keep retrying which doesnt always work


No problems
Are you using local UK mirrors?

I’m not, but it’s an option

Is the problem with all repos or just some?

Post your repos for us to see

zypper lr -d

On 2011-08-06 11:26, jimt123 wrote:
> Is anyone having problems with downloading/installing packages using
> yast at the moment, it has just recently been timing out and I have to
> keep retrying which doesnt always work

Sometimes you have to change from the redirector to explicit mirrors.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I’m in the UK too, and I’m having all sorts of bother trying to update openSUSE 11.4 today. All was fine yesterday, and I performed a lot of updates, including a kernel update with no problems, but today I cannot get my package manager to work. What should I do? Is there a known problem today?

My zypper lr -d output:

**Kinzie@linux:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | GNOME:STABLE:3.0 | GNOME:STABLE:3.0 | Yes | Yes | 98 | rpm-md | |
2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | Yes | 99 | rpm-md | |
3 | | nVidia Graphics Drivers | Yes | Yes | 99 | rpm-md | |
4 | | openSUSE BuildService - GNOME:Apps | Yes | Yes | 99 | rpm-md | |
5 | | openSUSE BuildService - Banshee | Yes | Yes | 99 | rpm-md | |
6 | | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | |
7 | | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | |
8 | | Main Repository (Contrib) | Yes | Yes | 99 | rpm-md | |
9 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | |
10 | google-earth | google-earth | Yes | Yes | 99 | rpm-md | |
11 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-PIONEER_DVD-RW_DVR-216D,/dev/sr0 |
12 | | libdvdcss repository | Yes | Yes | 99 | rpm-md | |
13 | | Packman Repository | Yes | Yes | 99 | rpm-md | |
14 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | |
15 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | |
16 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2 | |
17 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | yast2 | |
18 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | **

I suggest you test your internet connection by downloading a suse .iso direct http download. See if it max’s out

My internet connection seems fine generally. I downloaded Ubuntu Oneiric alpha 3 today without a hitch. Very confused.:confused:

I will add though, that I’m noticing that the OpenSUSE forums are tricky to connect to today. Only Google Chrome will get me onto the site. Firefox 5 will not load it at all. And if I click any of my above repository links in the Chrome browser, sometimes I get the repo lists, and other times it won’t connect. I suppose it could be my connection, but I haven’t noticed any similarly strange behaviour on any other sites.

I would run a traceroute on the connection to openSUSE, your ISP may be sending you via Pluto :smiley:

But as I said, it’s perfect here. ISP (Entanet)

Just a bit of fun, but I would check traceroute.
Also IPv6 ? Your ISP may not support it. It doesn’t harm to disable it.

OK - traceroute, though I am no expert at all when it comes to networks, doesn’t seem to show anything untoward and shows only local area routes. Nothing via Europe or anything daft.

I must say I’m having a hell of a job trying to connect to the site here too. Only Google Chrome (official) will do the job, and that sometimes times out, as it did when trying to make this post. If I try to connect with FF5 on any of my installs it won’t work and just hangs. I’ve literally just tried my PCLinuxOS 2011 install and I’m getting the same results there too, so it’s not an OS issue.

So I still have the same problem. I cannot connect to any of the repos via the package manager to update my system as I did the other day. I get network unreachable error messages. Is there anything I can do? It’s literally only when trying to connect to anything openSUSE related. All other sites and attempts to download anything anywhere else are fine.

Try disabling IPv6 and see if that helps

Sorry, ought to have mentioned that I did that. Disabled it in network devices and rebooted. No difference. :frowning:

I’m on Virgin Media broadband in the UK, if anyone passing can help.

Same problems, same ISP.

Took the laptop to another location and updated via a friends BT broadband, looks like Virgin is playing up.

Thanks for your reply. It’s a very odd conundrum then, but at least I’m not alone! Sadly this is a desktop so I cannot easily move it to another location. But then I wouldn’t anyway. At the end of the day I pay Virgin to provide the service, and it should be working.

I’ll give it a couple of days and see if it persists. I may have to phone them, but I can’t imagine customer services being helpful with a site connection that’s faulty only on one location, and a Linux one too! I don’t think a single UK ISP officially “supports” Linux.

Please post any response from Virgin on this thread, I am on a communal network installation in a block of “bed sits”, and so cant contact Virgin technical support myself.

Waste of time mentioning the matter to my landlord as he is as technically minded as a house brick.


Never any problems

I read in the get_iplayer mailing list about big Virgin problems
Traffic management I reckon

Virgin is usually very good, but recently it’s not been so hot, either with the broadband or the TV. Worse considering how expensive it all is.

Bit confused even more now. Disconnected the router, rebooted, and then tried to complete the updates and it worked. Reconnect the router and rebooted, and it won’t connect to the repos again. I cannot imagine what is causing the problems with the router being connected, but if anyone has any idea please let me know. All the settings seem fine and haven’t been altered or anything. They’re the same settings that worked a few days ago. Still couldn’t let me connect to the Opensuse main page via Firefox 5 though. :confused:

What a palaver! Strangest issue I’ve ever had!

I’m afraid I wouldn’t touch any of the UK’s retail broadband providers
There are precious few you can trust or rely on.

Though your issue is rather odd in that it affects basic http requests to openSUSE
And you had the same in PCLOS? Correct?

Seconded !!!

Yes that’s right. If I try to connect to the main openSUSE site with Firefox 5 in either openSUSE or PCLinuxOS on this desktop PC, it tries to connect but just sits there. Eventually it will time out. Using either Chromium or Chrome it is likely to connect fine. Oddly it connected with Windows 7 and Firefox 5, but was noticeably slow.

I cannot access the repos with the router connected (the PC is wired via it, not wireless), but on disconnecting the router I managed to access the repos fine and updated OK.

It’s either the router or Virgin. It’s very strange, but I think it’s best to wait a couple of days and see if the problem persists. I have an older router I could try which is a little faulty, just to see how that goes.

Thank you all for your replies. Hope I haven’t given any of you a headache!