problems connecting usb card reader/usb stick/hard drives

Hi all, I’m new to Suse, have come from Linux Mint. I am having problems with connecting card readers with CF cards, USB sticks to my computer, once plugged, I select open with file manager and then I get an error message pop up saying malformed URL, if I close that and then open Dolphin I find that the reader is mounted and available and its contents can be read. Is there a way to set my system up to to stop the error message and to also allow the card reader to remain visable in Dolphins menu once it has been safely removed so I can just click on it to remount rather than having to unplug and then plug in again to make it visible? I have a similar problem with internal extra hard drives, when I try to open them I get the message ’ An error occurred while accessing ‘Home’, the system responded: The device is already mounted: Device /dev/sdb1 is already mounted at `/run/media/aj/drive2’.’ I’m running Tumbleweed, everything else, Nvidia, Broadcom wireless etc seems to work OK now after a little fiddling around. Processor is an Intel 5930K, mobo is Asus x99 delux with 32 gb memory. Any help gratefully received but I please remember that this system is totally new to me. Adrian

Hello and welcome to the openSUSE forums.

… I select open with file manage …

probably means that you use a desktop. Which one (KDE, Gnome, …)
It also probably means you get a pop-up from where you make that choice “Open with file manager”. Is that correct?

Yes, I’m using KDE Plasma desktop, sorry for the omission.


Sounds somewhat similar to

Thank you Wolfi323, that does indeed seem like it may be my problem, or at least a part of it,. will see if I can figure out how to get around it to see if all the problems disappear. With the hard drives I did think it may be a permissions thing but now think this may be at the bottom of it all.

Apologies for my slow responses, the forum seems to be running very slowly, even refreshing the page can take fifteen minutes or so!


Same here. I can assure you that that is not what we nomally experience.

I’m pleased that it isn’t just me lol

I’m not sure how I’m going to rectify this ‘bug’ though, I have no way of going back to previous states as this is a totally new install. I cannot find any older versions of udisks2 listed in any of the repositories I have enabled, if that is indeed how I need to get around the problems. I am a little worried about corrupting any data on the hard drives/CF cards as they contain photos that cannot be repeated. I also need to be able swap out hard drives on a fairly regular basis.


Being new to OpenSuse I am just wondering if I could install another file manager such as Konqueror or something else that may not be affected by the bug. Would this introduce conflicts or cause other problems on my system. At the moment it is running beautifully, don’t want to mess things up.


I would assume that Konqueror is installed with KDE.

But I am not sure it helps because you say Dolphin is already working correct. The problem seems to be before a file manager is really started by the software “behind the pop-up”.

Use Yast2 - Software Management - Repositories - Configuration - Repositories - Add - Specify URL… to Temporarily add the Leap 15 OSS Repo ( URL to use: )

After it is added and has refreshed use the Search Tab and search for udisks2, the results pane should return libudisks2-0 and udisks2. For each use the Versions Tab to select the 2.6.5 (leap) versions and “Update Unconditionally”. After they have “updated” select each and mark as “Protected - Do not modify”.

Then remove (or at least disable) the leap repository as you don’t want to inadvertently add any other packages from there.

The only way I see currently is installing udisks2 from Leap 42.3.

I’d strongly disrecommend adding the Leap 42.3 repo though, this will give you problems.
Rather download and install the corresponding packages (udisks2, libudisks2) manually.

This should do:

sudo rpm -Uvh --oldpackage

(should be all in one line)

Or wait for a fix.

Installing Konqueror won’t change much as this uses the same KDE mechanisms (actually it just embeds dolphin for file browsing).
Krusader would be another KDE based file manager, but again it probably wouldn’t help with mount problems.

Maybe try nautilus (GNOME’s file manager, also known as “Files”), thunar, or pcmanfm, but those will pull in (possibly lots of) new dependencies, and of course they will not be as integrated into Plasma as KDE’s file managers.
Other than that it will not introduce conflicts, as you put it.

But then, all those also use udisks2 to detect/mount drives, so if it really is a bug in udisks2 they would probably be affected as well.

I don’t think you need to worry about corrupting your hard drives/CF cards though. This is not a bug in actually accessing (or mounting) the filesystems, but rather what disks in what status KDE’s libraries see.

Ah right, that’s probably the better choice as it contains a much newer udisks2 than 42.3. :wink:
I somehow thought that Leap 15.0 would have the latest one from TW too already, but it’s coming from SLE 15…

Yes. Leap 15 has (currently) udisks2 V2.6.5 which is the version Tumbleweed had prior to the 20180312 snapshot.

Thanks so much everyone, that seems to have sorted the problem, now running udisks2 and libudisks 2 2.6.5-1.3. I still have to get the 2nd and 3rd hard drives to open without having to use a password, so still need some help to get around that but otherwise everything so far is running beautifully and as it should.

Thank you all so much, you have all been so kind, patient and helpful to a total noob, thanks.


What is the password dialog telling when you click on “Details”?

I suppose they are regarded as “system drives” which need the root password to be mounted by default.

You basically have two options then.
Either mount them automatically during boot by adding entries to /etc/fstab, or allow system drives being mounted without the root password by overriding the polkit settings.
For the latter, add this line to /etc/polkit-default-privs.local and run “sudo /sbin/set_polkit_default_privs” to apply the change.

org.freedesktop.udisks2.filesystem-mount-system yes

That will allow it for all users on your system though, which you may or may not want.

Thanks once again Wolfi, that adding that line to /etc/polkit-default-privs.local works perfectly and is easily reversed if I do want more security. You have been a great help to me, many thanks.