Problems booting on Lenovo P51


Stuck with a strange problem.
Bought a new Lenovo p51 (ssd+hdd). Disabled Secure boot. Installed 42.3 from usb drive. All the default options (actually tried different options too). Install goes fine. But when i’m booting after install, screen just blinks black. Looks like it can find bootable disk.
Weird thing, if i boot to USB installation stick, then choose Boot from HD, it boots fine o_O

After you boot from USB is there an efi entry for openSUSE from the following output;

efibootmgr -v

Check the boot order, it’s not looking at the HDD or SSD first rather than (since your not using secureboot) grubx64.efi?

Is this just a openSUSE install or dual/multiboot?

EFI variables are not supported on this system.

boot order in BIOS? Seems fine.
in grub2 also the order is correct

OK, so your Legacy booting not efi, or it’s wanting efi and was installed in legacy mode?

Can you post the output from;

fdisk -l

no multiboot, clean install

i’m also wondering about “Boot loader” option in Boot loader app. By default it is set to GRUB2, and if select GRUB2 for EFI it gives an error

i don’t mind using efi. But if during installation i choose GRUB2 for EFI, i get an error that it’s not supported for plaform x86_64 or something
So BIOS is configured for legacy and efi, and i choose grub2 during install

sda       8:0    0 931.5G  0 disk 
├─sda1    8:1    0     7M  0 part 
├─sda2    8:2    0     2G  0 part [SWAP]
├─sda3    8:3    0    10G  0 part /var/lib/libvirt/images
└─sda4    8:4    0 919.5G  0 part /home
sdb       8:16   1   7.2G  0 disk 
├─sdb1    8:17   1   3.8M  0 part 
└─sdb2    8:18   1   4.3G  0 part 
nvme0n1 259:0    0 238.5G  0 disk 

Disk /dev/nvme0n1: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: F294EC00-4248-4047-830D-720A2011FB11

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 78811DEE-A788-486E-B0B8-12366B99FEE1

Device        Start        End    Sectors   Size Type
/dev/sda1      2048      16383      14336     7M BIOS boot
/dev/sda2     16384    4225023    4208640     2G Microsoft basic data
/dev/sda3   4225024   25206783   20981760    10G Microsoft basic data
/dev/sda4  25206784 1953523711 1928316928 919.5G Microsoft basic data

Disk /dev/sdb: 7.2 GiB, 7747397632 bytes, 15131636 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x1b681c50

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1        4220   12031    7812  3.8M ef EFI (FAT-12/16/32)
/dev/sdb2  *    12032 9062399 9050368  4.3G 17 Hidden HPFS/NTFS

10G is pretty small… I would recommend 40GB if using btrfs, maybe get by with 20GB with ext4…

Your disks are gpt (efi booting). I’m assuming sdb is the USB device? The ssd (nvme) is not being used at all…?

If you set the boot flag on sda1 via fdisk, maybe it will spring into life…

I would suggest you consider a fresh install, review your partitioning and go the efi route (can pre configure the disks via a USB bootable device)?

well, ive reinstalled it like 5 times today, tried different disks, different sizes (10gb is just a default size). I’m definitely missing something.
What are the requirements for efi for partitions? Sorry, i’m nooby when it comes to grub and efi and all that stuff =(

can pre configure the disks via a USB bootable device - what do you mean by that?

It should have the correct defaults for EFI mode if you boot the installer in EFI mode

You can, but I wonder how you created the USB install device, what program did you use? You won’t get anywhere until can get it to boot in UEFI mode…

So I suggest you boot up again (and hopefully you have a spare USB device)? and install imagewriter via commandline or YaST software management;

zypper in imagewriter

If you don’t please advise.

I am not sure if this is relevant,but;
On my Lenovo (Yoga 3 Pro), in BIOS settings I have:
Secure Boot [Enabled]
Boot Mode [UEFI]

I think (from memory – two years ago) that with Secure Boot [Disabled], Boot Mode has to be [Legacy].

yep, this is what i’ve used. So i suppose it creates bootable USB in uefi mode? I’ll check on that

It creates for both Legacy and UEFI, so the question (I have a Lenovo B50-80 here) is in the BIOS I left Secure Boot on, suggest you do the same, do you also have an option here to ‘Reset to Setup Mode’?

Do you have a spare USB device and put a Tumbleweed live cd on it and boot from that to confirm via efibootmgr it’s booting properly?

The next question is what disk do you want to use and your preferred setup with both?

We can clean out the existing install (assuming you have two USB devices, one for the Leap 42.3 install and one for the live Tumbleweed image), and pre-configure a few things first.

During the install you then select the expert option and rescan the disks, then it’s just a mater of selecting each disk partition with what your wanting.

well, i’ve played around with bios settings:

  1. i can not boot to USB with Secure boot on
  2. Secure boot off, but only UEFI Boot ( no legacy) - again, can not boot to usb
  3. only if i allow legacy boot, i can boot to USB

I do have Reset to Setup. What does id do? Should i be able to boot to 42.3 USB stick with Secure boot on?

On the BIOS Boot tab you should be able to set ‘USB Boot’ to enabled? Is there a Secure Boot Status? Make sure the device is in a USB 2.0 port as well (or one that will switch), you might have to try each individual USB port on the system (as in plug in, test, power off, try a different one etc), but you should be able to boot from USB after all Lenovo provided a free WinX restore USB media to me for this system…

well. surely USB Boot is enabled=) If Secure Boot is enabled, i can not boot to USB, only if it’s disabled and Legacy sypport is enabled. I’ll try different ports, and another stick with tumbleweed, see what happens.
Btw all the ports are USB3.0, but that surely can not be the problem. Although USB stick is 2.0, farely old.

well… used another USB stick with tumbleweed, but sadly, still can only boot to it if i enable legacy boot=( any other thoughts about bios configuration?

OK, so if you set to UEFI, reset the setup mode and factory defaults, save but go back into the BIOS and does the USED device appear in the boot list, if so move it up the top, save and exit and see if you can boot… Is should ask about the openSUSE key?


there are 3 options there: Reset to Setup Mode, Restore factory keys, Clear all secure boot keys. Tried all of them to no luck=( USB is in the list, but can not boot and it’s not asking for opensuse key

it seems there is an option in bios: os defailt settings, which is overriding security default settings like secure boot o_O turned off, there secure boot off, setup mode, reset to default, then it boots to usb. Not asking for opensuse key though=( so i’m wondering how can i enable secure boot

Anyway, thanks malcolmlewis! Appreciate your help!