Problems after installing version 13.1

We mentioned these in the “Nightmare” responses but they seem to have gotten ignored. We would like to install -or- try to anyway, the new openSuSE 13.1. It was implied, or we got the impression, that it is to be “the” supported version for quite some time. Our main reason and desire for installing it. As mentioned, in the Nightmare scenario, we have installed this with BOTH:

A FULL DVD Fresh Install  -and-  as an UpDate/UpGrade over 12.2

Neither worked. The following are the problems we experienced. Have any of you experienced these -and- does anyone have any idea what causes them with a possible correction??

So what is/are our problem(s)??
1.) Fire up “Firefox” and all we get is a blank Window with a Circle, that doesn’t rotate, and the word “Connecting” up in the top frame. It never connects. It is frozen.

2.) Click on the "Orb’ in the Lower Left corner and wait… and wait… and wait… and eventually get a menu.

3.) Was able to use the “Panel Settings” and get the “Lock/Logout” icon in the Lower Right side of the Panel. However, clicking on it to leave and we had to wait… and wait… and wait… and maybe eventually got the Logout choices.

Many of the other operations that we tried were also turtles in nature. Could anyone list the magic that will fix this and make it more usable??

Thanks,
Chuck

I have observed that symptom when home LAN / WLAN internet access is down.

Can you confirm that your PC’s network access was functioning ?

wrt updating, I note this from the release notes (although I don’t know what the resultant symptoms may be):

4.3. Duplicated Network Interfaces

The current version of systemd uses a new convention for assigning predictable names to network interfaces. YaST is changed accordingly.
Some reports indicate a bug in YaST when conversion from one naming scheme to another takes place. If the same network interface has two different names, you have been hit by this bug. In this case remove the different network interfaces in /etc/sysconfig/network and use YaST to configure the network anew.
For more information about predictable network interface names, see PredictableNetworkInterfaceNames.

On 2013-11-25 01:46, oldcpu wrote:
>
> chucktr;2601551 Wrote:

> I have observed that symptom when home LAN / WLAN internet access is
> down.
>
> Can you confirm that your PC’s network access was functioning ?
>
> wrt updating, I note this from the release notes (although I don’t know
> what the resultant symptoms may be):
>>
>> 4.3. DUPLICATED NETWORK INTERFACES

When that happens, network does not work. Chuck, please paste here the
result of running “ifconfig”. Do it inside code tags - the ‘#’ button in
the editor.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Ok. Thanks to both for your replies … however, I do not have it installed at the moment, so I can not provide any of the information that you request. Other than, right now in my 12.3 version Firefox 25 and the Network ‘are working’.

What we would like is… some reason, -and- fix, for the ‘unresponsiveness’. I mean you should get almost instantaneous results from clicking on the Gecko Orb in the lower left hand corner. We would click on it and have to wait for what seemed like 5 minutes before app selections would be presented. The same thing on ‘Leave’. Other operations were not fast either. In fact we probably overloaded the ‘input’ trying to get something to respond… without having to wait forever.

As stated in the ‘Nightmare’ scenario, we got totally frustrated and disgusted and dumped 13.1 and re-loaded our ‘working’ 12.3. We’re sure that it is probably something simple that we have overlooked but for the life of us we can not think of anything.

Thanks,
Chuck

With out log info and more information its hard to say why it was slow. Could it be this observation was right after boot and some unwanted search/categorization app was still running creating a temporary experience of slowless? Again its not IMHO possible to explain/test further without an actual install to repeat and debug the problem.

ok. What log info do you desire?? I plan to try the install again tonight and use some of these tips from the forum:

Courtesy of jdeca57:
solved the problem with KDE by going to a terminal [crtl][alt][F1] and entering:
kwriteconfig --file kwinrc --group Compositing --key Enabled false
kwriteconfig --file kwinrc --group Compositing --key CheckIsSafe true
kwriteconfig --file kwinrc --group Compositing --key OpenGLIsUnsafe false

Had the above problem in an earlier release but I thought it was fixed. I’ll try it anyway.

And from wolfi323:
use YaST->Network->Network Settings to switch between NetworkManager and ifup (Global Options tab).
But if you only have the one wired connection, you might just as well use ifup.

I’ll just make sure Newtwork Manager is in charge… and see IF that fixes my Networking problem.

And last but not least … round-about-courtesy of oldcpu and Carlos:

Make sure proc, sysfs, debugfs, usbfs and devpts are removed from fstab.

IF you can think of anything else please let me know. I am either destroying my System one more time
with this 13.1 attempt -or- managing an UpDate/UpGrade. We are trying right off to make it our “Main System”
and NOT have to fight this twice. Therefore, we are going the UpDate route and not the Fresh Install.
Neither worked before so it is a toss up and UpDate won.:wink:

If an app is acting up, try running from a terminal/konsole and look for indicative errors.

If KDE is acting up, try a test where you run as a different user and see if a new user has same problem. That can sometimes point to problems with ones old /home with the new version of KDE of GNOME.

Sometimes /var/log/messages will have a hint as to a problem.

If too difficult to copy and paste text to internet try instead to take a pix with a digital camera and post images.

Apologies for non specific advice … These are the methods I use myself.

We belong to the “Bullheaded Taylor Clan” and we are having a hard time imagining that we can not get this silly thing to work correctly. -But- it is being a beast. The following is our System description:(copied from my WebPage)

|
|
|Item Specifics - HP m7480n Pavilion Computer.|
| |Brand:|Hewlett Packard|Memory(RAM):expressionless:4 GB (Got a smokin’ deal on 2GB)|
| |Model:|Pavilion m7480n|Hard Drive Capacity:|(1) 500GB & (1) 750GB Drive|
| |Processor Type:|Intel PentiumD 940 (P)|Operating System(s):|**Windows XP Media Center/SuSE 12.1 **|
| |Processor Speed:|3.2 GHz|Optical Drive:|Lightscribe DVD + DVD ROM|
| |Video Card:|nVidia GTX 560|Sound/Audio:|Realtek ALC 882 chipset|
| |TV/FM Tuner:|Hauppauge WinTV HVR-1600|:||
[TR=“bgcolor: #d6e4f0”]
[TD] [/TD]
[TD=“colspan: 4”]Wireless Keyboard & Mouse with USB receiver/transmitter, Modem, Memory card reader, Network Integrated 10/100 Base-T, Wireless LAN 802.11 b/g, Remote Control - USB infrared remote and receiver[/TD]
[/TR]
[TR=“bgcolor: #ff9a88”]
[TD] [/TD]
[TD=“colspan: 4”]Even though it is not included in the name, the processor is Dual-Core. An “older” technology but still a Multi-Core. Does make it faster. (…yes I am proud of it.)[/TD]
[/TR]| |Printer:|HP cp1700 or HP 7520|Router:|NetGear RT311 WNDR3700|
| |Printer Server:|NetGear PS110|Switch:|NetGear GS108|
| |ETH0:|82801G (ICH7 Family) LAN|WLAN:|Atheros AR5413 802.11abg NIC|
| |:||:|

Now then, this works just fine with version 12.3. We have installed from a DVD thrice -and- even brought down a second copy, created another DVD and installed it. Also tried Re-Loading 12.3 and doing another UpDate. And last, but not least, we installed an nVidia driver - NVIDIA-Linux-x86_64-331.20.run - thought that might be the fix but it did not help.

We have had a ‘Terminal’ up and running although the initial startup was slow. Operations inside the Terminal were acceptable. It takes 20 to 30 secs for most of the operations to startup. We used ‘Dolphin’ and after an agonizing startup it worked fairly fast. We could change ‘Drives’ and ‘Directories’ and things looked almost normal. However, using the ‘Control’ at the top to add an Information Panel and then configuring it was another slow process.

When we first get to our Desktop -and- letting it settle, we click on the Orb and have to wait for a response. Then when the menu shows up, clicking on File Manager - takes almost 30 secs to get a response. Then when we click on the corner ‘x’ to close it we get “The app is Unresponsive - Terminate?” and we say yes.

Now selecting “System” in the Launch Panel and then “File Manger Super User” was a faster response. We got asked for the root password fairly quickly and the launch seemed to be a little faster. We have looked at the logs -but- nothing is jumping out at us… yet.

Oh, and it takes forever and ever for it to recognize a shutdown request.

Thanks,
Chuck

open a konsole and run top. See if some process is running taking all the CPU.

You mention dolphin so I guess you are running a KDE desktop so it may be a Nepomuk this is a file indexer and can get carried away. You can go into Configure Desktop - Desktop search and turn off Nepomuk. See if that helps.

Thanks… good ideas -but- no help at this time. Nothing appears to be hogging the CPU and turning off Nepomuk did nothing. So I turned it back on. In some cases it is not totally consistent and in others it is. Something is causing delays. Its like it is configured wrong… like the wrong machine or something. Just can’t put my finger on it.

I can click on Yast2 and get a quick response and then can look around in Yast2.

Thanks,
Chuck

If the process is not showing in top it has to be a kernel process. But I’d expect to see more people with the problem your hardware is not that exotic. Check the power setting maybe the CPU is running at a power saver rate???

If you have a spare hard drive sitting around, say some old (even a 40-gig will do, or even slightly smaller) retired-but-was-working HD, try removing all other drives, put this old drive in, low-level format it if you have the HD manufacturer’s tool or similar.

Then, try a fresh install of SUSE 13.1 just using the defaults, don’t bother with online updates yet.

Then, play around in this install and see if the symptoms are gone.

If they are still there, then you know it is something specific to 13.1

If they are gone, you know something is getting carried over that can probably be tracked down & fixed.

Good luck.

:slight_smile:

-fb

Have bounced back and forth between version 12.3 and 13.1. The “problems” are specific to 13.1 -or- KDE 4.11. This new systemd and the changes in the way things look has me a little befuddled. Is there a list somewhere of what services are supposed to be active and running in run level 5?? I don’t have them all memorized. Don’t look at them that often.:wink:

I do believe that something is either not running -or- something is running that shouldn’t. Had this problem once before or something similar to it. Seem to remember it being in KDE…??

Thanks,
Chuck

I have upgraded two computers today - going the way from 12.1 to 12.2 to 12.3 to 13.1 using “zypper dup” in the process. I recognize some of what the OP is experiencing. Here’s what I did to resolve it (from memory - there may be inaccuracies here, but you’ll see the priciple and I think that could be sufficient):

The speed problem:

  • I simply ignored it while making my adjustments. My speed problem wasn’t as notorious as OP is describing it, but the response was still “irky” and considerably slower than usual. I also knew from descriptions from my own and other’s betatesting that the “architecture” *) for handling network cards is new under 13.1, and manual corrections had to be made to resolve that - when upgrading. And true enough, after getting the network to communicate, the computers became as responsive as I knew them.

*) It’s not really a new architecture, but it is also much more than just new names on the network cards. However, to the user, it is the name change that is visible. I’m not native English, and “architecture” is the word I came up with while typing here that fit the most while also pointing to the fact that more than just a name had changed.

Adjusting the network-problems:

  • To put it simply, the new network card naming takes precedence over existing network card names, and the previous network cards remains in the configuration - but cannot be used anymore. All network cards are disabled. That seems to go for the firewall as well. I made my adjustments using ifup from within Yast.
  • The adjustments need at least two rounds in ifup: The first one to configure the new cards (those with the new names). All cards can be changed in one go. I used the old configuration from the old cards as template and copied it over one card at the time. Make sure to select a firewall zone manually for each card. After transferring all cards, make a note of the routing data (if any). Remove the old cards. Save the changes so the new cards with the new names gets activated.
  • Go back into ifup and make adjustments to the routing data so they incude the new cards the same way the old ones did. Save the changes, and activate the new configuration.
  • When I did my updating, the firewall ended up blocking all network communication - even after completing reconfiguration in ifup. So: Enter firewall configuration (I used Yast), and make sure it is activated at startup and that the configuration is saved. Check that the new cards are visible. They should be. Save the configuration and activate the firewall.
  • Now you can go back into ifup and change the names of the new network-cards if you would like to. I haven’t done that, so I do not know if such a change will necessitate corresponding adjustments elsewhere (e.g. in the firewall). I wouldn’t expect so, but it might.

Other problems experienced:

  • So far, I’ve only detected problems where I expected. (Those computers were VMs, so they are a little easier on the HW side that on-the-iron installations). Particularly the apache server and PHP, where I had made extensive tuning effort and adjusted them outside of Yast. So, of course, I need to dig into the new parametres and drop expired syntax to get what I want back on the air. A day or two will be sufficient for that, I hope.
  • The Grub-menu still displays version 12.3 in the menu items, but displays a 13.1 graphic (it’s a known bug). This can be corrected by editing text in the Grub files.

OP: Let us know how things progress. Good luck!

dayfinger

Edit: If you prefer Network Manager, you should be able to switch to that one after getting the computer to communicate.

@dayfinger – Wow… Wow!! I’ll have to digest that and get back to you…:expressionless: Don’t know which I prefer yet. This is a weird problem. But thanks for your dissertation.

Thanks,
Chuck

@dayfinger, Missed my ten minute interval so this is another reply. But … I don’t think your situation applies to mine. We did a FULL DVD Fresh Install and not an UpDate… on this latest try. So I don’t see how we could get a name conflict. IF that is so, then there is something drastically wrong with this 13.1 version.

Think we need to look elsewhere. -But- it does seem to look like the slowness is when we are accessing our drives and the Network. Can not get the Internet at all… except for OnLine UpDates??

Thanks,
Chuck

Apologies if I misunderstood an earlier answer.

If you are keeping an old /home, try logging as a new user and make them the default loggin. Do they have the same problem?

Also (this is speculative) try disabling pulse via YaST and restarting. Does the same slowdown occur with a disabled pulse audio?

Nope. Not keeping old home. This “latest” install was a FULL DVD Fresh Install. Just like Linux was never there.

Now then, this scenario “may” give someone some idea of what is missing or what is running and shouldn’t. We’re sure that something in ‘systemd’ -or- the new KDE 4.11 is the culprit. Just like the sound… the sign on jingle is disabled by default. Wondering what else is “disabled by default”. Thanks to petermcph and wolfi323 at:
https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/492543-no-music-jingle-boot

Now then, the scenario:

Click on the Gecko Orb, click on File Manager. Takes 28 secs for it to appear -and- another *51 secs before it fills in the info in the information panel on the right side. For a total of 1 min 19 secs just to bring up Dolphin.


HOWEVER IF… we got to “Applications”-> “System” → “File Manager” → “File Manager - Super User Mode” the operations are almost instant. Like they should be.

AFTER the “User” **Dolphin **is fully up, we can click on another Drive and it is displayed instantly… like normal. We can click on a text file and **Kate **pops up instantly. It was just the startup that was slow.

And we can NOT get on the internet with Firefox. It opens a blank window with a menu across the top and a **Tab **that has the activity circle that has stopped followed by the word “Connecting…”. Clicking on any of the Menu items does nothing. (We are now conversing from our Windows 7 Laptop.)

It is “ALMOST” normal -but- NOT quite.

Thanks,
Chuck

Your new speed description seems to be more equal to mine than your first description. Due to that, I suggest that you - until you get an idea yourself or from others that makes you beleive in it - concentrate on the communication problems. Return to the speed problem when you get online if it still persists. Chances are that it will disappear. I have experienced similar “irkyness” with other computers and other OS-es that could not communicate properly, so this is not unique to opsenSUSE (or Linux) in general nor openSUSE 13.1 in particular.

A little hairsplitting/nitpicking/semantics:

How fresh was it? Did you format the partitions completely prior to booting for install (or did you use a blank disk), or did the formatting happen during the installation - maybe even re-using partitions where 12.3 used to be installed? It is known that - in some cases - previous settings are picked up prior to the disk/partition formatting, thereby affecting the later configuration. If so, you actually could have some sort of “upgrade” even if you format everything during installation. If so, you could format your partitions and try again in order to gain “galvanic isolation” from the old 12.3 installation.

If that is not the issue, I think robin_listas’ suggestion is in order:

Given this output, someone may get an idea for what to look at, and there are some factual output to work from. (This is not to say your descriptions are unreliable, but there is a big difference between computer dumps and human semantic translations/filtering and to what we think is important or the issue at hand - always!) You may get follow-up questions, however before getting a useful answer. My experience is that if you give it a little time and communicate with the forums here, things do get resolved.

Another thought: If you can, try to disable as much HW as you can in the BIOS. Then retry installation. If that helps, try activating HW units one at a time until you hit the problem again. The first bit of HW I would enable after such a test, would be one of the networking cards. After all, you may have hit a new, unknown problem. We just don’t know yet.

Again, good luck!

dayfinger

Probably more than is wanted -but- maybe someone can come up with an answer -or- request more:nerd:.

ctaylor@dusty-tr2:~> /sbin/ifconfig
enp2s8 Link encap:Ethernet HWaddr 00:1A:92:51:75:A5
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21a:92ff:fe51:75a5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:570 errors:0 dropped:15 overruns:0 frame:0
TX packets:202 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:92358 (90.1 Kb) TX bytes:31080 (30.3 Kb)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:127 errors:0 dropped:0 overruns:0 frame:0
TX packets:127 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7500 (7.3 Kb) TX bytes:7500 (7.3 Kb)

ctaylor@dusty-tr2:~>

=========================================================================================================
kdm.log
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the “xorg” product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See GitPage for git access instructions.

X.Org X Server 1.14.3.901 (1.14.4 RC 1)
Release Date: 2013-10-26
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux dusty-tr2 3.11.6-4-desktop #1 SMP PREEMPT Wed Oct 30 18:04:56 UTC 2013 (e6d4a27) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.11.6-4-desktop root=UUID=91be147e-e9e3-477e-8206-40d8360e1658 resume=/dev/disk/by-id/ata-ST3750640NS_5QD34SB8-part8 splash=silent quiet showopts
Build Date: 06 November 2013 10:07:38AM

Current version of pixman: 0.30.2
Before reporting problems, check xorg
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Nov 26 19:31:35 2013
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
Loading extension NV-GLX
Loading extension NV-CONTROL
Loading extension XINERAMA
klauncher(1751) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(1698)/kdecore (KTimeZone): KSystemTimeZones: ktimezoned initialize() D-Bus call failed: “Not connected to D-Bus server”

kdmgreet(1698)/kdecore (KTimeZone): No time zone information obtained from ktimezoned
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Compat map for group 2 redefined
> Using new definition
> Warning: Compat map for group 3 redefined
> Using new definition
> Warning: Compat map for group 4 redefined
> Using new definition
Errors from xkbcomp are not fatal to the X server
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Compat map for group 2 redefined
> Using new definition
> Warning: Compat map for group 3 redefined
> Using new definition
> Warning: Compat map for group 4 redefined
> Using new definition
Errors from xkbcomp are not fatal to the X server

From the Services Manager:
dbus-org.bluez Enabled Inactive
dbus-org.freedesktop.Avahi Enabled Active
dbus-org.freedesktop.ModemManager1 Enabled Active

localmessages
2013-11-26T19:31:37.180229-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: dhcpcd 3.2.3 starting
2013-11-26T19:31:37.180881-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: hardware address = 00:1a:92:51:75:a5
2013-11-26T19:31:37.191134-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: broadcasting for a lease
2013-11-26T19:31:37.194341-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: offered 192.168.0.3 from 192.168.0.1
2013-11-26T19:31:37.311151-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: checking 192.168.0.3 is available on attached networks
2013-11-26T19:31:38.335160-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: leased 192.168.0.3 for 86400 seconds
2013-11-26T19:31:38.335765-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: no renewal time supplied, assuming 43200 seconds
2013-11-26T19:31:38.336243-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: no rebind time supplied, assuming 75600 seconds
2013-11-26T19:31:38.336670-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: adding IP address 192.168.0.3/24
2013-11-26T19:31:38.338545-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: adding default route via 192.168.0.1 metric 0
2013-11-26T19:31:57.679810-07:00 dusty-tr2 dhcpcd[1178]: enp2s8: exiting

Well it was to much info… boot.log in next message.

Thanks,
Chuck